Setup & Software Discussions
2017 15" MacBook Pro (RP555) [7th,4C,H] + GTX 1080 Ti @ 32Gbps-TB3 (Mantiz Venus...
 

2017 15" MacBook Pro (RP555) [7th,4C,H] + GTX 1080 Ti @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.13.4 & Win10 [external_user]  

  RSS

external_user
(@external_user)
Active Member
Joined: 2 years ago
 

System specs

Laptop: MacBook Pro (15-inch, 2017)

CPU: Intel Core i7-7700HQ CPU @ 2.80GHz

iGPU: Intel HD Graphics 630

dGPU: Radeon Pro 555

Operating system: macOS 10.13.4 Beta, Bootcamp Windows 10

 

eGPU hardware

Enclosure: Mantiz MZ-02 (VENUS)

Video card: MSI GeForce GTX 1080 Ti Gaming X Trio

Fan: Noctua NF-A8 ULN 80mm


Installation steps

Unfortunately I made a few photos.

Enclosure:

 

Replace standard 80mm fan with silent Noctua NF-A8 ULN 

It was very difficult because it was necessary to disassemble the enclosure. Fortunately the new fan has rubber connectors.

 

Insert the video card.

MSI GeForce GTX 1080 Ti Gaming X Trio is very large video card: 325 x 140 x 48 mm:

 

All specs there: 

https://www.msi.com/Graphics-card/GeForce-GTX-1080-Ti-GAMING-X-TRIO/Specification

So it was very hard to insert the card to the enclosure. I removed the back cover with the PSU, then I connected PSU chords with the card and then simultaneously I inserted the card and the PSU with back cover to the enclosure.


System setup

macOS 10.13 

I had macOS 10.13.3 and this guide worked well: 

https://egpu.io/forums/mac-setup/wip-nvidia-egpu-support-for-high-sierra/

After updating macOS to 10.13.4 Beta Web Driver was disabled. And these steps helped me: 

  1. Download the webdriver.sh file from here:   https://github.com/vulgo/webdriver.sh
  2. And run:

sudo ./webdriver.sh -cu http://us.download.nvidia.com/Mac/Quadro_Certified/387.10.10.10.25.156/WebDriver-387.10.10.10.25.156.pkg

sudo ./webdriver.sh -m

Windows 10

For Windows I used this guide:

https://egpu.io/forums/builds/mid-2017-macbook-pro-rp560-msi-gtx1080-gaming-x32gbps-tb3-mantiz-venus-macos-win10-wip/

It worked well. 


Benchmarks

Unigine Heaven Benchmark 4.0 on macOS 10.13.4

FPS: 116.0

Score: 2922

Min FPS: 35.0

Max FPS: 219.0

Also I played Overwatch on Win10 with ultra settings and 4k. And it was about 130fps. 


The desktop

This topic was modified 3 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined: 3 years ago
 

Hello,

I am getting the same fan. The mantiz venus fan is noisy!! I would like to know what is exactly the configuration you use. Are you using the ULNA?

Thanks

P.S: what is the monitor that are you using? Cheers.

mid-2017 Macbook Pro RP560 + MSI GTX 1080Ti Gaming [email protected] (Mantiz Venus) + macOS10.13 & Win10


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

which port your system fan plugged in ?

 

Mantiz: ● ●


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined: 3 years ago
 

@Mymantiz_John, In what port is supposed that we should connect it via ULNA?

mid-2017 Macbook Pro RP560 + MSI GTX 1080Ti Gaming [email protected] (Mantiz Venus) + macOS10.13 & Win10


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

both are ok, close to the TB3 port one is quieter.

Mantiz: ● ●


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined: 3 years ago
 

@external_user, how did you use installed it? Have you bought new screws? Cheers

mid-2017 Macbook Pro RP560 + MSI GTX 1080Ti Gaming [email protected] (Mantiz Venus) + macOS10.13 & Win10


ReplyQuote
external_user
(@external_user)
Active Member
Joined: 2 years ago
 

Hi, I connected the fan via u.l.n.a. connector. I installed it with the help of rubber brown mounts.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined: 3 years ago
 

What connector did you use? left or right?

mid-2017 Macbook Pro RP560 + MSI GTX 1080Ti Gaming [email protected] (Mantiz Venus) + macOS10.13 & Win10


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined: 3 years ago
 

Have you reversed the fan? with the letters label up or down?

mid-2017 Macbook Pro RP560 + MSI GTX 1080Ti Gaming [email protected] (Mantiz Venus) + macOS10.13 & Win10


ReplyQuote
external_user
(@external_user)
Active Member
Joined: 2 years ago
 

@ed_co, I use right connector. The fan blow from top to bottom (with the letters label down).

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Sam.mcbride
(@sam-mcbride)
New Member
Joined: 10 months ago
 

Hi! I have the exact same set up, but my question is, can you run this script on Mac OS Mojave? or does it have to be done on high Sierra 10.13 (I already updated and don't really want to backtrack unless its necessary)

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote