2017 15-inch MacBook Pro RP560 + [email protected] (Mantiz Venus) + Win10 [Lacin]  

  RSS

Lacin
(@lacin)
Active Member
Joined: 2 years ago
Posts: 16
July 15, 2017 11:25 am  

Hello everyone,

I've just implemented my eGPU setup and am quite pleased with it. The implementation was as smooth as it could be, it was almost plug & play so not much to tell really but here are the steps I took;

  • Installed latest Win 10 Enterprise through Boot Camp, no version awareness here just used latest ones.
  • Plugged in and turned on Mantiz with GPU (980Ti), Sata connected 256 Gb SSD, USB connected 1 TB external drive, 4k monitor and USB connected keyboard & mouse.
  • My MBP was off but once I hit the power button on Mantiz it automatically booted up. Windows recognized all the devices connected to the Mantiz except 980Ti so I just went to device manager and clicked update driver and voila. After a brief driver installation my 4k monitor received signal and started working.

I scored 4300 on Time Spy with 980Ti on external monitor VS 1500 without eGpu on internal screen with RP560. I've also played Mass Effect Andromeda on 4k high settings with no issues.

The only problem I had was with Mantiz internal fan that seems unbearably loud. I cannot believe how they could possibly consider using such a loud fan for such a quality product but it is easy enough to replace with a quiter one I suppose, so no worries there. But I would love to receive silent fan replacement suggestions from you guys.

That's it. It was almost plug & play as I said. I will probably need some hacking to drive internal screen with onboard intel graphics for more efficient power use and saving some pcie but I am content for now with just turning off internal display.

I would like to thank @nando4 for suggesting this eGPU setup for me on this thread.

Cheers.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1814
July 15, 2017 11:34 am  

Lacin, thank you for posting your implementation. Would you mind including a CUDA-Z performance run? I'd like to confirm bandwidth against the reference table to confirm your Venus' firmware is not H2D performance affected.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
Lacin
(@lacin)
Active Member
Joined: 2 years ago
Posts: 16
July 15, 2017 12:10 pm  

Cuda-Z seems to give varying results depending on load. Here's what it shows when GPU is idle;

And here it's under load (Time Spy Benchmark);

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1814
July 15, 2017 12:27 pm  

Lacin, the idle results are less than expected. Mantiz_John alludes to awaiting Intel certification of an updated firmware in the Mantiz Venus thread which will to give > 2000MiB/s CUDA-Z host-to-device. Then the Venus bandwidth will match the AKiTiO Node.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
Lacin
(@lacin)
Active Member
Joined: 2 years ago
Posts: 16
July 15, 2017 12:41 pm  

Thanks for letting me know. I will hold off upgrading my video card then. The extra horsepower will probably be wasted if I don't have the bandwidth to carry it out.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
pewpewfish
(@pewpewfish)
Active Member
Joined: 1 year ago
Posts: 8
July 18, 2017 9:42 pm  

Hi there, how does your setup look like? I'm wondering because I was hoping to use my potential MBP with its lid closed, but I fear the heat from the laptop may damage the screen like the Razer Blade.

Also, if you have the time, would you be able to post any benchmarks of the RP560 please and thank you?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 2 years ago
Posts: 276
August 3, 2017 8:35 pm  

Tomorrow my Mantiz and my Macbook Pro 2017 arrive. I hope I get a clear instalation process like you had. This guy  https://egpu.io/forums/builds/2017-macbook-pro-15-bootcamp-win-10-akitio-node-r9-380/ just had more issues because he was running an AMD card right? I have a 1080ti and I really hope no hack is needed on bootcamp.

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1097

ReplyQuote