2017 15" Macbook Pr...
 
Share:

2017 15" Macbook Pro RP560 + @ [email protected] (Razer Core X) + Windows 10 1803 + [diego]  

  RSS

diego
(@diego)
New Member
Joined: 1 month ago
Posts: 2
March 24, 2019 6:47 pm  

System specs

2017 15" Macbook Pro RP560 Touchbar
i7-7820HQ @ 2.9 GHz
Windows 10 Home 1083 Bootcamp
Old 1920 x 1200 24" Samsung Monitor with DVI-D connection. Nothing special.

eGPU hardware

Razer Core X ( https://www.amazon.com/gp/product/B07CQG2K5K )
eVGA RTX 2070 Black ( https://www.amazon.com/gp/product/B07J9L4HC2 )
TB3 3 meter Active Cable ( https://www.amazon.com/gp/product/B074JZVD2M )

Hardware pictures

Nothing fancy or pretty so leaving these out.

Installation steps (what did you do to get it all going?)

  • Install GPU into Razor Core X
  • Power Razer Core X
  • Boot into windows
  • Connect Razer Core X via TB3 to Macbook Pro
  • Install latest Drivers (419.35 March 2019 WHQL)
  • Reboot a few times with TB3 Cable connected (more than once because there seemed to be some setup and strange behavior at first in windows but my external display always booted up fine and allowed me to login and restart)
  • Plug into different usb-c ports on the macbook as needed . Some seemed more sluggish or unresponsive than others including with my other peripherals via a usb-c hub
  • Game away

Benchmarks

cuda-z
https://ibb.co/k5MxC55

valley
https://ibb.co/fdTY1RS

timespy
https://ibb.co/HBJLcsx

Comments
After reading a few builds I was concerned about all the setup that would be involved including hot plugging, separate EFI partition, scripts etc.

For whatever reason is was all plug-n-play for me minus a few reboots while windows installed various things and settled down. By settling down I mean that there were some weird font issues and more setup behind the scenes that seemed to happen after all the nvidia drivers were installed.

At one point I had to test the tb3 cable on different ports because of sluggishness until I found one that worked great. Same went for my usb hub dongle which connected my external keyboard, mouse, and ethernet cable.

I hope my build can encourage others that this setup is becoming more stable/easier. Not sure if it was so stable because of the RTX 2070, Razer Core X, Macbook Pro or maybe the entire combo but happy with the results and appreciate all the builds by others here.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


Quote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1443
March 25, 2019 7:36 am  

From what I have read the 2017 and 2018 15 inch MBP's are the easiest to set up, especially with Nvidia cards so by chance you bought a very simple solution, congrats!
A lot of the guides/issues you hear about are from 2016, the 2016 15inch is a different machine set up wise and can be a bit of a pain.

Oh, and I'd love to see some set up pics!

This post was modified 1 month ago

2017 13" MacBook Pro Touchbar + [email protected] (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + [email protected] (Sonnet Breakaway Box) + Win10

2017 13" MacBook Pro Touch Bar + GTX1070 (debating 2070 upgrade) @32Gbps-TB3 (Razer Core V1) + Win10

2017 13" MacBook Pro Touch Bar + Vega 56 @32Gbps-TB3 (Razer Core V1) + Win10 & macOS 10.14+

---
LG 5K Ultrafine flickering issue fix


OliverB liked
ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 6 months ago
Posts: 1050
March 25, 2019 8:21 am  
Posted by: diego

After reading a few builds I was concerned about all the setup that would be involved including hot plugging, separate EFI partition, scripts etc.

For whatever reason is was all plug-n-play for me minus a few reboots while windows installed various things and settled down.

This is exactly what I am talking all the time. Here on this site there are many guides and reviews that a confusing and plainly wrong today. People are getting the false impression at it would be very difficult to set up eGPUs especially in Bootcamp. It is not.

There are some difficulties like nVidia for MacOSX, or mixing AMD dGPU and eGPU in Bootcamp, but that's not what is being addressed mostly.

This old Bootcamp guide is rather misleading and should be updated.

Posted by: Eightarmedpet

From what I have read the 2017 and 2018 15 inch MBP's are the easiest to set up, especially with Nvidia cards so by chance you bought a very simple solution, congrats!
A lot of the guides/issues you hear about are from 2016, the 2016 15inch is a different machine set up wise and can be a bit of a pain.

Oh, and I'd love to see some set up pics!

True, it looks like the 2016 15-inch is a problematic one, but it looks as the only one, because the 2018, 2017 models are not and the 2015 is not either.

@eightarmedpet, you are having a 15-inch 2016 MBP, aren't you? You were facing Error 12, am I correct?

Did you try my New Bootcamp Build Guide? With a newer Windows version? Because I am guessing the Error 12 might not an issue anymore even with this model.

This post was modified 1 month ago

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1443

ReplyQuote
(@james_paola)
New Member
Joined: 1 month ago
Posts: 1
March 26, 2019 2:13 am  

I have the same MBP model and I was looking at getting the exact same setup, that EVGA 2070 with the dvi-d port for my old 120hz monitor and Razer core x.
I was a bit hesitant going down the egpu path after looking at a few of the other threads mentioning hot swapping etc. so it's good to hear you didn't have any issues after the initial install.
Appreciate the effort you put into the post, cheers!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


diego liked
ReplyQuote
diego
(@diego)
New Member
Joined: 1 month ago
Posts: 2
April 4, 2019 2:26 am  

I'm really happy to hear my post is helpful and encouraging! A week plus in, I'm enjoying my setup and have no regrets. Thanks gang!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote