2017 27" iMac 5K (RP580) [7th,4C,K] + RX Vega 64 @ 32Gbps-TB3 (Razer Core X) + W...
 
Notifications
Clear all

2017 27" iMac 5K (RP580) [7th,4C,K] + RX Vega 64 @ 32Gbps-TB3 (Razer Core X) + Win10 & macOS 10.15.4  

  RSS

dwalster
(@dwalster)
New Member
Joined: 2 years ago
 

I wanna keep this as straight forward as possible. However, please understand that I might have to explain some details and thought processes of mine that might be helpful to make up some clues on why this exactly worked and how we can learn form this for the future. Like this, maybe all that time I wasted wasn't for nothing. First of all I wanna get something out there clearly:

Don't consider this setup if you primarily want to use Win 10 with it.

I's no secret that AMD eGPUs are hard to get running under Windows 10. However, especially this configuration being an iMac with only two TB3 ports and a fairly powerful dGPU means more harm than good.

 

System specs

  • 2017 27" iMac 5k, maxed out (i7 7700K, Radeon Pro 580)

eGPU hardware

  • Razer Core X (non chroma)
  • Sapphire Nitro+ Radeon RX Vega 64
  • Belkin Thunderbolt 3 5A Kabel (2 m)
  • external 144Hz WQHD Monitor (MSI)

 

Installation steps

macOS:
Since on macOS every AMD card works plug-n-play this one does no different.

Windows 10:

It's was a nightmare. Success seems completely random. You need to achieve a weird combination of Windows Version and bootcampdriver.com driver. When I will be referring to "combinations" in this post I'm talking about Windows and Graphics drivers.

Let me tell you: I did at least 10 Windows reinstalls, tested several versions of the bootcampdriver.com recent optimized drivers and followed probably every single guide on here to overcome error 12. 

That being said, I'm almost certain that there is probably a better "combination" that also works but I'm so glad that I actually am at this point right now that I won't dare touching it ever again.
The frustrating part is that I can't be sure if a driver failing for me when testing was a reproducible behavior or not. This means that the combination I found now to be working could just be a random success / that a combination I tested before could have potentially worked if I tried again. I fear this to be the case because most of the time when the drivers were installing it was a very close-run thing between the system muddle through or crashing sometimes corrupting the whole installation.

What I want to point out with this is that the "sweet spot" where everything is (suddenly) working stable is apparently extremely picky, resulting in your system either working perfectly fine (like I have achieved now) letting you question yourself and if all the hassle before actually happened or making your windows installation fully unusable. The worst is that I can't make out any aspects that separate this combination from others I have tried.

That being said, always create restore points when trying to figure out a better driver combination, maybe this one doesn't even work for you and you need to do so.

Stuff I tried (read this to understand, don't follow along yet)

  • Every time starting from scratch. Fully reinstalling windows using bootcamp. 
    Disclaimer: I did a few things that may or may not be necessary. I would be so glad if anyone tried to follow this guide initially excluding them. You will maybe understand why shortly.
  • During most of the attempts I let the bootcamp installation program work as intended by Apple when booting windows the first time, meaning it installed every driver (including graphics) causing me to use DDU when trying a combination as a side effect.
    • for those attempts (when I still let bootcamp installer do it's thing) I tried Windows 10 1903 (V1), the insider preview that seems to fix the problems introduced with later Windows version for some, and later 1803.
    • I used several releases from bootcampdrivers.com to get the Radeon software that includes the XConnect technology required for eGPUs installed
      (please correct me if I'm wrong, but I assume that it isn't possible to solely install the Vega 64 driver manually through device manager since the Xconnect part would be missing then, right? When installing it this way the AMD Control Software would be missing that includes the Xconnect, at least that's how I'd guess. Please someone verify this!)
    • Regarding bootcampdrivers.com I tested the 2020 releases, namely Red Gaming edition and blue enterprise edition, 2019 (iMac 4k & 5k) November edition (blue), August Edition, September Edition and a few 19.xx.x ones until I gave up. It either crashed completely not even getting the internal graphics to work or managed that part but created error 12 for the Vega 64, even when disabling the dGPU

Steps that got it working

  • After that, I tried on last thing. And since it suddenly worked after all that hassle I can't and don't want to verify what thing that I changed actually was responsible for it to finally work. It simply would take too much time and I'm afraid to loose my setup again. If someone want's to switch things up and verify if the following points make any difference or not, I'm really curious. I'm fairly confident that for those who don't want to get scientific these steps will most likely work. Probably the right driver version from bootcampdrivers did the thing.
    • Freshly installed Windows 1803 (it potentially works with 1903 V1; didn't try, PLEASE try it yourself using the 18.2.2 driver as described below since I think this is the crucial thing I changed!)
    • Disabled Windows Update fully.  I didn't want to take any risk. You do this by either disabling the "Windows Update" Service in the "Services" pane or following a tutorial regarding managing windows updates with Group Policy Editor.
    • Interrupted the bootcamp drivers installation, meaning that no graphics driver has been installed (maybe necessary, can't tell since it was the only attempt where I did this and it worked right away).
      • Installed chipset, management and ethernet drivers manually.
        Disclaimer: You can find those on the partition apple creates for installation that gets deleted after first boot. Copy the folder or if you already rebooted, you can download the drivers folder with the bootcamp app on macOS manually.
        Important: It seems that Apple has actually released whole new bootcamp drivers during the last days! This results in most of them not being available for manual install anymore (the folders are still there but no executable file for installation, maybe someone can enlighten me about this if you actually still can). However, maybe this whole "cancel apples driver installation step" just turns out to be irrelevant and we can simply ignore this. I backed up the old driver folder though and was able to manually install those remaining drivers later after I surprisingly got it to work. PM me if you need those.
    • Used this bootcampdrivers.com release: 2019 --> for iMac 4k / 5k --> Adrenalin 18.2.2 XG (best for overclocking)
      • I'm fairly sure this is actually the important detail that makes the difference: The driver version. A while back I already got this setup up and running also using an 18.x.x version that was even older and isn't available for download on the site anymore. I think it's worth to note that I also skipped Apple's driver installation at that time, that's why I'm incredibly uncertain now if it actually helps or not. Back then, I made the stupid decision to update windows and it crashed during the update process. After that, I couldn't remember which bootcampdrivers release I used before and started to try the newer driver releases as described above (which probably was the reason I didn't got it to work). But since so many people seemed to have success with the newer drivers I simply couldn't imagine that this was the culprit - but apparently it was. Again, I'm really curious if only this working driver is sufficient to get it to work or if the other steps are also necessary.
      • Installed the driver with eGPU plugged in. Use the Thunderbolt port next to the ethernet port. Make sure not to hot plug eGPU, do a fresh boot with it turned on and plugged in. No GPU-drivers were installed before so I didn't use DDU. Both the dGPU as well as the eGPU were showing up in Device Manager at that point. So I had the eGPU turned on during installation which went fine without errors or suspicious behavior. I did a reboot, but the eGPU wasn't showing up as Vega 64 while the dGPU was now labeled as Pro 580. I conclude that the 18.2.2 didn't include the Vega 64 drivers back then (the recent ones do I think). To verify if this really was the case, I ran the installer (18.2.2) a second time, this didn't produce any errors but the eGPU's labeling remained the same.
    • Downloaded the latest Vega 64 drivers form AMDs official site. 
      • Ran the installer so that it would unpack it's files into an "AMD"-Folder at C://. Of course, it told me that no suitable hardware was found and the installation "failed". That's normal.
      • Opened Device Manager and navigated to the Vega 64 still labeled as "Basic Display Adapter". Searched for drivers manually and selected the just mentioned AMD folder as source. Installation went fine. I disabled the dGPU in device manager and rebooted.

eGPU was working fine now, consistent results. Internal screen also works but just under basic display adapter. I disable it using WIN+P. 

However, once I got a blue screen on login screen. I already assumed something was going one since the login screen did appear on internal monitor on that boot rather than on the external. That's where it freezed and finally crashed.

Normal behavior would look like this:
Boot with windows logo on internal screen. Login screen appears on internal screen first, then glitches to external monitor. When logging in, extended desktop mode is frustratingly always enabled so I have to select only external monitor every time using WIN+p manually.

 

Hardware pictures

 

Like I mentioned multiple times, this took me a lot of time to figure out. So that it wasn't completely for nothing, I wanted to share my findings. Technically I'm really interested in which points you needed to follow to make it work for you. There are many question marks in my head right now and it would be awesome to see if the 18.2.2 also works on a newer windows version, if the "driverless" installation is really necessary, what bootcamp release also worked for you etc.

Please leave your thoughts below. Thanks for reading and I hope I have helped someone out there!

This topic was modified 6 months ago
2017 27" iMac 5K (RP580) [7th,4C,K] + RX Vega 64 @ 32Gbps-TB3 (Razer Core X) + Win10 & macOS 10.15.4 [build link]  

ReplyQuote
Gg Gg
(@gg_gg)
New Member
Joined: 6 months ago
 

Thanks for this. I have been struggling with my 5700 for 2 days non-stop working on it now.

 

I've been using the latest insider build - everything is plug and play until it starts installing drivers; after which i get my internal screen going black and my eGPU screen going black. I can get into safe mode and DDU the drivers and boot back in, but allowing the drivers to install (or using the latest bootcampdrivers.com drivers) causes the same black screen issue. I'll try the version you reccomended and see if it resolves it.

 

2015 MBP with M370X. AMD 5700 in Sonnet 350

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
dwalster
(@dwalster)
New Member
Joined: 2 years ago
 

@gg_gg, Hey, let me know if it worked:)

But I think since the 2015 MBP is Thunderbolt 2 this is very hard to compare...

 

2017 27" iMac 5K (RP580) [7th,4C,K] + RX Vega 64 @ 32Gbps-TB3 (Razer Core X) + Win10 & macOS 10.15.4 [build link]  

ReplyQuote
Gg Gg
(@gg_gg)
New Member
Joined: 6 months ago
 

@dwalster ( @goalque for knowledge exposure)

So I Mostly followed the guide... As I mentioned, I am on the latest insider build. Everything works great!! Full success on 2015 MBP with the M390X dGPU. Using AMD 5700 in Sonnet 350; TB3-TB2 adapter from Apple.

I followed all the steps exactly but before starting I installed build 1903v1 and then updated it to Windows Insider using the latest FAST RING build (slow ring did not work for me. I am on build 19608 released April 15th 2020). Using rEFInd to boot allows me to keep the Intel iGPU enabled. Do not connect to the internet yet! I did not install the standard Apple BootCamp Drivers package - instead, I went through the "WindowsSupport" folders and installed every non-GPU driver manually by clicking on each. Then I installed bootcampdrivers.com version Adrenalin 18.2.2 XG (Best for OC'ing) without any issues (put it on a USB with the official bootcamp drivers). After installing these, you should connect to the internet.

After connecting, the computer automatically installed the Intel Iris 5200 drivers along with many other driver updates. THE INTEL iGPU DRIVER IS WHAT BREAKS THE SETUP BUT LET IT FINISH INSTALLING ALL DRIVERS UPDATES! After these auto-installed, the internal screen would not work AT ALL.  On a reboot I would be able to use the eGPU with no issue on my external monitor, but the internal screen would remain frozen or black and i could not access it. To resolve this and restore the ability to use the internal screen; here is what I did:

Boot normally (cold-plug) using eGPU monitor as your only monitor. You won't be able to access the internal screen now. Perform the following edits:

1) Control Panel -> System -> Advanced -> hardware -> disable auto install drivers.

2) Services -> Windows Update - Disabled.

3) Group Policy Editor -> configure windows update -> disabled.

4) Settings -> Windows insider -> stop getting new builds

4) Turn off wifi using normal tray icon

5) boot into safe mode

6) DDU all Intel Drivers

7) Reboot

At this point if you boot with your eGPU connected, your eGPU monitor will be considered the considered the computer's "PC Display" and Main Display. Your internal display will freeze or go black. You can do WINDOWS+P (CMD+P on our keyboard) to switch to Duplicate the video signal - allowing you to use the internal screen once again; though it is considered the 'external display.'

Booting with no eGPU connected (desirable as well for me so i can easily use FORScan) enabled the internal screen using the Microsoft Basic Display Adapter. You wont get ANY internal screen settings, not even brightness or resolution by nature of the missing drivers, but the screen will work!

Thank you very much @dwalster for your well written and informative guide; I would not have been able to do this without it. I hope others find this useful as well. Anyone - Feel free to tag me in a reply and I'd be happy to follow up.

This post was modified 6 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
dwalster
(@dwalster)
New Member
Joined: 2 years ago
 

@gg_gg, I'm so glad this was able to help someone, thank you for sharing!

Thank you for the information regarding the insider build. When I find time in a few weeks I may also test it on my system.

It's a little pity though that you didn't try to get it working by normally installing the standard apple BootCamp Drivers package on the first try to check if it would also work like that, after uninstalling all graphics drivers that the apple installer put on the system at that point.

Posted by: @gg_gg

After installing these, you should connect to the internet.

After connecting, the computer automatically installed the Intel Iris 5200 drivers along with many other driver updates. THE INTEL iGPU DRIVER IS WHAT BREAKS THE SETUP

So If I understood you right, you could just have prevented this by disabling auto driver install before connecting to the internet, right? I was a little confused when reading your reply because you mentioned one "should connect to the internet" already.
Btw. there's a feature in DDU that lets you disable automatic driver installation:)

Further, did I get it right that you didn't have had to install the 5700's own driver manually? Did everything work already only after installing the 18.2.2 from bootcampdrivers? I personally had to manually install the Vega 64 drivers.

One last question: You mentioned that you installed the drivers in the WindowsSupport folder manually. As I stated in my post, there seems to have been a change in the last two weeks of how apple handles the driver installation. If I download the most recent "WindowsSupport" folder via Bootcamp, all the files in "Broadcom", "Asix" etc. are not executable anymore. Luckily, I saved an old "WindowsSupport" instance where in every folder lay scripts you can manually execute, like you described.
So either that "update" doesn't apply to the old MacBooks or the MacBook line in general or it's something else. Would be very interesting to know.

Thats it, thank you and stay safe!

 

2017 27" iMac 5K (RP580) [7th,4C,K] + RX Vega 64 @ 32Gbps-TB3 (Razer Core X) + Win10 & macOS 10.15.4 [build link]  

ReplyQuote
Luigi Filice
(@luigi_filice)
New Member
Joined: 2 months ago
 

hi I have a Core X + Asus Radeon vega 64 + a MacBook Pro 15 2019 and when I connect core X to the computer with Thunderbolt 3 it tells me that I have no video card to deactivate,
I tried several ways to fix this from both macOS and Window with bootcamp but most of them worked ....
What should I do to connect the video card inside core X to the computer? thx!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote