Setup & Software Discussions
2017 27" iMac 5K (RP575) [7th,4C,K] + RTX 2070 @ 32Gbps-TB3 (AORUS Gaming Box) +...
 

2017 27" iMac 5K (RP575) [7th,4C,K] + RTX 2070 @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 [rasmusb]  

  RSS

rasmusb
(@rasmusb)
New Member
Joined: 4 months ago
 

System specs

[System]: Apple iMac (Retina 5K, 27-inch, 2017)
[OS]: Windows 10 (via Bootcamp)
[CPU]: Intel Core i5 3.5 GHz
[GPU]: AMD Radeon Pro 575 4GB
[RAM]: 40GB DDR4
[eGPU]:AORUS GAMING BOX GeForce RTX 2070 8GB GDDR6

eGPU hardware 

AORUS GAMING BOX GeForce RTX 2070 8GB GDDR6

Installation steps
Almost plug'n'play with WIN10, had the eGPU disconnected until windows was fully loaded then I connected the USB-C cable and turned on the power. Windows recognised the eGPU as "Microsoft Basic Display Adapter" in device manager. I downloaded the latest drivers from Nvidia and right clicked on the "Microsoft Basic Display Adapter" to be able to install the drivers manually. After a restart with the eGPU unplugged and powered off I reconnected the eGPU, powered it on and it was 
recognised as Nvidia Geforce RTX 2070

Since I am only going to be using the eGPU for Octane Render I haven't tested the internal or external monitor, but the eGPU works fine with RTX Octanebench 2019 Preview and Cycles for Blender. See Octanebench results below.

Benchmarks
Octane version:
2019

Operating system:
Windows 10 64-bit

Devices:
GeForce RTX 2070, 8 GB , RTX √

Total score:
542.826603 (RTX speedup: 2.866170X)

RTX On (542.826603 OB)
Scene, Kernel, Ms/s, GTX980 Ms/s, Ratio, Weight, Score
Havana (by Geoff Holman), path tracing, 29.418660, 5.69, 5.170, 50, 235.245878
Havana (by Geoff Holman), direct lighting, 43.678426, 7.67, 5.695, 40, 209.565328
Havana (by Geoff Holman), info channels, 124.605712, 12.84, 9.704, 10, 98.015396

RTX Off (189.390915 OB)
Scene, Kernel, Ms/s, GTX980 Ms/s, Ratio, Weight, Score
Havana (by Geoff Holman), path tracing, 11.428134, 5.69, 2.008, 50, 91.384899
Havana (by Geoff Holman), direct lighting, 15.942558, 7.67, 2.079, 40, 76.491023
Havana (by Geoff Holman), info channels, 27.351734, 12.84, 2.130, 10, 21.514993

This topic was modified 3 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


itsage liked
ReplyQuote
pilotflying320
(@pilotflying320)
New Member
Joined: 1 week ago
 

Hello! Thanks for sharing your setup! I am planning to build my own, almost same to yours, but with iMac 4k (RP560). And I have 2 questions: 

1. Which windows 10 version did you use, 1809 or 1903? 

2. Should I install AMD Driver from bootcampdrivers.com or I can use default one (from apple drivers) ? 

Thanks in advance!!! 😉 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote