Setup & Software Discussions
2017 13" Dell XPS 13 9365 [7th,2C,Y] + GTX 970 @ 16Gbps-TB3 (AORUS Gaming Box) ...
 

2017 13" Dell XPS 13 9365 [7th,2C,Y] + GTX 970 @ 16Gbps-TB3 (AORUS Gaming Box) + Win10 [jc2222]  

  RSS

jc2222
(@jc2222)
Active Member
Joined: 2 years ago
 

System specs (model inc screen size, CPU, iGPU, dGPU, operating system)
2017 Dell 9365 13"
1080p screen
7th-gen i7-7Y75
no dGPU
Win 10 64-bit

eGPU hardware

eBay Aorus Gaming Box, no GPU
OEM 0.5m Thunderbolt cable
eBay Asus STRIX GTX 970 (broken fan)
PCIe 16x riser cable
8-pin power extension cable

riser_cable_1

Installation steps

  1. Opened up enclosure, connected GPU with riser cable and power extension cable
  2. Downloaded and installed Nvidia drivers
  3. Reboot

When rebooting with eGPU attached BIOS complains about incompatible USB-C device.

Benchmarks
benchmark_1
Heaven Score: 1385
cuda_z_1
CUDA-Z 1150.75 MiB/s

Comment
I tried updating the TB3 firmware with the utility provided by Gigabyte but it cannot detect the device. Is this possibly caused by using a different GPU?

This topic was modified 5 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 3 years ago
 

@jc2222 , thank you got your submission. The picture links are broken so cannot see your CUDA-Z H2D values.  Did you want to repost them?

@itsage did confirm your XPS 9365 has a 4-lane TB3 controller here so your upper limit would be 32Gbps-TB3 bandwidth.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

15" Dell Precision 7510 (Q M1000M) (6th,4C,H) + GTX 1080 Ti @ 32Gbps-M2 (ADT-Link R43SG) + macOS 10.13.6 & Win10


ReplyQuote
jc2222
(@jc2222)
Active Member
Joined: 2 years ago
 

I rehosted the images, updated opening post.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
jc2222
(@jc2222)
Active Member
Joined: 2 years ago
 

After reading some more and downloading the correct firmware, Host to Device is now 1598 MiB/s:
cuda_z_2
My next steps are replacing the GPU fan and looking into a custom enclosure.

The cable I have is (I'm assuming) the OEM 0.5m cable provided with the Aorus Gaming box and it does have a 3 printed on each end, indicative it's a 40Gbps cable.

All of the above benchmarks have been with the internal screen and I don't know how much that affects the performance.

Update: why bandwidth is lower-than-expected

The lower-than-expected bandwidth numbers are due to the Dell XPS 9365 running a 2GT/s rather than 4GT/s OPI here.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote