2016 17" HP ZBook 17 G3 K3000M + Titan [email protected] (AKITiO Node) + Win 7 [burhop]^  

  RSS

burhop
(@burhop)
Active Member
Joined: 1 year ago
Posts: 6
October 5, 2017 3:48 pm  

I've got an HP ZBook 17, Akito Node and a NVidia Titan XP.   The HP ZBook also has an NVidia Quadro 3000M

Out of the box,  I get the infamous error 12 for the Titan XP driver.   There is a HACKFLAGS registry setting I found here on the Microsoft that allowed it to load and start working (whoo hoo!)  but only at the cost of breaking:

  1. Second SSD Drive -  There is now a driver error.  Interestingly, the SSD dies when I plug in the TB3 with the Titan.
  2. All USB devices on the TB3 HP doc (video ports and power kept working)
  3. Logitech wireless mouse driver dies.
  4. Fan runs all out all the time.

So, the HACKFLAGS thing, like its name implies is a hack 🙁

I uninstalled all Nvidia drivers and started from scratch.  No change.  All HP drivers were updated too (BIOS, TB3, etc.).  I removed the dock from the equation (no change).

I'm now looking though other posts but no joy.  For those with zbooks following in my footsteps, here are at least a few posts that might help you.  I'm guessing my issue is wit the Titan XP.

switch  has a good post here on his zbook 15

delmar has another post here for his zbook 15

Anyone else have ideas on what to try next or URLs on what to try next?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


nando4 and theitsage liked
ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1815
October 6, 2017 2:20 am  

The ZBooks tend to have a BIOS option where you can:

1. enable/disable Nvidia Optimus: the software runs a iGPU+dGPU arrangement, the latter runs just a dGPU arrangement
2. set or unset Thunderbolt security.

@Yukikaze had good on a Zbook G2 by disabling Optimus in the BIOS and just allowing the Nvidia eGPU to use the Quadro drivers. Then could get maximum GPU performance from both. If Optimus is enabled then there is an anomoly with a iGPU+Quadro+Geforce drive conflict where disabling the Quadro allows the Geforce to work.

As for error 12, I found disabling, then enabling the eGPU's TB PCIe upstream and downstream bridges fixed the problem. Please try this:

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
burhop
(@burhop)
Active Member
Joined: 1 year ago
Posts: 6
October 16, 2017 4:51 pm  

Thanks, nado4.  I think I have a newer version of the ZBOOK as I don't have anything that mentions Optimus.  There is a bios graphics options I can set to Hybrid/Auto/Off and I've tried all 3 with no change.

On the Device manager, I don't have anything that says "upstream" or "downstream".  They all say "PCI standard PCI-to-PCI bridge" under the PCI Express Root ports. I tired disabling various combinations similar to what you showed but still no luck.

I did turn the HACKFLAGs option on and saw that when the card is working, it is at IRQ 17 with 3 PCI standard PCI-to-PCI  bridge" connections and 1 PCI Express Root Port #2 A111.   I tried disabling anything extra in IRQ 17 in the non-working mode but still didn't have any luck.

 

 

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Yukikaze
(@yukikaze)
Prominent Member Moderator
Joined: 2 years ago
Posts: 832
October 16, 2017 5:07 pm  

I am currently running a ZBook 15 G4 albeit with Win10 (signature has link for the setup), and for what it is worth, the eGPU was completely painless. You mention a TB3 dock: How are you connecting everything together? The eGPU is behind the dock, or is the dock connected to the second TB3 port? Try to not use the dock temporarily, does it make things better (I run a USB hub for peripherals and use the TB3 only for the eGPU, so that might be a hint).

Any reason why you aren't upgrading to Win10? It has much better eGPU support.

My eGPU Zoo - Link to my Implementations.
Want to output [email protected] out of an old system on the cheap? Read here.
"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."


ReplyQuote
burhop
(@burhop)
Active Member
Joined: 1 year ago
Posts: 6
March 8, 2018 2:51 pm  

Hi Yakikaze, Sorry for the late reply... I just upgraded to Windows 10 and you are right, this seems to be the way to go.

The only problem is  I had to disable the Quadro M3000M on the laptop  to make the Titan fan quiet. If I turn on the PCIe Controler via the device manager (which has the NVIDIA Quadro M3000M and Driver version 23.21.13.9101) everything works except the Titan Xp fan runs all out.

Posted on the NVIDIA forum but no love there so far 🙁   https://forums.geforce.com/default/topic/1039561/geforce-drivers/loud-fan-with-two-video-drivers-gt-titan-xp-windows-10-quadro-m3000m-on-hp-zbook/ )

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Yukikaze
(@yukikaze)
Prominent Member Moderator
Joined: 2 years ago
Posts: 832
March 8, 2018 3:57 pm  

Couldn't you use something like MSI Afterburner to control the runaway fan and define a user fan curve?

My eGPU Zoo - Link to my Implementations.
Want to output [email protected] out of an old system on the cheap? Read here.
"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."


ReplyQuote
burhop
(@burhop)
Active Member
Joined: 1 year ago
Posts: 6
March 9, 2018 6:26 pm  

I gave that a try. No joy 🙁

It seems to ignore whatever fan speed I tell it to use if the M3000M is enabled (I made sure I grabbed the right GPU).  If I disable the M3000M and reboot, MSI Afterburner works just fine in controlling the fan.

I can get both cards working with a quiet fan if I turn off the M3000M, reboot, then turn on the M3000M after the Titan Xp is up and running.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
burhop
(@burhop)
Active Member
Joined: 1 year ago
Posts: 6
April 19, 2018 1:43 pm  

Just a heads up that I filed a bug report with Nvidia on this.  It should be easy to reproduce so I'm hopeful 🙂

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


theitsage liked
ReplyQuote
burhop
(@burhop)
Active Member
Joined: 1 year ago
Posts: 6
May 24, 2018 9:24 pm  

I installed the latest NVIDIA drivers that they released today (5/24/2018)

It doesn't fix the fan problem but I have learned I can do the following to get it working without a reboot.

1. Boot up with both drivers running.
2. Device Manager/Display Adapters/Disable device -  for both the display adapters
3. Turn off and back on the External GPU (Titan XP for me)
4. Enable the Titan XP driver
5. Enable the other driver (M3000M for me)

Everything is now working as it should with both GPUs working.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote