2018 15" Acer Nitro 5 AN515-42 (RX560X) [R2K,4C,U] + RX 580 @ 8Gbps-M2 (ADT-Link...
 
Notifications
Clear all

2018 15" Acer Nitro 5 AN515-42 (RX560X) [R2K,4C,U] + RX 580 @ 8Gbps-M2 (ADT-Link R53SL) + Win10  

  RSS

Jeffrey Ferrer
(@jeffrey_ferrer)
New Member
Joined: 4 months ago
 

System specs:

  • Acer Nitro 5 AN515-42 15.6”
  • Ryzen 7 2700U
  • 32GB 2666Mhz
  • RX Vega 10 iGPU
  • RX 560X dGPU
  • Win10 Pro Ver. 2004

eGPU hardware:

Hardware Pictures:

20200909 002604
20200909 002432

Installation steps:

  • following the usual procedure, Replace the wifi card with R53SL M.2 Wifi A.E cable.
  • Mount GPU on ADT-Link R53SL
  • Plug 4-pin floppy connector to adapter
  • Connect external monitor on the GPU
  • Shorted pins 16 and 17 (green and black wire) straight on to the power supply, so that I will not use the 24pin cables anymore.
  • I Disabled dGPU and PCI port for the dGPU to remove dGPU on the display adapter list, because sometimes it won’t go PCIE x16 3.0 @ x1 1.1 to PCIE x16 3.0 @ x1 3.0 on GPU-Z when dGPU is enabled.
20200909 000516
20200909 002409
20200909 000829
DevMan
disabled pci port for dgpu

Benchmarks:

 

Aida
Unigine

 

 

 Comments:

I have this eGPU working for almost 2 weeks now, and I’m not quite satisfied with the performance as I can only use it with PCIe x1 (3.0) too bad may m.2 slot is only sata. ☹

I will mostly prefer using dGPU when playing CS:GO as the FPS goes 100 – 150fps, but when I’m using the eGPU my fps just runs at 80 – 120fps.

UPDATE: 

I tried to install a fresh copy of windows.. and now I can play CS:GO at 230FPS at 1080p. 

Any suggestions to make my system run smooth will be appreciated.

2018 15" Acer Nitro 5 AN515-42 (RX560X) [R2K,4C,U] + RX 580 @ 8Gbps-M2 (ADT-Link R53SL) + Win10 [build link]  

nando4 and mr.ribeiro liked
ReplyQuote
mr.ribeiro
(@mr-ribeiro)
Trusted Member
Joined: 3 years ago
 

Thanks for sharing your build, is good to see an eGPU with Ryzen U mobile. Its my first time that i see something like this one..

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote