Setup & Software Discussions
2018 15" MacBook Pro (Vega20) [8th,6C,H] + RTX 2070 @ 32Gbps-TB3 (Razer Core X) ...
 

2018 15" MacBook Pro (Vega20) [8th,6C,H] + RTX 2070 @ 32Gbps-TB3 (Razer Core X) + Win10 [verypacific]  

  RSS

verypacific
(@verypacific)
New Member
Joined: 9 months ago
 

System specs

  • 2018 15" MacBook Pro (MacBookPro15,3 | A1990)
    • Intel Core i9 2.9 GHz
    • 32GB RAM
    • AMD Radeon Pro Vega 20
    • Intel UHD Graphics 630
    • 1 TB SSD
  • Windows 10 Pro 1809
  • (macOS Mojave 10.14.3)

 


eGPU hardware

 


Installation steps

  1. Keep your eGPU enclosure disconnected until advised below
  2. Update macOS Mojave to 10.14.3 in order to properly perform the next step
  3. Install your Windows 10 using the macOS Boot Camp Assistant
    • I used Windows 10 Pro 1809, though the setup might work with an earlier Windows version too (acc. to this post as of 1803)
  4. Boot into Windows and perform all necessary system updates
  5. Download the latest AMD Adrenalin drivers
  6. Download latest Nvidia GeForce Game Ready Drivers
  7. Download and install Display Driver Uninstaller (DDU)
    • I used 18.0.0.8
  8. Use DDU as instructed to remove the graphics drivers supplied by Apple Boot Camp Support Software
  9. Reboot into Windows after removal of the display drivers
  10. Create a Windows restore point - just in case 😉
  11. Install the AMD Adrenalin drivers downloaded before and reboot as necessary
  12. With Windows 10 up and running plug in your eGPU now BUT always disconnect the eGPU enclosure upon reboot
    • I used the top left port but all others should just work fine too
    • I successfully tested both original Razer Thunderbolt 3 cables, the 0.5m long passive cable and the 2.0m active cable
    • Also tried using a cheaper Cable Matters Thunderbolt 3 Active Cable (2.0m) without success.
      • On the very first connection Windows 10 did recognize the eGPU.
      • After starting an eGPU accelerated app Windows 10 quit with a BSOD just after a couple of seconds.
      • Completing the reboot Windows 10 would not even recognize the eGPU at all. 
  13. Wait for Windows to install all necessary drivers
    • This process is usually accompanied by a couple of system events like connect/disconnect sounds, network disconnection etc. so wait for it to finish
  14. Install the Nvidia GeForce drivers and reboot as necessary (remember to unplug the eGPU enclosure and reconnect it earliest when the Windows login screen is shown)
    • I had to perform the install twice. On the first attempt the Nvidia driver package installed everything except the GeForce Experience software. The software install which happens as the last step in the Nvidia driver package quit with an error. I rebooted the system and performed the driver package install again which then performed without any issue.

 


Using the eGPU in Windows 10

  1. Boot your MacBook Pro into Windows 10 without the eGPU enclosure plugged in (hot-plugging required)
  2. Connect your eGPU the earliest you see the login screen, otherwise the internal screen stays black
    • As Windows is not aware of the Intel UHD Graphics 630, Nvidia Optimus can't be used to make applications run on the eGPU but Windows itself is of help
  3. Use the Windows 10 supplied graphics switching mode to assign applications (i.e. games, rendering software, etc.) to your eGPU hardware instead of the dGPU (for further reference see this post)
    1. Go into "Settings" -> "System" -> "Display" (or just right click on your desktop and select "Graphics settings") -> "Graphic Settings"
    2. Add the application(s) you want to make use of the eGPU by either choosing from the list or searching for the executable on your drive
    3. Clicking the Options button pops up a "Graphics specifications" window 
      • Both GPUs should show up in there with the dGPU being listed as the energy saving GPU and the eGPU as the high performance GPU 
      • If you boot with eGPU unplugged the dGPU should be listed both as energy saving and as high performance GPU so your application will just run fine but on the dGPU
    4. select "High Performance" and hit save
      • Just keeping the system default setting didn't do it for me

How to tell if your application is running on the eGPU?

  1. Nvidia tray icon
    1. With the GeForce driver install and after the eGPU is connected there is a small grey icon populating your taskbar
      • If you click it should tell you that no applications are currently running on the eGPU
    2. After you start an application you have set up as described above the icon itself should change to a colored style
      • If you click it now the application should be shown as running on the eGPU
  2. Windows Task Manager
    1. Open Windows Task Manager (i.e. command + option + backspace) 
    2. Locate your application in the "Processes" tab
    3. You can find the name of the GPU your application is running on in the "GPU Engine" column
      • If this column is not visible by default  you can make it visible by right clicking any column header and selecting "GPU" as well as "GPU Engine"

 


Benchmarks

I will supply you with more in detail benchmarks time allowing and if there's any interest.
So far here are the CUDA-Z screenshots showing the GPU specs and the respective transfer speeds between Windows(Mac) and the eGPU.


Comments

  • I did not have to make use of any sort of workaround supplied in the forums though the reference given here and all the experience helped me set this up straight forward
  • I did not have to de-activate or re-activate any system devices
  • There was no Error 12 ever showing up on the system nor any other issues apart from:
  • The internal screen turns black after showing the Windows logo if the eGPU is connected before Windows 10 completed booting up. I guess this is normal system behavior. (see this post for more information)
  • The Nvidia control panel is not working. The panel refuses to open saying there is no display connected to the eGPU

(English is not my mother tongue so in case there's anything unclear or misleading please help me correct it 🙂


This topic was modified 7 months ago

2018 MacBook Pro 15" | Razer Core X | GeForce RTX 2070 | (macOS 10.14.3) | Windows 10 Pro 1809


ReplyQuote