2018 15" Dell XPS 15 9575 [8th,4C,G] + RTX 2070 @ 32Gbps-TB3 (Zotac AMP Box Mini...
 
Notifications
Clear all

2018 15" Dell XPS 15 9575 [8th,4C,G] + RTX 2070 @ 32Gbps-TB3 (Zotac AMP Box Mini) + Win10 1909 [txz81]  

  RSS

txz81
(@txz81)
Active Member
Joined: 3 months ago
 

System specs:

2018 Dell XPS 9575 (2-in-1) => i7 8705G, 16GB Ram, 500GB 970EVO, 4K Touch

34" Viotek UW 3440x1440 100hz 

 

eGPU hardware:

Zotac AMP Box Mini + Zotac GTX 1070 ITX  

Zotac AMP Box Mini + Asus Dual Mini RTX 2070 OC 

 

Benchmarks/FPS:

Vega M Internal 1070 External

 

2070 External 

 

 

3440x1440 with GTX 1070 

Game FPS Settings Comment
COD:MW 47 Med-High, Ray Tracing On Ground War
COD:MW 43

Med-High, Ray Tracing On

Warzone 
Borderlands 3 36 Medium-High Built-in Benchmark
Overwatch 78 Max   

 

 

3440x1440 with RTX 2070

Game FPS Settings Comment
COD:MW 53 High-Ultra, Ray Tracing  Ground War
COD:MW 53

High-Ultra, Ray Tracing 

Warzone 
Borderlands 3 48 Medium-High Built-in Benchmark
Overwatch 102 Max  
Minecraft 38 Max, Ray Tracing, DLSS 2 RT Render Distance 16 chunks
The Division 2 62 High  

 

Userbenchmark(1070): https://www.userbenchmark.com/UserRun/26947396

Userbenchmark(2070): https://www.userbenchmark.com/UserRun/27316010

 

All benchmarks done with undervolt of the graphics card and cpu (limit to 38W max).

Throttlestop settings: https://imgur.com/a/pE5DClR

 

 

Hardware Photos:

GTX 1070

Asus RTX 2070 Dual Mini 

PCH Thermal Pad + Copper Shim in XPS 9575

Overall setup

 

 

 
   
   
   
   

Installed a copper shim + thermal pads on the PCH; The PCH does not go past 60C, even under heavy loads. 

I run a sata hdd & all the peripherals/user inputs through the amp box mini usb ports.

Conclusion:

Works pretty well; more or less plug and play. The only complaint is that the iGPU needs to be disabled and enabled everytime the eGPU is connected. Otherwise, there is very noticeable micro stutter, and nvidia color settings are not loaded. A simple bat script scheduled at startup does the trick: 

devcon -disable "PCI\your igpu hardware id"
timeout /t 2
devcon -enable "PCI\your igpu hardware id" 

Note: devcon.exe must be in same folder as the script, instructions on getting it here: https://superuser.com/questions/1002950/quick-method-to-install-devcon-exe

Update: 

Swapped out the 1070 for a 2070. The zotac amp box mini with a 230W adapter runs the card fine. I set an undervolt profile and the power limit to 95% in afterburner just to be safe.

This topic was modified 2 months ago

Dell 15 9575 2-in-1 - i7 8705G
Zotac AMP Box Mini
Asus Dual OC RTX 2070 Mini

 
2018 15" Dell XPS 15 9575 [8th,4C,G] + RTX 2070 @ 32Gbps-TB3 (Zotac AMP Box Mini) + Win10 1909 [build link]  


ReplyQuote
Topic Tags