2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 1...
 
Notifications
Clear all

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 10.15.5  

  RSS

tomd
 tomd
(@tomd)
New Member
Joined: 4 weeks ago
 

System specs (model inc screen size, CPU, iGPU, dGPU, operating system which eGPU is being used)

1x Mac Mini (2018) - 3.2 GHz 6-Core Intel Core i7 + 64 GB 2667 MHz DDR4 + 1TB SSD

2x HP Z27 27" 4K Monitor 

 

eGPU hardware (eGPU enclosure, video card, any third-party  TB3 cable , any custom mods)

AKiTiO Node Titan + Sapphire Pulse AMD Radeon 5700 XT  (bundle purchased from OWC)

 

Hardware pictures (note: require 5+ posts for "attach files" button to appear. Or can link from say  http://imgur.com   BUT post the .jpg/.png image file rather than a link to it)

TBD

 

Installation steps (what did you do to get it all going?)

1. Insert graphics card into enclosure

2. Plug everything in

3. There is no step three.

 

Benchmarks (Include a  CUDA-Z  or  AIDA64  bandwidth pic. Optional: Valley, 3dmark, noting if it's on internal/external LCD )

TBD

 

Comments (eg: how has the eGPU improved your workflow or gaming)

So the installation wasn't quite as easy as the above including two RMA's to OWC (who were amazing) but that was basically all down to user error.  Couple of things to note:

- Connecting the Mac Mini over USB-C cables to the displays _and_ connecting the eGPU, will always give you four screens, always.  Doesn't seem to be a good way to switch between using the eGPU and using the onboard Intel UHD.  This led to a lot of frustration with lost windows & cursors.  I'm now using the USB-C video picture-in-picture mode..

- Make sure you plug all the power cables in.  This is embarrassing but I didn't plug them all in and this led to misdiagnosing broken card/enclosure and the RMA's.  In my defense I made the mistake of actually reading the Sapphire Pulse RX 5700 manual.  It states that the board takes power in either a 2x6 or 2x8 configuration.  But the board power plugs are 1x6 and 1x6+2.  I plugged in 2x6 and left the +2 open.  Unfortunately this config actually look like it's powering the board correctly inasmuch as the board branding LEDs come on, along with the enclosure fan but it doesn't actually work. Lesson learned.

The enclosure itself is pretty boss.  Tool-less and very easy to work and good, sturdy construction.  As someone else posted the handle comes in surprisingly handy too.

Next up is to try bootcamp & Win10 and also to connect it to my Mid-2015 Macbook Pro Retina.

 

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 10.15.5 [build link]  

Leovinus and itsage liked
ReplyQuote
bprendy
(@bprendy)
Active Member
Joined: 6 days ago
 

@tomd

I have the same Mac Mini (32GB) and the same AKiTiO Node Titan RX 5700 XT bundle purchased from Macsales.

Did you ever make it to Bootcamp and Windows 10??.  

Just like you I got it working on the MacMini without any issues...  However my "endgame" was to get this working under Bootcamp with Windows10 since thats where all of the best games are.  However I didn't realize the Node Titan while supported on Windows 10 and OSX 10.15, is not supported with Bootcamp.

https://www.akitio.com/faq/312-node-can-i-use-the-node-on-my-mac-with-macos-or-boot-camp

I am now past my 30 days with OWC, and completely stuck. Is it normal for vendors to say their stuff doesn't  work with Bootcamp?

 

Also I did want to ask you "off topic", how are you cooling your MacMini ? I bought one of those alloy side stands to put it on its side, its better but still gets very hot.

 

I posted my own question here, so maybe it might help you if someone is able to help me.  If I have success I'll let you know.

 

Good luck!

 

 

Mac Mini (2018) 3.2 GHZ i7 32 GB
OSX 10.15.5 || BootCamp WIN10 1803
AKiTiO Node Titan Thunderbolt 3 eGPU Enclosure with Radeon RX 5700 XT (working OSX, not working BootCamp/WIN10)
Dual LG 32UL950-W 32" Class Ultrafine 4K UHD LED Monitor with Thunderbolt 3


ReplyQuote
corb555
(@corb555)
Active Member
Joined: 2 months ago
 

@tomd, I have a similar setup - Mini, Node Titan, Radeon Pro W5700.  If I put the Mini to sleep, when I wake it up, the screens stay blank until I do a full restart.  Have you had this problem?

I have one 4K screen (LG 5K) using USB-C to the Pro 5700W card.  The second 4K screen (BenQ SW271) has both an HDMI to the Mini (to use as boot screen) and is also connected to the 5700W with Display-Port 1.4. (Using the picture-in-picture on USB-C sounds interesting, but the LG 5k doesn't turn on unless there is a second monitor on the Mini).

 

2019 13" MacBook Pro [8th,4C,U] + RP W5700 @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 10.15.4 [build link]  

ReplyQuote
bprendy
(@bprendy)
Active Member
Joined: 6 days ago
 

@corb555, I have the same setup as you both.. I am able to my Mac mini to sleep and wake up without any issues when using the eGPU.  I'm using USB-C to MacMini for primary display and eGPU is using Display Port on Secondary monitor.

By chance did you try Bootcamp/WIN10 with your setup? I am currently stuck/just getting started with that.

 

 

This post was modified 6 days ago

Mac Mini (2018) 3.2 GHZ i7 32 GB
OSX 10.15.5 || BootCamp WIN10 1803
AKiTiO Node Titan Thunderbolt 3 eGPU Enclosure with Radeon RX 5700 XT (working OSX, not working BootCamp/WIN10)
Dual LG 32UL950-W 32" Class Ultrafine 4K UHD LED Monitor with Thunderbolt 3


ReplyQuote
corb555
(@corb555)
Active Member
Joined: 2 months ago
 

@bprendy, I'm just using OSX, no Windows. I use it for video production and the eGPU has been a total game changer.  It allows me to do multiple effects in realtime at 10bit color, 4k resolution, and other jobs like rendering finish in a fraction of the time. 

Bootcamp on OSX seems like a dark art.  You've probably already done this but see if there is anyone with the 5700 XT and another enclosure that has gotten Bootcamp to work. The other thing would be to try to find someone with another enclosure that uses the Titan Ridge chipset (although I'm not sure if there are any).

 

2019 13" MacBook Pro [8th,4C,U] + RP W5700 @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 10.15.4 [build link]  

ReplyQuote
tomd
 tomd
(@tomd)
New Member
Joined: 4 weeks ago
 
Posted by: @bprendy

@tomd

I have the same Mac Mini (32GB) and the same AKiTiO Node Titan RX 5700 XT bundle purchased from Macsales.

Did you ever make it to Bootcamp and Windows 10??.  

Just like you I got it working on the MacMini without any issues...  However my "endgame" was to get this working under Bootcamp with Windows10 since thats where all of the best games are.  However I didn't realize the Node Titan while supported on Windows 10 and OSX 10.15, is not supported with Bootcamp.

https://www.akitio.com/faq/312-node-can-i-use-the-node-on-my-mac-with-macos-or-boot-camp

I am now past my 30 days with OWC, and completely stuck. Is it normal for vendors to say their stuff doesn't  work with Bootcamp?

This is my current project but so far no luck.  I'm finding that booting with the eGPU plugged in causes problems starting up.  If I plug it in once I'm logged in I get the same PCI error that others have reported.  I'm testing it with different versions of Win10 right now.

Also I did want to ask you "off topic", how are you cooling your MacMini ? I bought one of those alloy side stands to put it on its side, its better but still gets very hot.

I've not noticed this.  Do you have the Mini plugged in to your screens as well?  

I posted my own question here, so maybe it might help you if someone is able to help me.  If I have success I'll let you know.

Good luck!

Cheers!

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 10.15.5 [build link]  

ReplyQuote
tomd
 tomd
(@tomd)
New Member
Joined: 4 weeks ago
 
Posted by: @corb555

@tomd, I have a similar setup - Mini, Node Titan, Radeon Pro W5700.  If I put the Mini to sleep, when I wake it up, the screens stay blank until I do a full restart.  Have you had this problem?

I have one 4K screen (LG 5K) using USB-C to the Pro 5700W card.  The second 4K screen (BenQ SW271) has both an HDMI to the Mini (to use as boot screen) and is also connected to the 5700W with Display-Port 1.4. (Using the picture-in-picture on USB-C sounds interesting, but the LG 5k doesn't turn on unless there is a second monitor on the Mini).

 

Yes I have a similar issue.  If it goes to sleep it doesn't always wake the screens - or at least it seems to wake the screens but they stay black. I have both screens connected to the eGPU via USB-C to DisplayPort.  The hack I use is to have one screen also connected directly to the Mini as well and then switch to that input (via my monitor's OSD).  I find if I bring up display preferences and change the resolution or arrangement, that will fix it without needing a restart.

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 10.15.5 [build link]  

ReplyQuote
corb555
(@corb555)
Active Member
Joined: 2 months ago
 

@tomd, thanks - great to know.  I have one monitor that is connected to both Mini and DP so I will try the display preferences hack.

 

2019 13" MacBook Pro [8th,4C,U] + RP W5700 @ 32Gbps-TB3 (AKiTiO Node Titan) + macOS 10.15.4 [build link]  

ReplyQuote