2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15....
 
Notifications
Clear all

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.3 & Win10 1903 [itsage]  

 of  6
  RSS

Muscovite
(@muscovite)
Active Member
Joined: 3 months ago
 

So this is how this 'works'

Prerequisites: apple_set_os v0.5, Windows 10 Version 19631.1, 16x PCIe 1901 disabled (not sure if necessary), LG 5K on Port 1, eGPU on Port 3, all other stuff (a usb hub and an external drive plugged into the other two TB ports)

I have to shut down the Mini completely, restarting from MacOS/Option-booting does not work (Code 12)

Turn on the Mini and Option-boot into Windows with the eGPU plugged-in, otherwise it won't be recognized as a display adaptor when hot-plugged at all, USB device error, etc

Once booted the 5700xt is either Code 43 or not detected at all.  In either case, unplug/plug-in while in Windows and it will most of the time result in being recognized properly, running at the full 5K resolution.

Rebooting results in Code 12.  Have to power the Mini down and Option-boot into Windows.  

Not what I call a seamless integration, but at least it's something.

BTW, the benchmark results for the Sapphire Nitro+ 5700XT are abysmal/much worse than a Sapphire Pulse RX580 in my ancient Mac Pro 5,1.  Is the i7 CPU the bottleneck or is it the TB loopback mode I am forced to use?

This post was modified 1 month ago

Mac mini (2018) / 3,2 GHz 6-Core Intel Core i7 / 64GB / 1TB + LG Ultrafine 5K + Sonnet eGFX 550
Sapphire Nitro+ RX 5700 XT (plug and play in macOS Catalina 10.15.5, IMPOSSIBLE in Bootcamp Windows, no matter the version)
Sapphire Pulse__RX 580 8GB (plug and play in macOS Catalina 10.15.5, WORKS cold-plugged after a shutdown on Windows 2004


itsage liked
ReplyQuote
arouris
(@arouris)
Eminent Member
Joined: 4 months ago
 

Well it was fun while it lasted.

 

10 days ago I managed to make my 5700XT work with my Mac Mini using the latest fast insider Windows 10 and the Official AMD drivers. Today I wanted to change the height of my monitor (LG 4K) and something moved (either the eGPU or one of the 2 two SSDs in other T3 ports) while in Windows with the eGPU working properly. Image and Windows 10 frozen so I forced rebooted. That's it I cant make it work again, tried everything:

 

  • the 0.5 EFI boot loader
  • bootcampdrivers
  • DDU
  • official drivers
  • swapping T3 ports
  • changing pci.sys from version 1809 (that won't even work Windows detect the change at next boot an it "repairs" it. Then repairs fails and Windows is unbootable. Had to put back the original pci.sys from build 2004

Nothing works now, no eGPU in Windows 10. I believe this is highly fragile. Windows 10 allocate resources to devices. At the point I got it working it might have allocated the only resources that this works with. By having that disconnect maybe eGPU resources got allocated to some other device and eGPU remains the unlucky one.

While this was working for 10 days straight I was restarting the mini back and forth from Windows to macOS and it would work every time. The moment something changed in the connected devices area things got messed up and they won't revert back to working condition.

 

BTW in these 10 days I tried WinCloning the Boot Camp partition in case something like this would happen but WinClone was failing with some error about not being able to mount the partition.

 

Good luck to everyone.

Mac Mini 2018 (Core i5), Sonnet 550 enclosure, Sapphire 5700 XT Nitro


ReplyQuote
 of  6