Setup & Software Discussions
2019 13" Lenovo Yoga C930 [8th,4C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box)...
 

2019 13" Lenovo Yoga C930 [8th,4C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 [sigma957]  

  RSS

sigma957
(@sigma957)
New Member
Joined: 8 months ago
 

System Specs:
Lenovo Yoga C930-13IKB
CPU: i7-8550U
iGPU: Intel UHD 620
Display: 13.9" UHD (3840x2160) IPS
Memory: 16 GB
HDD: 1 TB PCIe-NVME M.2
Ports: 2 x Thunderbolt 3 (4 Lane)
OS: Windows 10 Pro, Version 1809

eGPU Hardware:
Aorus GTX 1070 Gaming Box (GV-N1070IXEB-8GD)
Stock TB3 Cable

Installation Steps:

  1. Made sure I was running the latest TB3 driver. The driver on Lenovo's website was version 17.4.76.9. I started with that driver, but eventually downloaded and installed the latest NUC driver (version 17.4.76.300) from the Intel website.
  2. I tried installing the latest Intel display driver (25.20.100.6519), but found after updating that I couldn't open the "Graphics Settings" app (right click on desktop and select "Intel Graphics Settings", and nothing would happen). So I uninstalled that driver, and went back to the version that Windows Update installs (25.20.100.6323).
  3. I downloaded the latest Nvidia drivers (417.71). I wasn't sure whether to use the notebook or desktop driver, so I started with the notebook driver, but eventually ended up installing the desktop driver because of some issues I encountered (see below).
  4. I plugged in the Aorus box, and waited a minute or two for the Thunderbolt software to recognize the device and ask for permission to use it. I then started to install the Nvidia drivers, but the Nvidia installer failed because Windows was already installing a driver (which is an older version). I let that finish, which took several minutes, and then rebooted like it asked.
  5. Next I uninstalled the Nvidia driver that Windows had installed (version 388.xx), and installed the 417.71 notebook driver I had downloaded. After restarting again, everything seemed to work okay at first, but then I started getting random disconnects of the GTX 1070. If I unplugged the Aorus box, waited a minute and plugged it back in it would recognize it, but then a short while later it would disconnect again.
  6. I decided to start over, so I did a complete uninstall of the Nvidia drivers, and then an clean reinstall, this time using the 417.71 desktop drivers. I'm not sure if it was the desktop driver that did it, or the clean installation, but after rebooting and connecting the Aorus, everything was recognized and seemed to work well.
  7. I did some initial testing, and then ran the Aorus H2D firmware update.
  8. Based on advice I've seen here and elsewhere, I didn't bother installing any of the Aorus software.

Benchmarks:
Since I have a desktop for gaming at home, I'm mostly focused on performance when using the internal laptop screen away from home. However, I did do a series of benchmarks with an external monitor.

Using Internal Display (set to 1080p):
3D Mark (Time Spy): 4696 (Graphics: 5047, CPU: 3370)
3D Mark (Fire Strike): 10328 (Graphics: 12603, Physics: 9278, Combined: 4729)
Shadow of the Tomb Raider: 62 FPS, 51% GPU Bound
CUDA-Z H2D: 2204 Pinned, 1696 Pageable
CUDA-Z D2H: 2594 Pinned, 2105 Pageable

Using External Display (1080p):
3D Mark (Time Spy): 4882 (Graphics: 5200, CPU: 3627) (4% increase over internal)
3D Mark (Fire Strike): 11454 (Graphics: 13953, Physics: 10396, Combined: 5229) (11% increase over internal)
Shadow of the Tomb Raider: 66 FPS, 56% GPU Bound (6% increase over internal)
CUDA-Z H2D: 2232 Pinned, 1770 Pageable
CUDA-Z D2H: 2606 Pinned, 2169 Pageable

Comments:

  • I tried a lot of different tweaks to squeeze more performance out of the i7-8550U CPU, but it just doesn't take very much before these low power CPUs throttle down aggressively. The best I could do was undervolting by -90mv core/cache and -60 iGPU.
  • I've never had a laptop with a 4K display before, and I'm finding that in general it's a lot more trouble than it's worth. When I first started running benchmarks, things were ridiculously slow - Time Spy and Fire Strike were like a slide show. I couldn't figure out what the problem was, and then it occurred to me - with the 4K display, the external GPU is scaling everything up to 4K and then sending the 4K image back to the internal display, which is eating up all of the TB3 bandwidth. So, I changed the the resolution on the internal screen to 1080p, and then everything worked as expected.
  • Another problem with the 4K display was that Shadow of the Tomb Raider seems to get "stuck" at 3840x2160 and won't let me select any other resolution in the graphics settings. This of course kills the performance. After much trial and error, I found a combination of internal display settings that with a fresh reboot seems to let me select 1080p.
This topic was modified 7 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


Two One and itsage liked
ReplyQuote
(@two_one)
New Member
Joined: 7 months ago
 

Thanks so much for the info.
Can I ask for additional info
- heat under daily use and heavy (gaming) load & throttling
- sleep->awake difficulty?
- any difference between both usb-c TB3 ports? I mean both can PD? & OPI 4GT/s?
(I saw an xps 9370 which had 2 adjacent TB3 ports, however only the distal port is recognized when attached with egpu, while the other doesn't)
Thanks a lot again

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
rc1
 rc1
(@rc1)
New Member
Joined: 3 months ago
 

I'm glad this worked for you. I bought a c930 after reading your post. I also bought a Razor Core X + Asus 2080.

Unfortunately, my experience has been very different. I have tried all manor of different driver configurations and physical setups, and cannot get anything that will run reliably for more than an hour. The c930 keeps crashing randomly.

I am all out of ideas what to try.  I wanted to post this in cautionary tale in case anyone was tempted to purchase the c930 (with a slightly different setup to yours). Lenovo support hasn't been helpful; they deem an egpu to be an "accessory".  I bought the laptop specifically to work with an egpu.

There isn't a problem with the Razor Core X + 2080 because it works flawlessly with a Dell XPS that I was hoping to replace with the c930.

How has your experience with the c930 + egpu been since the February?

This post was modified 3 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
iiwolf
(@iiwolf)
New Member
Joined: 4 weeks ago
 

@sigma957

Your notes were a huge help to me thank you!  I have the exact same setup, other than that I am on Windows 10 pro 1903. Wanted to throw my 2 cents in here.

@two_one
I haven't done a ton of intense gaming, but Elite Dangerous and Mordhau on high settings work just fine. The toughest thing I've actually had it do is use an OpenPose Unity3D plugin, the CPU bottlenecked pretty hard, and both the GPU and CPU heated up significantly. That being said, it still ran pretty well, no crashes or anything.

In regards the the TB3 ports, from what I can figure, neither the charging nor the Aorus will work on the 2nd TB3 port. Only the one marked for charging recognizes the Aorus.

I wanted to make two other notes:

First, I initially followed your instructions, but then also installed CUDA 10.1 for some computing stuff I was doing. I wasn't paying attention and it installed its own graphics and HD audio drivers from Nvidia. These caused the box to crash, but I was able to uninstall, reinstall, and specify a custom installation and not install the recommended drivers. Then CUDA and Aorus box worked well together.

Next, the most recent (8/14/19) Windows cumulative update (Windows 10 Version 1903 for x64- based systems (KB4512508)) broke my setup - I would plug in the Aorus box and my laptop would buzz and totally freeze. Rolling back the update fixed it.  From here on out, I will have automatic updates turned off to avoid this.

UPDATE:

A third note: I hooked up a HDMI and DVI (to HDMI) to two monitors. It worked for a bit, then started crashing repeatedly. Checking the reliability history, it was the Intel Display Audio that was crashing. I disabled it and plugged in again and everything is working fine so far!

Wish this setup would just work without any issues though...

UPDATE 2 RETURN OF UPDATE:

So the crashes continued, until I couldn't even login before it crashed. My new TB3 cable came in the mail that I had ordered beforehand (2m StartTech 40GPS), so I plugged that in. So far, it's working. Some searches online revealed other people having a similar problem with the stock TB3, so I hope this fixes it for good. I wonder if this was the issue all along, and everything else was just a red herring.

Also, if you do get a new cable, there are as far as I've seen only 2 cables that will support this box over a length of 1.5ft or so. Read about it here: https://www.reddit.com/r/eGPU/comments/6x9ruw/known_working_active_40_gbps_thunderbolt_3_cables/?ref=share&ref_source=link

Isaac

This post was modified 3 weeks ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote