2019 13" Dell XPS 13 7390 [10th,6C,U] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X) +...
 
Notifications
Clear all

2019 13" Dell XPS 13 7390 [10th,6C,U] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X) + Win10 1909 // some issues help please  

  RSS

Nimoc_1
(@nimoc_1)
New Member
Joined: 4 months ago
 

 

System specs 

2019 13-inch  Dell XPS 13 7390 , i7-10510U, 16GB RAM, 500GB SSD

1x 1920x1080 60hz HP 22" (HP 22W)
Drevo Gramr Cherry Brown, Trust BT Mouse, Bang & Olufsen B&O Play

eGPU hardware 

Razer Core X + XFX RX 5600 XT Thicc II pro + 0.5M TB3 Cable

Hardware pictures 

 

Installation steps 

1. Installed the GPU inside the Razer Core X 2. Plugged to power and connected the already booted laptop 3. installed amd drivers via adrenalin 4. egpu was not working so I rebooted the laptop and after inserting the bitlocker key it worked.

Benchmarks 

  • Aida: R: 2622 W: 2459
  • Geekbench OpenCL: 56907
  • 3d Mark Time Spy: Total 5604 Graphics: 6130 CPU: 3773 Test 1: 42.99 fps Test 2: 33.09 FPS
  • 3d Mark Fire Strike: Total: 13377 Graphic: 18091 Test 1: 85 FPS Test 2: 73.17 FPS
  • Uningine heaven 4: FPS: 128.0 Score: 3223 Min FPS: 33.6 Max FPS: 231.4

Comments 

The EGPU works well. However, there are some issues which I did not manage to solve: 1. When I hotplug the EGPU to the laptop it does not work, often i receive error 12 or " The device is working properly" but nor the external monitor nor the GPU itself seem to be working. I manage to use it only if I reboot the laptop with the eGPU connected. 2. Here we come to the second problem, often when I boot the laptop it asks me for the bitlocker recovery key, both when the eGPU is connected and when it is not. 

This topic was modified 3 months ago

Dell XPS 13 7390 + Razer Core X + XFX RX 5600 XT Thicc II Pro

 
2019 13" Dell XPS 13 7390 [10th,6C,U] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X) + Win10 1909 [build link]  


ReplyQuote