2018 13" Dell XPS 13 9370 [8th,4C,U] + RTX 2060 @ 32Gbps-TB3 (AKiTiO Node Pro) +...
 
Notifications
Clear all

2018 13" Dell XPS 13 9370 [8th,4C,U] + RTX 2060 @ 32Gbps-TB3 (AKiTiO Node Pro) + Win10  

  RSS

stump007
(@stump007)
New Member
Joined: 3 years ago
 

 

A bit old - this was meant to be posted 2 years ago but maybe it can still help.

System specs 

eGPU hardware 

  • Akitio Node Pro
  • Changed exhaust fan to Noctua NF B9 redux
  • Cable: Akitio 40Gbps Thunderbolt3 Cable 200cm/

 

 

Hardware pictures 

Above

 

Installation steps (what did you do to get it all going?)

Installed Nvidia drivers - then reboot - pretty much plug and play

 

Benchmarks

 

Comments (eg: how has the eGPU improved your workflow or gaming)

Great experience - will not go back to pure laptop nor desktop in the future for my personal use. 

Note that I used to be able to hotswap, but since 2 or so months I have to reboot everytime I want to connect to the eGPU (I can still hot unplug only if I turn down screen/egpu first - otherwise I get black screen) - I guess this is because of a recent Bios update from Dell.

I plugged all my USB devices (mouse, keyboard, others) to the USB hub embedded in the monitor, then daisy chained it through node. So I only have one cable.

I was dreaming of using this setup for my professional laptop as well - but my company's windows image doesn't allow to install Nvidia drivers. So for this one I have an extra HDMI cable to add to the laptop + need to swap the USB hub cable from Akitio and company laptop - a bit cumbersome.

In the future - planning to upgrade to a 3080 or 3070 GPU. Or maybe upgrade the whole thing to that new Asus Flow system in a year or so if it works well.

This topic was modified 9 months ago
2018 13" Dell XPS 13 9370 [8th,4C,U] + RTX 2060 @ 32Gbps-TB3 (AKiTiO Node Pro) + Win10 [build link]  

ReplyQuote