2019 15" MacBook Pro (Vega20) [9th,8C,H] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X...
 
Notifications
Clear all

2019 15" MacBook Pro (Vega20) [9th,8C,H] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 17763  

  RSS

solomani
(@solomani)
Eminent Member
Joined: 5 months ago
 

System specs 

MacBook Pro 15" 2019 with Vega 20 dGPU running macOS Catalina 10.15.4 with Bootcamp Windows 10 v17763

Razer Core X Chroma with AMD RX 5600 XT, 6GB GDDR6, 256-bit

Samsung CJ79 34" 100Hz UWQHD Curved FreeSync VA QLED Monitor w/ Thunderbolt 3 (connecting via HDMI).

Installation Steps

MacOS

Plug and play, no issues.

Windows 10

I literally followed all the steps in the video from and it worked right away.  After completing all the steps in the linked video I then plugged in my eGPU and it worked without issue.

Benchmarks

On paper the 5600 is 2.5 faster than the Vega 20 without overclocking.  This was the case when running benchmarks in both MacOS and Windows10 (Vega20/5600):

  • Heaven (4k widescreen, all settings maxed): 361/770
  • 3dMark Spy (4k widescreen, all settings maxed): 2800/7500
  • Borderlands 3 (4k widescreen, max settings): unplayable/40 fps
  • Borderlands 3 (4k widescreen, medium settings): 30/60+ fps.
  • Dragons Dogma (2k standard, max setttings) 30/60 to 100 fps (really depends on area)
  • Total War: Warhammer 2 (MacOS) (2k widescreen, max settings late game save file) 15/60 fps

Comments

I have quite an old version of Windows 10 installed - this is because that was the version I bought when I first setup bootcamp.  I am sure this helped.  The 5600 is almost identical to the 5700 just less memory.  Some oddities:

  • I can not overclock the eGPU using the AMD Drivers and if I try using Afterburner it works for the memory but it doesn't work for the eGPU, in fact, according the Tech-Z it downscales the GPU to 1100 MHZ if I try and change anything.  No sure what's going on there.
  • My MacBook's fans run a full ball even when sitting in Windows.  eGPU fans are fun so not sure why that's happening either.  I would have expected a decrease in heat and noise.  So something weird happening here.

Hope that's helpful as this site was very helpful to me building this box.

2019 15" MacBook Pro (Vega20) [9th,8C,H] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 17763 [build link]  

ReplyQuote
solomani
(@solomani)
Eminent Member
Joined: 5 months ago
 

After another reboot the fan issue died down to what I would consider normal levels.  The overclock is a mystery.

Also, I am able to boot into Windows directly with the eGPU hooked up, I cannot do that the other way around.  I need to already have MacOS logged in for the eGPU display to work.  Its a minor nuisance but if anyone knows the solution would love to know this as well.  Thanks.

2019 15" MacBook Pro (Vega20) [9th,8C,H] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 17763 [build link]  

ReplyQuote
Rob Ogilvie
(@rob_ogilvie)
New Member
Joined: 5 months ago
 

@solomani, did you happen to have any luck getting the Ethernet adapter working in the Core X Chroma?

 

2020 13" MBP | Razer Core X Chroma | RX 580


ReplyQuote
solomani
(@solomani)
Eminent Member
Joined: 5 months ago
 

You know what, I have not tested it.  And my Chroma died a week after I bought - PSU died.  Waiting for my replacement, can test it then.

2019 15" MacBook Pro (Vega20) [9th,8C,H] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 17763 [build link]  

ReplyQuote
solomani
(@solomani)
Eminent Member
Joined: 5 months ago
 

@rob_ogilvie, so got my replacement Razer today, plugged in a network cable and it didn't work under macOS, not tested under windows.  Having said that, obviously something is going on since the screen flashes when I put in the network cable and take it out.  

Chroma X seems a bit flakey to be honest.

 

2019 15" MacBook Pro (Vega20) [9th,8C,H] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 17763 [build link]  

ReplyQuote
solomani
(@solomani)
Eminent Member
Joined: 5 months ago
 

Update on this build, I ended up grabbing an old GTX 970 and using this instead of the 5600 XT.  So far I am liking this setup better.  I use the default Vega20 in the MacBook for MacOS and the Nvidia for Windows.  A couple of reasons why:

  1. Performance of the AMD under MacOS Catalina is miserable.  Benchmarks and gaming show that it performs 50% that of the same card under Windows 10.
  2. It's very fiddly getting the 5600 working under Bootcamp Windows working (per the setup guides above).  I would sometimes reboot and it wouldn't work unless I did port dancing or had to restore an older working backup of bootcamp because the AMD flaked out and forced a crash/reboot which MACOS determined caused damage to the Bootcamp partition (would not bless the partition).
  3. The Nvidia setup is just hassle free.  When I reboot between sides it switches smoothly - no black screens. Drivers are always up to date etc.

So if the reason you are using an eGPU is for gaming, stick with Nvidia and do all your gaming on the windows side.  In fact, if performance is a key item you want from your egpu, you may as well not use AMD under MacOS.  Just use Nvidia under Windows 10.  It's not fiddly at all and can keep your windows up to date.

The reason it's so rubbish under macOS is Apple, they think they can build better drivers than AMD when they can not.  The raw AMD drivers are far superior (double in fact!).

2019 15" MacBook Pro (Vega20) [9th,8C,H] + RX 5600 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.4 & Win10 17763 [build link]  

ReplyQuote