2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Sta...
 
Notifications
Clear all

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station 2) + macOS 10.15.1 & Win10 1903 [itsage]  

 of  11
  RSS

aa15032261
(@aa15032261)
Eminent Member
Joined: 2 years ago
 

@itsage

What thunderbolt firmware version do you have on your MacBook? I'm wondering if the firmware causing error 12. My 15" 2018 model works with my eGPU flawlessly under bootcamp, but on the 16" with the same settings gives me error 12.

  2019 16" 2018 15"
Thunderbolt firmware 51.7 47.3
Link controller firmware 1.38.0 1.34.0
This post was modified 2 years ago

MacBook Pro 16" / i9-9880H / 16GB / 5500M 4GB
Razer Core X / AMD Radeon VII


ReplyQuote
akash4393
(@akash4393)
Eminent Member
Joined: 5 years ago
 

@aa15032261

You’re a lifesaver!! I cannot believe this worked.
Although, I’m having to do the whole swap ports thing on every reboot. But it’s woking, so I’m happy. 

CAE094E3 15BA 4629 8A75 5FE248E368BA

 

2019 16-inch MacBook Pro (i9/1TB/64GB/5500 - 8GB). Akitio Node (Corsair SF600) - Vega 64

 
2014 13" MacBook Pro [5th,2C,U] + RX Vega 64 @ 16Gbps-TB2>TB3 (AKiTiO Node) + macOS 10.14.5 & Win10 1903 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Famed Member Moderator
Joined: 5 years ago
Builds: 14

ReplyQuote
mcoleman
(@mcoleman)
New Member
Joined: 2 years ago
 

@akash4393

Did you use the adrenaline 2020 drivers, or just the standard November package from BCD?

2019 MacBook Pro 16-inch / 2.3ghz / RP 5500m 4GB / 16GB / 1TB. Razer Core X with AMD RX 580
Windows 10 Pro 1903 (18362.295) & macOS Catalina 10.15.2


ReplyQuote
Jon Meadows
(@jon_meadows)
Active Member
Joined: 2 years ago
 

@aa15032261

wow, I don't know how you figured this weird dance out, but it worked for me also. Thanks a million, I don't know how many hours I spent trying to figure it out.

@mcoleman
I used adrenaline 2020 drivers (the latest ones from 12-18-2019). After running the installer and getting the hardware not found error, i went to device manager and updated the driver manually by selecting the 2020 driver folder (C:AMD/Win10-Radeon-Software-Adrenalin-2020-Edition-19.12.3-Dec18)

This post was modified 2 years ago

16 MBP 9980HK / 32GB / 2 TB / 5500M 8GB / Razer Core X / 5700 XT


ReplyQuote
aa15032261
(@aa15032261)
Eminent Member
Joined: 2 years ago
 

It's good to know the solution works for you guys too! Hope we will find a better solution soon!

MacBook Pro 16" / i9-9880H / 16GB / 5500M 4GB
Razer Core X / AMD Radeon VII


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Famed Member Moderator
Joined: 5 years ago
Builds: 14

ReplyQuote
akash4393
(@akash4393)
Eminent Member
Joined: 5 years ago
 

@eightarmedpet

No. I followed the steps that @aa15032261 mentioned in his post on the automate-egpu efi post. 

Link: https://egpu.io/forums/mac-setup/automate-egpu-efi-egpu-boot-manager-for-macos-and-windows/paged/27/#post-70940

2019 16-inch MacBook Pro (i9/1TB/64GB/5500 - 8GB). Akitio Node (Corsair SF600) - Vega 64

 
2014 13" MacBook Pro [5th,2C,U] + RX Vega 64 @ 16Gbps-TB2>TB3 (AKiTiO Node) + macOS 10.14.5 & Win10 1903 [build link]  


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
Builds: 155
 

@eightarmedpet I don't know if it's possible to downgrade the Thunderbolt firmware of a Mac. Reading between the lines, it may be the newest Radeon drivers that helps with error 12. Also I have always used the right-sided Thunderbolt 3 ports on the 16-in MacBook Pro.

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 14" Microsoft Surface Laptop Studio [11th,4C,H] + RTX 2080 Ti @ 32Gbps-TB4 (WD_Black D50) + Win11 [build link]  


ReplyQuote
mcoleman
(@mcoleman)
New Member
Joined: 2 years ago
 

I too can confirm that my Razer Core X with RX 580 works when using the installation / setup steps from @itsage in this post and the boot up steps provided by @aa15032261 in the automate eUFI post.

My setup steps were (largely lifted from the first post in this thread):

  • Install 1903 windows.
  • Install Apple provided BootCamp drivers
  • upgrade windows to x.295 using manually downloaded package.
  • Safe mode DDU driver removal of the Apple AMD drivers
  • Attempted installation of the Adrenaline 2020 18-12-2019 drivers to failure.
  • Device manager installation of GPU driver. Select have disk and point to C:AMD/Win10-Radeon-Software-Adrenalin-2020-Edition-19.12.3-Dec18

Create automate eUFI USB stick using the automate-eUFI 1.0.5 installer script from here. Ensure to disable secure boot as per the instructions on this page. I have not set a firmware password - but I will experiment with adding one later.

Boot up steps (automate eUFI post):

  • Unplug gpu - plug in eUFI USB stick
  • Boot MacOS Catalina 10.15.2 - no need to login
  • Plug in GPU (left rear port) - Wait for macOS to display on the second screen. (I am unable to cold boot to macOS with eGPU connected without performing an SMC reset)
  • Restart to eUFI usb stick - selecting windows.
  • Check device manager. 'I have two basic display adapters showing'.
  • unplug eGPU from rear left port. plug in to rear right port and wait for windows to make its plug-and-play bleep bloops.
  • Unplug from rear ridge port and plug in to rear left port. Following the plug-and-play detection this display adapter is detected and the screen lights up.

I have successfully booted with the eGPU working three times.

Need to do some more testing to verify performance. 

I would also like to play around with the ports. I fear for the longevity of my TB3 cable with the number of plugs and unplugs I am doing. Having previously used the right ports in other setups I now need to rearrange my office.

2019 MacBook Pro 16-inch / 2.3ghz / RP 5500m 4GB / 16GB / 1TB. Razer Core X with AMD RX 580
Windows 10 Pro 1903 (18362.295) & macOS Catalina 10.15.2


ReplyQuote
 of  11