2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core ...
 
Notifications
Clear all

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.5 & Win10 1903  

 of  2
  RSS

Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 4 years ago
 

Referring to my latest experiment. It won't work under 2004 . 

 

Mantiz: ● ●


ReplyQuote
bereal
(@bereal)
Active Member
Joined: 2 months ago
 

@deliciousalbatross7

Hey, thanks for your helpful guide. I have exact same configuration, but went with another guide (win10 2004). What pisses me off is that I have to do "left-right-left" reconnection between MBP and eGPU every time I start up Windows, including start from sleep. 

Could you describe your experience with cold/hot plug-in? Does it work by itself? Separate note - can you put your system to sleep without disconnecting eGPU and all devices connected to it (external monitor, mouse , keyboard, etc) ? in MacOS/Windows? Does the eGPU goes off completely or partially (I had some cases where the LED was off but I still heard some fan noise )

 

This post was modified 2 months ago

16" MBP 2019, 8 core i9 gen9, 32Gb RAM ||| Sapphire Nitro+ Radeon RX 5700 XT (8GB) ||| Razer Core X Chroma


ReplyQuote
DeliciousAlbatross7
(@deliciousalbatross7)
Active Member
Joined: 8 months ago
 

@bereal, sorry for the late reply, didn't check out this site for quite awhile. 

regarding cold plug under bootcamp, it works on the right side ports but left side ones don't always work. But most of the time I go with hot plug, as I found that hot plugs are just more reliable in general. With cold plug, sometimes the amd software doesn't gets loaded after windows login and the bluetooth doesn't work. And anyway I need to literally open the lid to power on the laptop, so I don't find that cold plugging really have a use case. 

cold plug initially worked on macOS as well, but that was when I was still on macOS 15.5.5. After upgrading the 15.5.6, cold plug on macOS stopped working. Need to login with password first, then I can plug in the egpu, otherwise the system hangs after I key in password and hit enter. 

as for sleep, it works fine in macOS, the egpu will "power down", all my other devices are connected directly to the egpu the only things that are connected directly to my MacBook is the egpu and a thunderbolt external ssd(connected to the opposite side's port). 

in windows, I didn't really test or notice the behaviour for sleep, because normally if im done in windows, I just go back to macOS. So I don't really need it to sleep in windows.

The last point, regarding the LED was off but fan spinning, that is a "design flaw" of the Razer Core X chroma. As long as it is connected to the laptop, the PSU fan will spin, even when the laptop is not powered on. Though I could see why Razer made it as such. Because some people may want to use the Razer Core as a charger for the MacBook even when they are not using the system. And technically, they did give you an option to "turn off" this "feature"... through the main power switch behind the Core X chroma.. LOL

Hope I answered all your questions. Smile

 

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.5 & Win10 1903 [build link]  

ReplyQuote
bereal
(@bereal)
Active Member
Joined: 2 months ago
 

@deliciousalbatross7, many thanks for your detailed answer.

I found out that replacing PSU for something like Corsair SF750 will solve that issue with spinning fan during "charge". 

 

16" MBP 2019, 8 core i9 gen9, 32Gb RAM ||| Sapphire Nitro+ Radeon RX 5700 XT (8GB) ||| Razer Core X Chroma


ReplyQuote
 of  2