2019 17" Dell Inspiron 17 7791 2-in-1 (MX250) [10th,4C,U] + RX 5700 XT @ 32Gbps-...
 
Notifications
Clear all

2019 17" Dell Inspiron 17 7791 2-in-1 (MX250) [10th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + Win10 1909 [Gerdoch]  

  RSS

(@gerdoch)
Active Member
Joined: 2 weeks ago
 

System specs

  • 17" Dell Inspiron 17 7791 2-in-1
  • Intel Core i7-10510U 1.8 Ghz-2.3Ghz 4c/8t
  • 16GB DDR4-2666MHz
  • Nvidia MX250 dGPU (Disabled in Device Manager) / Intel UHD iGPU
  • 17" 1920x1080 Touch Internal Display / 32" LG 1080p 32MP58HQ External Display
  • 32GB Optane Drive + 512GB Nvme m.2 (RAID) / 2TB HDD
  • Windows 10 Home Build 1909

eGPU hardware

 

Hardware pictures

IMG 0342
IMG 0341
IMG 0343

 

Installation steps

  • Copy pci.sys from Windows 10 1903 ISO to Windows Recovery USB
  • Boot from Recovery USB and open Terminal
  • Copy 1903 pci.sys from Recovery USB to C:\Windows\System32\Drivers\pci.sys
  • Reboot to Windows 10, Connect eGPU
  • Install latest AMD Adrenalin drivers (20.4.2)
  • Set Displays to Extend with External Display set as Primary (connected to eGPU via DP)

 

Benchmarks (All Benchmarks run on External screen)

image
image
image

 

Comments 

I have had some issues with USB devices when using the eGPU.  Setting PCI Link State Power management to "off" when plugged in helped (devices no longer entirely disconnect, but still stutter/crackle - mouse and USB audio dongle), but it is apparent that there is some sort of power management issue that can cause USB devices to stutter or disconnect.  So far the solution for me has been to quit using my unpowered USB 3.0 hub and only have two USB devices plugged directly into the 2 USB 3.0 type A ports on my system.  I intend to try a powered USB hub once I get one to see if that makes a difference.

As well, I've seen a lot of comments on builds with similar hardware about issues with Bitlocker when booting up with the eGPU connected.  So for anyone who is curious about those issues, on the hardware for this build, Bitlocker is enabled, and I have no issues with boot-up, sleep, wake, etc.  I just leave my eGPU connected constantly and everything works fine.

This topic was modified 1 week ago

Dell Inspiron 7791 / i7-10510U / Razer Core X / Gigabyte Radeon 5700 XT

 
2019 17" Dell Inspiron 17 7791 2-in-1 (MX250) [10th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + Win10 1909 [build link]  


mr.ribeiro and nando4 liked
ReplyQuote