2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macO...
 
Notifications
Clear all

2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [andygev35]  

 of  8
  RSS

andygev35
(@andygev35)
Estimable Member
Joined: 4 months ago
 

@tsakal, no permissions/ownership changes are needed when doing the drag and drop swap from within MacOS for me.

 

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@andygev35, Thanks

 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@andygev35, @itsage

 

hi there, I have managed to get my new 2020 mbp to work wiht the pci.sys swap. However, in my case the drag and drop did not work and mounty was not working either. So I had to change the permissions to do it. However, windows keep changing the pci.sys file back to the newer one after restart. 

How can I stop this from happening? 

 

Thanks in advance. 

 

 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
andygev35
(@andygev35)
Estimable Member
Joined: 4 months ago
 
Posted by: @tsakal

How can I stop this from happening? 

I can only guess, but when you mess with ownership and permissions of system drivers, Windows tends to not like that very much.  This is why I prefer doing the swap from MacOS.  Occasionally Windows will still replace it when it's part of an update.  

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
Steven Withman
(@steven_withman)
New Member
Joined: 4 weeks ago
 

tried the tutorial and got my gigabyte 5700xt up and running under 1903, thanks!

 

I wanted to see if I can go to 2004 with the pci.sys swap. At first it seemed the driver was installed successfully with the external display turned on. After a while it threw me an message telling me some changes has made in the system and I need to reboot in order to take effect. Prior to this I already disabled automatic update and driver download completely. After the reboot I started to have code 12 again. Replacing pci.sys in macos once again and do the whole DDU>install driver thing didn’t solve the problem. 

 

Any ideas why? Feel like it’s probably best to just stay at 1903 v1

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
andygev35
(@andygev35)
Estimable Member
Joined: 4 months ago
 
Posted by: @steven_withman

Any ideas why? Feel like it’s probably best to just stay at 1903 v1

Did you do a clean install of v2004 or did you update your 1903 install?  For some reason, I've never had any luck with Adrenalin reinstallation even after using DDU.  Also make sure you're using the latest WHQL version (20.4.2) of Adrenalin and NOT the more recent optional driver version (20.7.2).  I've tried both and couldn't get 20.7.2 to survive a reboot.

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
Steven Withman
(@steven_withman)
New Member
Joined: 4 weeks ago
 

@andygev35

Clean install. I tried both whql and newest version but neither survived the reboot.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@steven_withman, mine worked fine with the 2004 version 

 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Vetal
(@vetal)
Active Member
Joined: 3 months ago
 

@andygev35 Thank you! Your instruction saved me a lot of hours or even days, everything works fine in mac os and Windows 10 1903 V1.  I re-enabled all PCI Express Root Ports after installation, so my egpu is able to work from every thunderbolt port.
MacBook Pro 13 2020 (10th gen, i7, 32gb RAM) + Razer Core X chroma + ASUS ROG Strix Radeon RX VEGA64 + mac os 10.15.6

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
andygev35
(@andygev35)
Estimable Member
Joined: 4 months ago
 

@vetal, I'm glad it worked for you.

 

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
 of  8