2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macO...
 
Notifications
Clear all

2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [andygev35]  

 of  9
  RSS

andygev35
(@andygev35)
Estimable Member
Joined: 6 months ago
 
Posted by: @tsakal

@andygev35, the i7 is 4.1 . In any case as I mentioned above with two threads if you are at 80-90 Celsius you should run the test at 3.8 throughout. 

 

That's definitely not the case then.

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@andygev35, I have been in contact with apple support and they elevated the case to the engineering team. They confirmed it to me today after analyzing the logs from my system. I may be worthwhile for you raising the issue. ..

My thought process is that if the cpu is the issue and not the firmware then we have a case to get a replacement. 

I relaized the performance drag when I run the same encoding in handbrake and I recorded exactly the same time in both an i7 2018 and an i7 2020 10 th gen. 

After two years there should be at least some improvement ... not to mention that my 2020 system is 32g ram.

 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
andygev35
(@andygev35)
Estimable Member
Joined: 6 months ago
 

@tsakal, valid point. In Windows Cinebench R20 2 threads, it's running at 3.4GHz to 3.5GHz.

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@andygev35, I got the 2020 I run a cine r20 and I got a score of 2111 and thought bingo it was worth the while but after I updated to 10.15.6 I get max 1870 even with fans at 100% from the start. 

I was fooled as my 2018 was running ok with 10.15.6. 

the t2 chip affects also windows performance. I asked apple support the exact same question and that's what they told me. 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
andygev35
(@andygev35)
Estimable Member
Joined: 6 months ago
 

@tsakal, I just ran a full 8 thread bench and got 1899 with Macs Fan Control running max fans on Big Sur.  Running on Windows, a full 8 thread bench again with Macs Fan Control running max fans netted a score of 1604.

 

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

 

screenshot

@andygev35, I get similar results on 10.15.6. As I mentioned on macOS 10.15.4 new out of the box I got 2111 !!!!!

Based on reviews the i5 should give 1900 score with stock fans. 

 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
brockblahous
(@brockblahous)
New Member
Joined: 1 year ago
 

I followed this guide but im still getting a yellow bang on my RX 580 and the external display wont work.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mfiorentino
(@mfiorentino)
New Member
Joined: 1 year ago
 

@andygev35, Tried your build on a 2020 13" MacBook Pro, Four Thunderbolt 3 ports, 2,3 GHz Quad-Core Intel Core i7, 32 GB RAM, macOS 10.15.6, Razer Core X Chroma with Radeon RX Vega 64, and all worked fine until I had to download and install the AMD drivers. I found out that the combination of Windows 10 1903 V1 and this setup slowed down my internet connection to a halt. Even though I tried some different approaches by modifying the settings of the adapter in Device manager, I simply could not figure out how to speed up the connection. Alas, I had to abort - also because it's quite unfruitful to game on a low bandwidth... Just for information to those trying this setup...

 

Massimo Fiorentino
- mostly using eGPU for After Effects and photo work
- Razer Core X Chroma with AMD Radeon RX Vega 64
- BenQ SW321C
- MacBook Pro 13" 2020


ReplyQuote
luotn
(@luotn)
New Member
Joined: 11 months ago
 

@andygev35

 

Thank you the detailed tutorial. But I’m still running into error 207 and code 12 upon driver install. I followed each step carefully.

Our MBP and enclosure are the same, and I am sure the windows is 1903 V1, newest version of DDU and the driver from amd website (recommended). Do you have any idea why this would be the case? I also tried both installing windows on the Mac’s internal drive and an external. The results are the same. But the same setup works fine with GTX980.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
roko
 roko
(@roko)
New Member
Joined: 2 weeks ago
 

@andygev35, THANK YOU SO MUCH. I tried following maybe 10 guides & troubleshooting fixes until coming across this and it worked perfectly. Appreciate the level of detail in your guide for us noobies

The one divergence I saw on my machine was that instead of Notify for download and notify for install, I could only select "Notify for download and automatically install." Might this be problematic, or would it only install if I opted to download an update?

Follow-up question: Is it possible to enable a different TB3 port, and if so, how are they mapped or how do I figure that out? My Razer Core X TB3 cord is laughably short, so I'm hoping to be able to plug it into the right side of my 2020 MBP 13"

Cheers Smile

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  9