2020 14" Lenovo Thinkpad X1 Carbon Gen 8 [10th,4C,U] + RTX 2080 Ti @ 32Gbps-TB3 ...
 
Notifications
Clear all

2020 14" Lenovo Thinkpad X1 Carbon Gen 8 [10th,4C,U] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10  

  RSS

Andy Chu
(@andy_chu)
New Member
Joined: 8 months ago
 

 

 

System Spec:

Lenovo X1 Carbon Gen 8 i7-10610U/16GB/DDR3/1TD SSD

External Monitor: Asus VG27A 27 inches

Lenovo Thunderbolt Dock Gen 2

External GPU: RTX 2080 Ti AORUS Gaming Box

 

In the beginning, I followed the install instructions from Gigabyte handy manual.  No need to approve the connection, it was connected automatically.  Download official Nvidia software and ultility software from Gigabyte and simply installed it.  It worked.  However, system freezed whenever I booted up the computer for few mins.  I realised that I need to connect the gaming box thunderbolt cable to X1 after windows was fully loaded, it will work normal.  I updated to latest Nvidia drivers, it worked the same.  If I didn't unplug the cable before boot up the system, it freezed all the time after short time using it.

 

It was not fine for me so I browsed many builds in this web site.

 

Very simple here, I go to Nvidia Control Panel, change to /Mange 3D setting/Global setting/Power Management Mode/Prefer Maximum Performance. 

Go to Registry editor, add the below two keys manually:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers

Key Value: TdrDelay, Value Type don't change, Value data put to 10

Key Value: TdrDdiDelay, Value Type don't change, Value data put to 20

Reference topic:

https://egpu.io/forums/pc-setup/random-freezing-in-windows-10-pro-with-intel-nuci7beh-razor-core-x-gtx-2060-super/paged/4/#post-76639

It works fine now, no more issue.  However, you got to log in to windows to turn on the screen.  Even you change the boot to external display or thunderbolt in the bios, it doesn’t turn on the screen before log in windows.

 

Unigine Valley benchmark

 

 

 

2020 14" Lenovo Thinkpad X1 Carbon Gen 8 [10th,4C,U] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 [build link]  

ReplyQuote
Dmitry F
(@dmitry_f)
Active Member
Joined: 1 month ago
 

Hi, @andy_chu.

Thank you for your report.

I'm currently using X1 Carbon 6th with Razer Core X Chroma with RTX 2080 Super.

I constantly experience random GPU disconnects even without any load. Some time it is recoverable by simply disabling and re-enabling the GPU from the Device Manager, but some time I have to reboot to make it working again.

Could you please advice, do you have any similar issues with your set-up? Or the only issue is next?

Posted by: @andy_chu

you got to log in to windows to turn on the screen

I'm considering buying X1 8th to fix my issues but I do not understand will it work at all.

I would really appreciate your feedback.

Thanks a lot in advance!

2020 14" Lenovo Thinkpad X1 Carbon Gen 8 [10th,4C,U] + RTX 2080 Super @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 [build link]  

ReplyQuote
Dmitry F
(@dmitry_f)
Active Member
Joined: 1 month ago
 

@andy_chu I've decided to upgrade my build buying X1 Carbon 8th Gen.

Everything is fine, but I have strange issue with NVidia drivers trying to run games that require DX12, i.e. Cyberpunk 2077 or Ghostrunner in DX12 mode. They are just crashing on the start-up.

Do you have any of such issues? Or maybe you can kindly check it in your build? I will really appreciate this.

Thanks a lot in advance!

2020 14" Lenovo Thinkpad X1 Carbon Gen 8 [10th,4C,U] + RTX 2080 Super @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 [build link]  

ReplyQuote