2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core ...
 
Notifications
Clear all

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.6 & Win10 2004  

 of  11
  RSS

raebyagthefirst
(@raebyagthefirst)
Eminent Member
Joined: 7 months ago
 

@bereal, it's 2004, but I'm gonna to update. I don't do the port dance, I use just a single port as I described in the first post: EFI(plug)-Boot(unplug)-Welcome screen(plug).

@fredman, Idk, there's still difference, not too big, I agree, but those benchmarks are way too synthetic.

 

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.6 & Win10 2004 [build link]  

ReplyQuote
raebyagthefirst
(@raebyagthefirst)
Eminent Member
Joined: 7 months ago
 

I updated macOS to 11.1, egpu works well, though I don’t see a way for “disconnect safely” on Mac anymore. Windows boots as usual. Also, upgraded drivers to bootcampdrivers Dec 2020 version.

 

Edit: safe disconnect option appeared after reboot.

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.6 & Win10 2004 [build link]  

ReplyQuote
simooa
(@simooa)
Active Member
Joined: 1 year ago
 

At least I updated my system to Win 10 20H2 with all Updates yesterday. From Bootcamdrivers.com I installed the Adrenalin December 2020 Red Gaming edition. The system works well. I can also use my Vive Cosmos with Viewport games as expected. OS X is still Catalina, but upgrade to Big Sur will follow soon. 

MacBook Pro 16" 2019 - i9 - 9980HK - 1TB SSD - 32GB RAM - AMD Pro 5500M - Intel UHD 630
AMD Red Devil RX 5700 XT / Razer Core X
Mac OS Big Sur 11.1
BootCamp Windows 10 build H2


ReplyQuote
William Zheng
(@william_zheng)
New Member
Joined: 3 months ago
 

Hi, I am also on the newer 20H2 version of Windows and can confirm this setup works!

One thing I noticed, however, is the longer Windows boot time when I go through the custom EFI.
When I start my Mac as usual, it straight up goes to Windows without the custom EFI, and reaching desktop is then within 5 seconds. The Windows boot logo is just there for a second or two.

It becomes slower when I hold in alt, select the Windows partition, follow your steps of plugging in eGPU, remove when I see the Windows logo. The duration of the Windows logo seems to take about 30 seconds, before I get to my desktop. Any idea what the cause may be?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Hakim Masab
(@hakim_masab)
New Member
Joined: 5 months ago
 

I got this to work under the new developer insider build of windows and to display all three adapters, the Intel UHD 630, 5500M, and the 5700XT

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mini i5
(@mini-i5)
Prominent Member
Joined: 2 years ago
 

@hakim_masab

So your 16” MBP 2019 works with Win 10 20H2 Bootcamp. Any special steps needed?

 

2018 Mac Mini [8th,6C,B] + RX Vega 56 @ 32Gbps-TB3 (Sonnet Breakaway 650) + macOS 11.1 & Win10 [build link]  

ReplyQuote
Scaven X
(@scaven_x)
New Member
Joined: 4 weeks ago
 

I have a 2019 16-inch MacBook Pro as well, would you mind sharing your bootx64_original.efi with me? I accidentally deleted mine

16-inch MacBook Pro 2019 with Radeon 5500M, 2070 Super for eGPU paired with Razer Core X


ReplyQuote
raebyagthefirst
(@raebyagthefirst)
Eminent Member
Joined: 7 months ago
 

@hakim_masab, I noticed it too, but just a slight regression. Don't think there's a solution for it tbh.

@scaven_x, sure, np. I will share it this week if I don't forget about it.

 

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.6 & Win10 2004 [build link]  

ReplyQuote
simooa
(@simooa)
Active Member
Joined: 1 year ago
 

Hi, i 've updated my system with bootcampdrivers Adrenalin February 2021 edition (21.2.1 red) an OS X Big Sur. Unfortunately I am not able to play HL Alyx and Star Wars: Squadrons at the moment. HL Alyx freezes after 2-3 min gameplay, Star Wars:S quits after the start screen with setting menu. On my first setup with Win 1909 HL Alyx was running without any problems.

Has anyone experience with these two games especially in a VR setup (HTC Vive Cosmos)? 

It looks like the GPU is working as expected, when I check the adrenalin software the card is listed with 60-70% activity. When Star Wars quits, activity is back to 0%. 

I tried a lot of the bootcampdrivers from Jan 2020 to now and had no effect. For help or ideas I would be quite happy 😉 

 

 

MacBook Pro 16" 2019 - i9 - 9980HK - 1TB SSD - 32GB RAM - AMD Pro 5500M - Intel UHD 630
AMD Red Devil RX 5700 XT / Razer Core X
Mac OS Big Sur 11.1
BootCamp Windows 10 build H2


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@simooa, Use Radeon Spring 2020 drivers (20.4.2) for best eGPU performance.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RTX 3080 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 // my 3rd RTX 3080 build [build link]  


simooa liked
ReplyQuote
 of  11