2019 16" MacBook Pro (RP5600M) [9th,8C,H] + RX 6900 XT @ 32Gbps-TB3 (Razer Core ...
 
Notifications
Clear all

2019 16" MacBook Pro (RP5600M) [9th,8C,H] + RX 6900 XT @ 32Gbps-TB3 (Razer Core X Chroma) + Win10  

  RSS

sho
 sho
(@sho)
Active Member
Joined: 4 weeks ago
 

System specs

MacBook Pro 16”
2.4GHz 8‑core 9th‑generation Intel Core i9 processor, Turbo Boost up to 5.0GHz
64 GB RAM
AMD Radeon Pro 5600M with 8GB of HBM2 memory

eGPU Hardware

Razer Core X Chroma
Asus TUF  AMD Radeon 6900 XT
ALIENWARE 34 Curved Gaming Monitor (AW3420DW)


OSX Guide

  1. Plug and play. Then you need wait for the next Big Sur update providing the latest drivers. No work around for now.

Windows Guide

  1. Leave the eGPU and internet disconnected and use Boot Camp Assistant in macOS to install a fresh copy of Windows Pro 10 1903 V1 ISO (OS Build 18362.30) use this link - https://tb.rg-adguard.net/public.php
  2. After it is done installing, boot into Windows 10, get it all set up. Don’t connect to internet. Create an only local account.
  3. Install Apple boot camp drivers.
  4. Before restarting disable Windows Auto Updates. Do this through Group Policy [gpedit.msc]. Expand Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Windows Updates. Double-click Configure Automatic Updates to make changes. Click the radio button Enabled and choose 2-Notify for download and auto install in the drop-down under Options.
  5. Restart computer.
  6. Connect internet and download the newest drivers from https://www.bootcampdrivers.com
  7. Extract ZIP file and launch DDU. Change settings and select all AMD checkboxes. Select also checkbox to not automatically update drivers. Go back to DDU app and select AMD and GPU. Press button clean and restart.
  8. After you MacBook will boot again into Win, connect eGPU and run setup installing drivers. No fresh install selected on my end. After installation process will be done restart MacBook.
  9. Enjoy your 6900XT. No need to disconnect it etc. You can keep it connected all the time  using Big Sur than jumping back to bootcamp. To keep AMD drivers update you don't need to use bootcampdrivers anymore. Just download 6900xt drivers from AMD website, launch exe file which will unpack everything to C:\AMD folder. Than the app will run and show you error. Turn off app. Go to the Device Manager. Select your Display Adapter 6900xt first. Go to properties > driver. Hit update driver button. Browse your computer for driver using the button "Let me pick from a list of available drivers on my computer ...". Choose option "Have a disk". Go to folder C:\AMD\Non-WHQL-Radeon-Software-Adrenalin...\Packages\Drivers\Display\WT6A_INF and select one of inf files. Than find your card and install drivers. Do the same later for your 5600m card. Than restart computer. 

I was struggling with many tutorials for almost 10h today. Everything was giving me error 12. As you can see no EFI, pci.sys or other modifications are required. Feel free to play with Windows Updates (never choose optional ones because I’ve heard that they are crucial in destroying things) although first create restore point before doing anything. I haven’t updated system yet because everything works and that’s the most important thing for me. Will post though an update here in case of moving forward with it.

Cheers!

UPDATE:
You can download all updates but remember to keep your 1903 build. Right now Windows is installing automatically ALL updates (you can't choose anything on your own) but ... after restart and seeing your egpu not working again go to Settings > Update & Security > View updates history > Uninstall updates. Than uninstall "Feature pack update" you seeing there. That will push you back to 1903 working build when keeping all other security updates. EGPU will start working again

 


Benchmark: (card overclocked to 2650Mhz, CPU to stable 3.4GHZ)

FIRE STRIKE ULTRA 
https://www.3dmark.com/fs/24995444

TIME SPY EXTREME
https://www.3dmark.com/spy/18582020

 

Gaming:

Star Citizen - 4K max settings - Space Spooling ~30FPS, Port Olisar 37-50FPS, New Babbage 25-35FPS

Cyberpunk - 4k max settings - 40-57FPS

Microsoft Flight Simulator 2020 - 4k ultra settings - some random big cities with stormy weather ~36-40FPS Custom scenery in Chicago ~28FPS in the airport 30-35FPS outside, City Centre low flight between skyscrapers 26-30FPS in all weather conditions.

2019 16" MacBook Pro (RP5600M) [9th,8C,H] + RX 6900 XT @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 [build link]  

nando4, Mini i5 and itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@sho, Thank you for sharing this build! I don't recommend updating Windows 10 past 1903 V1 (OS Build 18362.30) due to more complication of PCIe device handling. 

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RTX 3080 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 // my 3rd RTX 3080 build [build link]  


sho liked
ReplyQuote
Yang LI
(@yang_li_1)
Eminent Member
Joined: 1 year ago
 

Thanks for the sharing.

This is amazing, i have been using BootCamp for a while and did couple of re-install but always have error 12 and have to use the old win10 sys file replacement trick or other work around to make it work.

Today i've installed big surf update for mac os and wiped windows for a fresh install. So i decided to give the approach in this build a try, surprisingly it worked perfectly without any issue, no error 12 or what so ever.

I've a 2019 15' mackbook pro, and 5700xt, mac ox big surf latest update and win10 1903v1, latest driver from Bootcampdrivers.com

This post was modified 5 days ago

MBP 15 2019
Asus XG Station Pro
PowerColor Red Devil 5700XT


sho liked
ReplyQuote
willdang331106
(@willdang331106)
New Member
Joined: 5 days ago
 

@sho

hello,

can you help me, cause i got mostly same configuration of yours, but i can’t make it working

First of all, here my configuration:

Macbookpro 16 2019.

16 Gb Ram

1 TO ssd

Graphic card Amd Pro 5600m 4gb

 

4 days days ago, I was able to buy a card despite the current shortage. An AMD RX 6900 XT. An radeon amd original version.

 

I have an egpu case (Razer Core X) that i use for my old gtx 1660.

I ´ve been following 2 different post step by step

 

https://egpu.io/forums/builds/2020-16-macbook-pro-5600m-8gb-hbm2-9th8ch-6900xt-32gbps-tb3-razer-core-x-chroma/

 

https://egpu.io/forums/builds/2017-15-macbook-pro-rp560-7th4ch-rx-6900-xt-32gbps-tb3-razer-core-x-win10-darkjz-minor-hardware-mod/

 

And the card doesn’t working, In the device manager both card are recognized by the system but only the Rx 6900 xt has a yellow exclamation mark.

I tried to uninstall and re-install many times with different driver on bootcampdrivers.com but it doesn’t change anything.

 

I just come to erase the bootcamp partition and re-install windows 10 pro, but nothing change.

So if anyone have any idea about this issue, please give me yours suggests.

all my thanks

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Limga
(@limga)
Active Member
Joined: 3 months ago
 

Thank you for sharing. When I first read this post I thought it is impossible. I tried different solutions using EFI and many others with some success but error 12 still ocured. I wanted to have reliable solution using only cold or hotplug and I thought I should give a try on your method. 
I followed your guide and there was a BSOD once when driver setup stucked and I tried to reboot. After that everything is working fine! Thanks Smile  

MacBook Pro 16 (5500M 8Gb, i9 2.3GHz, 32Gb RAM), Razer Core X Chroma, Vega 64 (custom liquid cooling)


sho liked
ReplyQuote
sho
 sho
(@sho)
Active Member
Joined: 4 weeks ago
 
Posted by: @willdang331106

@sho

hello,

can you help me, cause i got mostly same configuration of yours, but i can’t make it working

First of all, here my configuration:

Macbookpro 16 2019.

16 Gb Ram

1 TO ssd

Graphic card Amd Pro 5600m 4gb

 

4 days days ago, I was able to buy a card despite the current shortage. An AMD RX 6900 XT. An radeon amd original version.

 

I have an egpu case (Razer Core X) that i use for my old gtx 1660.

I ´ve been following 2 different post step by step

 

https://egpu.io/forums/builds/2020-16-macbook-pro-5600m-8gb-hbm2-9th8ch-6900xt-32gbps-tb3-razer-core-x-chroma/

 

https://egpu.io/forums/builds/2017-15-macbook-pro-rp560-7th4ch-rx-6900-xt-32gbps-tb3-razer-core-x-win10-darkjz-minor-hardware-mod/

 

And the card doesn’t working, In the device manager both card are recognized by the system but only the Rx 6900 xt has a yellow exclamation mark.

I tried to uninstall and re-install many times with different driver on bootcampdrivers.com but it doesn’t change anything.

 

I just come to erase the bootcamp partition and re-install windows 10 pro, but nothing change.

So if anyone have any idea about this issue, please give me yours suggests.

all my thanks

 

Just follow steps I mentioned in my post (top of the page). The key thing is to install correct Windows build. An only 1903 is supporting right now EGPUs. Windows Pro 10 1903 V1 ISO (OS Build 18362.30) using this link -  https://tb.rg-adguard.net/public.php

Then follow my instructions and you should be good based on your similar hardware config to the presented here case study.

Good Luck!

2019 16" MacBook Pro (RP5600M) [9th,8C,H] + RX 6900 XT @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 [build link]  

ReplyQuote
willdang331106
(@willdang331106)
New Member
Joined: 5 days ago
 

All my thanks, i will re-install once again and follow exactly same step. 

Is this the language affect the issue ? I will try in English International 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
willdang331106
(@willdang331106)
New Member
Joined: 5 days ago
 

Oh my *****
that’s really work. So thank you, the key thing is windows version

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote