2016 13" MacBook Pro [6th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AKiTiO Node) + macOS 1...
Clear all

2016 13" MacBook Pro [6th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AKiTiO Node) + macOS 10.12.4 & Win10 [traceq] // ammo-case  


Eminent Member
Joined: 4 years ago

Ok guys I had previously installed my eGPU an now I have a bit of time to make it clear :

Hardware :

  • MacBook Pro Touch Bar 13" / i5@2,9 gHz / 8 Gb RAM (Late 2016)
  • Akitio Node eGPU enclosure
  • KFA2 GTX 1070 EX
  • Iiyama B2783QSU / 2560x1440 / 70 Hz via DP
  • Kensington SD4600P (USB-C docking station with ethernet/power delivery/usb for keyboard and mouse/HDD for external storage and backup)

Software :

  • macOS Sierra 10,12,4
  • Windows 10 (via Boot Camp) latest version

Installation :

  • Hardware installation : 
    • Nothing particular, that is my first time mounting a graphic card into something, I just checked that the 6+2 pin from the node are equivalent to the 8 pin socket in the graphic card
  • Software installation in macOS : (15 min)
    • Boot with "cmd+R" / Go to the terminal and enter "csrutil disable" / reboot
    • hot plus the Node
    • Launch the Goalque's script latest version / reboot
    • That's it, everything worked fine with my external monitor being powered through the GTX 1070
  • Software installation in Windows 10 (30 min)
    • Create a USB stick bootable with the apple_set_os.efi (read here : https://egpu.io/forums/mac-setup/how-to-keep-mbps-irisiris-pro-activated-when-booting-into-windows-boot-camp/#post-1458)
      • I did this on MacOS 
    • Boot in windows and hot plug the node
    • Install the thunderbolt 3 driver from intel made for the NUC6i7KYK
    • In the components I found a Nvidia graphic card with ERROR 14 : I needed to install the web drivers.
    • Restart and boot into windows via the EFI BOOT from the usb key
    • Plug the node ONLY AFTER you choose the EFI BOOT and get the W10 wheel
    • Everything worked fined and I could use the GTX Smile
      • I had to launch again the script from Goalque in macOS because I updated the firmware I guess ...
  • To avoid booting with a USB key : I installed rEFInd and kept the apple_set_os.efi in the same folder and that works fine
    • no need to press alt when booting to chose the OS
    • I have 3 partition : 1 macOS and 2 Windows 10 (I guess one is the original bootcamp and the other is W10 same as the EFIBOOT)
    • I still need to plug the node while the wheel is spinning 

As a result : 

  • Everything in ULTRA/EPIC to play @1440p@70FPS in Overwatch / Dirt / Grid / H1Z1 / Last Man Standing ...
  • Only mid in PUB to get over 60 FPS ... 
  • I have yet to test it with 3D app like autoCAD and Revit ... (even if the 1070 might not be the best for it)

Thanks to the community for this large amount of help Smile

2016 13" MacBook Pro [6th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AKiTiO Node) + macOS 10.12.4 & Win10 // ammo-case [build link]  

ikir liked
Eminent Member
Joined: 4 years ago

I found out that my audio jack was not working in Windows 10 when eGPU is connected whereas it is completely fine when it is not and in Mac OS it is working with and without eGPU ...

Not a real problem cause I can plug my headphone into my USB C dock (I just bought an adapter to separate mic from headphone) but have some of you encounter the same issue ?

2016 13" MacBook Pro [6th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AKiTiO Node) + macOS 10.12.4 & Win10 // ammo-case [build link]