2016 13" HP Spectre X360 [7th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box) ...
 
Notifications
Clear all

2016 13" HP Spectre X360 [7th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 [bhushir]  

 of  2
  RSS

bhushir
(@bhushir)
Active Member
Joined: 3 years ago
 
Posted by: max
Posted by: mazarin

I'm considering a similar setup. Does the Aorus Gaming Box actually charge the HP Spectre X360? I've heard HP had the charging port locked down for some cases. The HP Omen Accelerator is the only one I've read that can definitely charge the laptop though the TB3 port so you can just have the one cable in.

Good question. I got Spectre X360 13" 8th Gen, and was considering the Omen Accelerator instead of the new Aorus 1080 since it was said to be the only on to charge the laptop through Thunderbolt connection. But if the Aorus can charge the laptop then I will go with that option instead. 

Yes the Gaming box charges the HP Spectre just fine. 

2016 13" HP Spectre X360 [7th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 [build link]  

ReplyQuote
bhushir
(@bhushir)
Active Member
Joined: 3 years ago
 
Posted by: HellhoundWP

I have a question for you about the Gaming box not detecting.  Have you done all of the driver and firmware updates.  I also have this combination of laptop and e-gpu.  I bought the Gaming Box a bout a week ago and I got it working at first.  But sense then my Spectre has never detected my Gaming Box again.  I have been trying to diagnose the problem, but these are my only two Thunderbolt devices.  The only thing I can think of is the Firmware I installed on the Gaming Box might have killed it, but maybe I am wrong and it is the port on the Spectre.  I was hoping by finding out what you have done driver and firmware wise might help me narrow down the problem.

This happened to me once, and i realised it was a recent windows update. go to the system recovery, and load windows to an earlier stage. It should help fix the issue. 

2016 13" HP Spectre X360 [7th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 [build link]  

ReplyQuote
MikeCoz061
(@mikecoz061)
New Member
Joined: 3 years ago
 

I also cannot get my Aorus Gaming Box to connect to this. It worked fine for about 3 weeks. Yesterday, I updated the bios (to F32) on my Spectre laptop to address the Spectre vulnerability and now I get a "Thunderbolt functionality might be limited" message. It's detected as a USB device but that's it. I have not done any BIOS updates to my eGPU, and it was working fine before the laptop BIOS update, so I know it's the laptop's problem.

I spent a very long time with tech support and they don't know what it is. I haven't got a response from Gigabyte. I reinstalled Windows and it does the same thing on a fresh install, so I really think it's something with the laptop's BIOS/TB3 drivers/Windows 10 updates. I just don't know whose fault it is. I learn towards HP, considering the BIOS update broke mine. But I know it's not always that clear.

I now have a pricey eGPU that does nothing but charge my laptop.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
0rabbit7
(@0rabbit7)
Active Member
Joined: 3 years ago
 
Posted by: MikeCoz061

I also cannot get my Aorus Gaming Box to connect to this. It worked fine for about 3 weeks. Yesterday, I updated the bios (to F32) on my Spectre laptop to address the Spectre vulnerability and now I get a "Thunderbolt functionality might be limited" message. It's detected as a USB device but that's it. I have not done any BIOS updates to my eGPU, and it was working fine before the laptop BIOS update, so I know it's the laptop's problem.

I spent a very long time with tech support and they don't know what it is. I haven't got a response from Gigabyte. I reinstalled Windows and it does the same thing on a fresh install, so I really think it's something with the laptop's BIOS/TB3 drivers/Windows 10 updates. I just don't know whose fault it is. I learn towards HP, considering the BIOS update broke mine. But I know it's not always that clear.

I now have a pricey eGPU that does nothing but charge my laptop.

Wow, keep us updated, that is brutal

2017 15" Dell Inspiron 7577 (GTX1060) [7th,4C,H] + GTX 1070 @ 32Gbps-TB3 (HP OMEN Accelerator) + Win10 [build link]  

ReplyQuote
4chip4
(@4chip4)
Estimable Member
Joined: 3 years ago
 

When you say "fresh install of windows", do you install it from the net, with updates? Asking as the largest part of the Meltdown/spectre patches is on the OS side, the BIOS update might have just enabled those (ie you might not be having the same pre-meltdown-unpatched Windows as you did a month ago even if it's a fresh install). 

FWIW I also updated to F32, no issues here (though I'm using the Omen Accelerator on a 15" x360, so it's not necessarily indicative for your setup).

2017 HP Spectre x360 15 i7-8550U GTX150 + GTX970@16Gbps-TB3 (HP Omen Accelerator) + Oculus Rift + Win10 (no guide)
HP Omen Accelerator Thunderbolt 3 enclosure legs stand removal walkthrough
Employed by HP, but my posts and opinions expressed on this forum are my own.


ReplyQuote
MikeCoz061
(@mikecoz061)
New Member
Joined: 3 years ago
 
Posted by: 4chip4

When you say "fresh install of windows", do you install it from the net, with updates? Asking as the largest part of the Meltdown/spectre patches is on the OS side, the BIOS update might have just enabled those (ie you might not be having the same pre-meltdown-unpatched Windows as you did a month ago even if it's a fresh install). 

FWIW I also updated to F32, no issues here (though I'm using the Omen Accelerator on a 15" x360, so it's not necessarily indicative for your setup).

I did the complete reset built into Windows 10. I realize it's going to get me an updated version, but I wanted to make sure it wasn't just something left over causing it.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Alberto Beto
(@alberto_beto)
New Member
Joined: 3 years ago
 

Hello,

Anyone still using the Aorus Gaming Box with the spectre?
I have the Spectre x360 ac0xx with i7-7500U and was considering the Gaming box with gtx 1070 or 1080.

Are the new drivers working properly with the eGPU? Or I must have windows with an out of date version?

How is the performance on the long run after some months of usage?

I'm also planning to use the box for more than gaming, specifically training neuronal networks.
Have anyone tried installing Cuda and cuDNN and use it with the Aorus box?

Thanks! 😀

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  2