2016 12.5" Razer Blade Stealth + [email protected] (Powercolor Devil Box) + Win10 [confidantduct]^ // compared to MBP build  

  RSS

confidantduck
(@confidantduck)
Active Member
Joined: 2 years ago
Posts: 16
July 14, 2017 12:03 pm  

This is a very brief user review to give you an idea what you should be expecting should you purchase the above setup.

Thought I'd do this since it there's no mention of it in the implementation guide list.

These have been the notable things that I have experienced.

_________________________

How I got here

After suffering too many difficulties with my MBP 13" (2016, no touchbar), not being able to play certain games, inexplicable crashes and a growing frequency of them (once a day) made me give up. So from my previous setup of a mbp with a devil box, I now have a razer blade stealth(late 2016) with the box instead.

It works right out of the box. After connecting the box and updating driver, everything should work. Performance is moderately better on the rbs than on the mbp(thanks to the 16GB RAM and i7).

My setup includes an external 23" display and audio output from the display to a 2.1 speaker setup.

Just in case you were looking for the updated(though unofficially released) drivers, here they are (caution, not necessary per se to the box's operation from my experience, given that powercolour's currently has removed their drivers from their website.) https://www.reddit.com/r/eGPU/comments/5w2npj/fresh_devilbox_firmware_update/

Pros:

-Fuss free solution that works. (mostly)

-Only other alternative if you can't get the core.

Cons:

-Price, if you could afford this then you could probably afford the Core, the only reason you buy this is that the core is simply unavailable and is too much of a hassle to obtain.

-Try to check the TI controller beforehand if you can, TI82 controllers are more compatible with more models, TI83 controllers only work on a few models for now (the new mbp, razer blade and stealth, intel NUC kit) , my experience is with the TI83.

- Electrical buzzing/whining sound when plugging in

On the rbs, you will find that with the power devil box, there will be a audibly annoying electrical buzz whenever you plug it in. This is due to the drivers and will be resolved once you install the one on the link below(originally intended for the Razer Core but works just fine with the Devil Box)

Download the fix here: http://www.razersupport.com/gaming-systems/razer-blade-stealth/

- Once in a blue moon crashes

Once every 2 months I've experienced what can only be described as a severe performance drop, for example, 120 fps playing Overwatch on Ultra that steadily declines down to 10-15 fps and then followed by a complete crash.

What I usually do is just close the game and restart the computer as soon as the significant performance drop starts and that resolves it. Pretty annoying to have happened in a competitive game but has not happened enough to annoy me.

It used to happen to my mbp setup and I suspect it has to do with the box.

- Things that require uninterrupted throughput are severely hampered when used through the box.

I've noticed with my mouse(razer mamba TE, but this happens with any mouse I used) that my tracking always jumps every other second, it's signal seems getting cut, especially when there is heavy throughput going through the box (i.e. gaming).

Download and upload speeds are also cut by more than half (compared to n type wifi ) even when I use the ethernet cable through the box.

Why bother giving us ports if it won't work well? I don't know.
___________________________________________________________

Thankfully, it carries out its main function just fine.

I paired my box with a GeForce GTX 1060 G1 Gaming 6G.

Here are a benchmark to give you an idea on how it'll perform.

(Please note everything here is in 1080p.)

It can also pull off 120fps+ on overwatch at ultra settings, sub 70fps at epic settings(starts getting a little toasty tho).

Most Assassin's creed games at medium or low settings gets you 60fps.

Hope this was helpful to anyone considering this setup!

 

p.s. If I did get anything wrong, do let me know so I can edit the post too.

Current setup: Late 2016 Razer Blade Stealth, Powercolour devil box + gtx 1060

Prev setup: 2016 13" MBP (no touchbar)
Powercolor Devil Box + GTX 1060/GTX 980(succeeded somewhat), RX480 Nitro+ 4GB(attempted but failed)


nando4 and theitsage liked
ReplyQuote
phungtuanhoang
(@phungtuanhoang)
Active Member
Joined: 2 years ago
Posts: 15
August 1, 2017 8:56 pm  

Hi I also have a 2016 RBS with a Mantiz Venus but strangely my D2H only hovers about 1500 mb/s

Can you check your CUDA Z H2D and D2H for me? Also what TB firmware does yours have?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
kUMters
(@kumters)
Active Member
Joined: 1 year ago
Posts: 8
October 4, 2017 10:33 pm  

Hi guys, I'm the owner of RBS 2017 and I just bought HP OMEN Accelerator. Everything is working except USBs. I have very the same issues with disconnecting/reconnecting/freezing all devices which are connected through USBs on DOCK. I tested the same dock with a different laptop (Alienware 15R3) and there were no issues at all.  Based on this experience it looks like a BUG in razer thunderbolt firmware, so I'm going to open the ticket on razer support.

 

PS: My CUDA D2H is very good (I think): 2600MiB/s

 

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
(@kartikeya_mishra)
New Member
Joined: 12 months ago
Posts: 3
January 6, 2018 11:55 pm  

Hello,

I have the 2016 RBS with the devil box on gtx 1070. I update the nvidia drivers, ibstalles the razer core drivers. But none of the games launch on mine. Would you hppen to know why?

I didnt install any software or update the devilbox because the reddit link gives me an error

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Lumos309
(@lumos309)
New Member
Joined: 9 months ago
Posts: 2
April 3, 2018 11:58 am  

Hey, thanks for the review. Does the box also recharge the RBS?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote