Setup & Software Discussions
2018 13" Razer Blade Stealth [8th,4C,U] + RX 580 @ 32Gbps-TB3 (Razer Core V2) +...
 

2018 13" Razer Blade Stealth [8th,4C,U] + RX 580 @ 32Gbps-TB3 (Razer Core V2) + Win10 [itsage]  

  RSS

itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

System specs:

Early 2018 13″ Razer Blade Stealth – i7-8550U/UHD Graphics 620 iGPU/16GB RAM/512GB SSD

 

eGPU hardware:

Razer Core V2 + Radeon RX 580 + .5m Thunderbolt 3 cable

 

Hardware pictures:

 

Installation steps:

Windows 10 1709 – it was plug and play with this setup, no drama here.

 

Benchmarks:

I ran AIDA64 with nothing attached to the expansion ports to get a baseline of bandwidth. HWiNFO64 showed a x4 PCIe connection to Thunderbolt 3 port.

 

Benchmarks:

These benchmarks were done through internal display acceleration mode.

Late 2016 15″ MacBook Pro Early 2018 Razer Blade Stealth

 

Comments:

I’ve been using this setup to complete the ultrabook buyer’s guide for eGPU. The early 2018 Razer Blade Stealth is a good choice for this purpose.

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
AcrankLu
(@acranklu)
New Member
Joined: 12 months ago
 

Hi,
I'm using the Early 2018 13" Razer Blade stealth + Razer Core V2 with Evga GTX1080 ACX3.0+Win10 Ver1809
And my eGPU will disconnect ocassionally and then windows will tell me the GTX1080 is connected and disconnected and connected...... very often. 
Reboot the system may work or may not work. I don't know what I should do to deal with this situation. 
When it shows the GTX1080 is disconnected, in the TB3 control center it shows there is only one TB3 device or sometimes it shows no device is connected.
I don't know what problem causes this situation. The GPU driver is in the latest model and the Windows is updated in Novermber 26th. At the moment I'm updating the windows and I don't know if updating the Windows will solve the problem the Windows is updated to the latest model and the problem still remains.

This post was modified 12 months ago

2018 Razer Balde Stealth 13.3”+ Razer Core V2 with EVGA GTX1080 ACX3.0


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@acranklu This sounds like a hardware issue with the Razer Core V2. What version of Intel Thunderbolt Software are you running on the RBS?

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
AcrankLu
(@acranklu)
New Member
Joined: 12 months ago
 

I think it's 16.3.61275

2018 Razer Balde Stealth 13.3”+ Razer Core V2 with EVGA GTX1080 ACX3.0


ReplyQuote