2012 15" Macbook Pro Retina GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.4&Win10 [Doren]^  

 

Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26
April 26, 2017 3:34 pm  

Aug-8 updated: went from a GTX1050Ti -> RX460 -> GTX1050 which is now being used. Details here.


Hi, first to all I apologize for my english. 

Yesterday I build my first eGPU:

- Akitio Thunder2
- Asus GTX 1050 Ti 4 GB Phoenix
- PSU 120W 12V

Macbook Pro 15" mid 2012 non-retina GTX650M + Intel HD 4000 +16GB Ram + 480 SSD + 1TB HDD


 

I remove the plastic around the fan.

The install was very easy using the automate-eGPU.sh script by goalque on macOS Sierra:

1.- Install the card in the thunder2
2.- Plug it ti the Mac
3.- Run the script
4.- Restart
5.- Voila! all works great! 



On Windows (Creator Update) the things changes, for my specific MacBook Pro I just use the nando4's DIY eGPU software that makes very easy detect the eGPU from the boot manager.

The steps on Windows are:

1.- Install. Windows via Bootcamp without install the Nvidia GTX650M drivers
2.- Download and install the Nvidia Web Drivers
3.- Install nando4's DIY eGPU software and follow the instructions that nando4 sent me
4.- Connect the eGPU and on Windows
5.- Re-install the Nvidia Web Drivers
6.- Restart and check the eGPU is detected
7.- All run perfect 🙂

Benchmark Heaven Windows

 

 

mid-2012 15'' Macbook Pro GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + RX460@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


ReplyQuote
thomas.cool
(@thomas-cool)
Active Member
Joined:1 year  ago
Posts: 11
April 26, 2017 7:13 pm  

stupid question but are you sure you're doing an EFI install or win 10?


ReplyQuote
Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26
April 26, 2017 7:54 pm  
Posted by: thomas.cool

 

stupid question but are you sure you're doing an EFI install or win 10?

   

You're right, the first install was in EFI, now is MBR and the eGPU is detected using the nando4 software.

mid-2012 15'' Macbook Pro GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + RX460@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


ReplyQuote
Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26
April 26, 2017 7:56 pm  

I switch to AMD RX460 4GB, here is the post. Macbook pro mid 2012 rx460
Works perfect on macOS Sierra and High Sierra but no luck on Windows.

mid-2012 15'' Macbook Pro GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + RX460@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


ReplyQuote
Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26
April 27, 2017 2:08 am  

Not bad for my old MacBook Pro 🙂

Splinter Cell Blacklist Video Setting: ULTRA 1920x1080

mid-2012 15'' Macbook Pro GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + RX460@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined:2 years  ago
Posts: 347
April 27, 2017 8:49 am  

nando software doesn't work with EFI, and just with MBR?? It does make a problem with bootcamp?

mid-2017 Macbook Pro RP560 + MSI GTX1080Ti GAMING X@32Gbps-TB3 (Mantiz Venus) + macOS10.13.5 & Win10


ReplyQuote
Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26
April 27, 2017 10:03 am  
Posted by: ed_co

 

nando software doesn't work with EFI, and just with MBR?? It does make a problem with bootcamp?

   

You're right, I reinstall Windows in MBR partition and the it works like a charm. 

mid-2012 15'' Macbook Pro GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + RX460@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


ReplyQuote
Antharsious
(@antharsious)
Trusted Member
Joined:2 years  ago
Posts: 94

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined:2 years  ago
Posts: 1750
April 27, 2017 10:49 am  

@all, DIY eGPU Setup 1.35 has been used successfully to detect and configure a eGPU on 2012 15" GT650M MBP using Windows 10/8/7 installed in MBR/BIOS mode

This software is available at https://egpu.io/egpu-setup-13x/ where full compatibility is listed

2013 15" Dell Latitude E6540 HD8790M + RX580@4Gbps-EC2 (EXP GDC 8.x) + macOS 10.13.5 & Win10
2013 15" HP ZBook 15 K610M + RX580@4Gbps-EC2 (EXP GDC 8.x) + Win10
--
eGPU Port Bandwidth Reference TableeGPU Setup 1.35


ed_co and Antharsious liked
ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined:1 year  ago
Posts: 1159
April 27, 2017 4:58 pm  

Given that the enclosure used is a Thunder2, I would expect that the GPU would have been detected and working in Windows even without @nando4's software. At least that was the case with one user who implemented a 980 Ti w/ 750M MBP 15" on both OSes.

This is good news, however, and probably applies to dGPU NVIDIA notebooks in general - to be able to get NVIDIA eGPUs working in Win.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
3 Build Guides


ReplyQuote
Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26
April 27, 2017 6:09 pm  

Well something went wrong because today after a restart my Mac get e a Kernel panic, after that I was to reinstall the OS and back to 10.12.1, so, no eGPU for now... but I still have Windows.

IMG 1920

mid-2012 15'' Macbook Pro GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + RX460@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined:2 years  ago
Posts: 347
April 27, 2017 10:08 pm  
Posted by: nando4

 

@all, DIY eGPU Setup 1.35 has been used successfully to detect and configure a eGPU on 2012 15" GT650M MBP using Windows 10/8/7 installed in MBR/BIOS mode

This software is available at https://egpu.io/egpu-setup-13x/ where full compatibility is listed

   

Thanks for the reply!! Are you planning to support EFI? And mbp 2016? Or is just a hardware limitation? it really would be the ultimate solution for everything...
Cheers.

mid-2017 Macbook Pro RP560 + MSI GTX1080Ti GAMING X@32Gbps-TB3 (Mantiz Venus) + macOS10.13.5 & Win10


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined:2 years  ago
Posts: 347
April 28, 2017 11:01 pm  

Should be great to know if something is planned... or not possible.

mid-2017 Macbook Pro RP560 + MSI GTX1080Ti GAMING X@32Gbps-TB3 (Mantiz Venus) + macOS10.13.5 & Win10


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined:2 years  ago
Posts: 1750
April 28, 2017 11:21 pm  
Posted by: ed_co

 

Should be great to know if something is planned... or not possible.

   

I'll let you know if something is release. For now, MBR mode provide an alternate boot method that remains an avenue to consider for eGPU detection issues on some MBPs using TB3->TB2 adapters.

2013 15" Dell Latitude E6540 HD8790M + RX580@4Gbps-EC2 (EXP GDC 8.x) + macOS 10.13.5 & Win10
2013 15" HP ZBook 15 K610M + RX580@4Gbps-EC2 (EXP GDC 8.x) + Win10
--
eGPU Port Bandwidth Reference TableeGPU Setup 1.35


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined:2 years  ago
Posts: 347
April 29, 2017 3:58 pm  
Posted by: nando4

 

Posted by: ed_co

 

Should be great to know if something is planned... or not possible.

   

I'll let you know if something is release. For now, MBR mode provide an alternate boot method that remains an avenue to consider for eGPU detection issues on some MBPs using TB3->TB2 adapters.

   

I have so many things in windows, that I am not able to reinstall it just because I have to use mbr 🙁 ... that's why I am asking... I will not need it till mantiz arrive though... 😉

mid-2017 Macbook Pro RP560 + MSI GTX1080Ti GAMING X@32Gbps-TB3 (Mantiz Venus) + macOS10.13.5 & Win10


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined:2 years  ago
Posts: 347
April 30, 2017 12:59 pm  

@nando4, as I saw in other thread for another thing. It could be possible to create a USB with the DIY eGPU setup 1.35 and avoid the need to reinstall windows with a MBR partition...? What do you think nando4??

mid-2017 Macbook Pro RP560 + MSI GTX1080Ti GAMING X@32Gbps-TB3 (Mantiz Venus) + macOS10.13.5 & Win10


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined:2 years  ago
Posts: 1127
April 30, 2017 1:11 pm  

Take a look at this thread, that we’re reconstructing:

https://egpu.io/forums/mac-setup/how-to-keep-mbps-irisiris-pro-activated-when-booting-into-windows-boot-camp/

I developed automate-eGPU EFI demo but the project is on ice due to my thread hijacks at TI forum (good luck with reverse engineering - it's stripped version, all important functions removed from the source code). I accepted some beta testers but never heard back. The demo is still downloadable (for M370X equipped MBP only, early Win10 builds):

https://github.com/goalque/automate-eGPU/releases

automate-eGPU EFIapple_set_os.efi
--
late-2016 13" Macbook Pro nTB + Vega64@32Gbps-TB3 (Netstor HL23T) + macOS & Win10
late-2016 13" Macbook Pro nTB + GTX980/RX580@32Gbps-TB3 (Netstor HL23T) + macOS10.13 & Win10


ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined:2 years  ago
Posts: 347
April 30, 2017 2:51 pm  
Posted by: goalque

 

Take a look at this thread, that we’re reconstructing:

https://egpu.io/forums/mac-setup/how-to-keep-mbps-irisiris-pro-activated-when-booting-into-windows-boot-camp/

I developed automate-eGPU EFI demo but the project is on ice due to my thread hijacks at TI forum (good luck with reverse engineering - it's stripped version, all important functions removed from the source code). I accepted some beta testers but never heard back. The demo is still downloadable (for M370X equipped MBP only, early Win10 builds):

https://github.com/goalque/automate-eGPU/releases

   

The thread I saw was this one, here:

https://egpu.io/forums/mac-setup/2016-macbook-pro-solving-egpu-error-12-in-windows-10/paged/2/#post-9517

 

 But I don't understand, I though that your script automate eGPU was just for mac... not for windows...

mid-2017 Macbook Pro RP560 + MSI GTX1080Ti GAMING X@32Gbps-TB3 (Mantiz Venus) + macOS10.13.5 & Win10


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined:2 years  ago
Posts: 1127
April 30, 2017 3:50 pm  

@ed_co: automate-eGPU.sh (script) and automate-eGPU EFI (UEFI application) are two distinct projects. The latter for Windows, only demo released and it is closed source. It doesn't utilize apple_set_os.efi or gpu-switch mechanism.

automate-eGPU EFIapple_set_os.efi
--
late-2016 13" Macbook Pro nTB + Vega64@32Gbps-TB3 (Netstor HL23T) + macOS & Win10
late-2016 13" Macbook Pro nTB + GTX980/RX580@32Gbps-TB3 (Netstor HL23T) + macOS10.13 & Win10


ed_co liked
ReplyQuote
ed_co
(@ed_co)
Reputable Member
Joined:2 years  ago
Posts: 347
April 30, 2017 5:04 pm  
Posted by: goalque

 

@ed_co: automate-eGPU.sh (script) and automate-eGPU EFI (UEFI application) are two distinct projects. The latter for Windows, only demo released and it is closed source. It doesn't utilize apple_set_os.efi or gpu-switch mechanism.

   

Nice. Thanks for the explanation!! As soon as my mantiz Venus arrive. I will try it. Mine is early 2013 mbp 15" (650M). Is it valid?

mid-2017 Macbook Pro RP560 + MSI GTX1080Ti GAMING X@32Gbps-TB3 (Mantiz Venus) + macOS10.13.5 & Win10


ReplyQuote
Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26
August 8, 2017 4:37 am  

After a few weeks with the RX460 I switch back to Nvidia, same configuration but with a EGVA GTX 1050 2GB, the process is the same and now I'm using an Ultra HD monitor with no lag in Mac and Windows, the result was great.

macOS Sierra 10.12.6

Windows detect the Card

Windows Creators Update Heaven Benchmark

macOS Sierra 10.12.6 Heaven Benchmark

mid-2012 15'' Macbook Pro GT650M + GTX1050@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + RX460@10Gbps-TB1 (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


nando4 liked
ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined:2 years  ago
Posts: 1750
November 28, 2017 11:41 am  

Upgraded to macOS10.13

From [APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)

Posted by: Doren

Hi!, i can confirm now that the script works very well on my Macbook Pro mid 2012 non-retina GTX650M.

Steps:
1.- Clean install High Sierra
2.- Check if SIP is enabled (boot in recovery mode [press and hold cmd+R], open terminal and type "csrutil status", if not enabled type "csrutil enable" press enter and reboot)
3.- Apply High Sierra supplemental update
4.- Install nVidia WebDriver WebDriver-378.10.10.10.15.121.pkg (SIP MUST be enabled)
5.- Reboot and login.
6.- Restart and boot in Recovery Mode (press and hold cmd + R when hear the chime sound)
7.- Enter in terminal and type "csrutil status", if its enabled type "csrutil disable" press enter and reboot
8.- Install nvidia-egpu-v1-1013.zip yeah is the V1 version (the v2 version not works in my system)
9.- Boot without the eGPU connected and login normal and shutdown the system.
10.- Connect your eGPU and start your system... all should be work well.

So, after that I have my 4K monitor running but I have no Brightness control on the Macbook Display :/

macOS SIerra
macOS High Sierra Display no brightness conttrol
macOS High Sierra

 

2013 15" Dell Latitude E6540 HD8790M + RX580@4Gbps-EC2 (EXP GDC 8.x) + macOS 10.13.5 & Win10
2013 15" HP ZBook 15 K610M + RX580@4Gbps-EC2 (EXP GDC 8.x) + Win10
--
eGPU Port Bandwidth Reference TableeGPU Setup 1.35


ReplyQuote
Doren
(@doren)
Eminent Member
Joined:1 year  ago
Posts: 26

nando4 liked
ReplyQuote
mintroini
(@mintroini)
Active Member
Joined:3 months  ago
Posts: 7
May 23, 2018 10:19 pm  

Hi, a question about nando DYI eGPU. Do instructions get sent when buying? Is it flashing something on the MacBook or just running upon windows boot? 

Thanks!


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined:2 years  ago
Posts: 1750
May 24, 2018 4:26 am  

@mintroini , the software runs before Windows boots to configure the eGPU. No flashing is involved. Instructions & support is via email.

2013 15" Dell Latitude E6540 HD8790M + RX580@4Gbps-EC2 (EXP GDC 8.x) + macOS 10.13.5 & Win10
2013 15" HP ZBook 15 K610M + RX580@4Gbps-EC2 (EXP GDC 8.x) + Win10
--
eGPU Port Bandwidth Reference TableeGPU Setup 1.35


ReplyQuote
lallo
(@lallo)
Active Member
Joined:3 months  ago
Posts: 7
May 26, 2018 10:15 am  

Nice build!

Is it possible to connect this macbook pro to a Razer Core V1? Or any closure that has thunderbolt 3? Is there a way to just use an adapter to thunderbolt 1 ?


ReplyQuote