2016 13" Macbook Pro non-TB + [email protected] (AKiTiO Node) + macOS10.12 & Win10 [RBeck]^  

  RSS

RBeck
(@rbeck)
Active Member
Joined: 1 year  ago
Posts: 9
July 23, 2017 1:48 pm  

This is a step by step guide of how I got my Akitio Node working after 4 hours of tinkering and trouble shooting.

Table of Content

- Windows 10 in Bootcamp setup

  - Inital Setup of the Akitio Node

  - Installing GPU and drivers

  - Getting your Macbook to keep it's iGPU active

 

Windows 10 in Bootcamp setup

Inital Setup of the Akitio Node

Step 1

Plug power into your Akitio Node, plug it into your Macbook and boot into windows (WITHOUT GPU INSTALLED).

Step 2

From here install the Thunderbolt Software and do not mind that you actually cannot open the program after installation. Reboot after installation.

Step 3 

Install the firmware upgrade from Akitio's website called PC Updater v1.0.0.4 (NOT 1.0.0.5, it will not work). Reboot after installation and power off the Aktio Node.

So far so good.

 

Installing GPU and drivers

Step 1

Open up your Aktio Node and install your GPU.

Step 2

Head on over to Nvidia's support page and fill out the form, (in here I chose GTX 1080), download and install the driver. Reboot after installation. If you get stuck at this point with Windows not loading, unplug your Node and boot up again.

 

Getting your Macbook to keep it's iGPU active so you can use your Akitio Node with the internal display.

Following steps are also neccesary to use your Macbook in BOOTCAMP with external displays.

Step 1 

Boot into MacOS and follow the short guide here by goalque. Keep in mind for it to work for this specific Macbook Pro model the USB must be plugged into the first Thunderbolt port to the left of the escape key. Your Akitio Node must be plugged into the second port just below.

At this point in your device manager if you click properties on your GTX 1080 it will give you error 12. This is fine, as we will solve it below in Step 2.

Step 2 

Follow point 3. here. Basically just disable the marked device 9D19. Reboot one last time.

 

That's it! As long as you have your USB handy you can boot with the Akitio Node using the internal display.

If you are wondering about how to make it work in MacOS just follow the standard installation guide in the top right hand corner.

Benchmarks

Ran Prey and Doom in which I got solid 60fps @ 2560x1600 all settings maxed out with AA @ x8 and v-sync enabled.

Also ran Unigine 2's superposition benchmark:

Aktio Node on internal screen:

Same GPU in desktop setup:

Only 19% higher than in extenal enclosure, cool huh?

Akitio Node with MSI GTX 1080 inside.


ppm and theitsage liked
ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years  ago
Posts: 3081
July 24, 2017 4:14 pm  

@RBeck Thank you for the step-by-step implementation of your late-2016 13" MacBook Pro non-Touch Bar. Were you able to skip step 1 to keep iGPU activated in Bootcamp? I recall I did not have to do that step when I used the same setup as yours (980 Ti instead of 1080).

Best ultrabooks for eGPU use

eGPU enclosure buying guide

82 external GPU build guides


RBeck liked
ReplyQuote
RBeck
(@rbeck)
Active Member
Joined: 1 year  ago
Posts: 9
July 24, 2017 4:20 pm  

@theitsage Hi mate,

No I was not able to skip it unfortunately. Though I would have loved to.

Issue is that my MacBook simply would not boot into windows without the USB.

I would be stuck at the windows logo with no circle dots moving around. Sometimes it would say please wait. Other times it would just flicker. Never actually booting without.

Akitio Node with MSI GTX 1080 inside.


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years  ago
Posts: 1804
July 24, 2017 4:23 pm  

Did you any of the hotplug methods to eliminate needing the USB stick? eg: 'automate-egpu.sh -a' amongst others at:

https://egpu.io/forums/mac-setup/mbp-egpu-detection-issues/

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


RBeck liked
ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years  ago
Posts: 3081
July 24, 2017 4:32 pm  
Posted by: RBeck

@theitsage Hi mate,

No I was not able to skip it unfortunately. Though I would have loved to.

Issue is that my MacBook simply would not boot into windows without the USB.

I would be stuck at the windows logo with no circle dots moving around. Sometimes it would say please wait. Other times it would just flicker. Never actually booting without.

Give this boot delay a try. OPTION boot your MBP without eGPU connected. Wait for the WiFi to finish loading then select to boot into Windows partition. As soon as you see the Windows logo and spinning circles hot plug the eGPU.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

82 external GPU build guides


RBeck liked
ReplyQuote
RBeck
(@rbeck)
Active Member
Joined: 1 year  ago
Posts: 9
July 24, 2017 5:01 pm  

@nando4

Hi mate,

Just tried 1,2,4 & 5.

None of them allowed me to boot into windows. I would be stuck at the windows boot logo. No. 5 gave me BSOD. All tested twice.

EDIT: @theitsage Also tried your option mate, it did not work. I made me stuck at boot screen now with circling dots moving but nothing else further from there.

Akitio Node with MSI GTX 1080 inside.


nando4 liked
ReplyQuote
RBeck
(@rbeck)
Active Member
Joined: 1 year  ago
Posts: 9
December 4, 2017 8:32 pm  

Update:

Also confirmed working with an ASUS GTX 1080 TI. (Same procedure).

CPU will bottleneck the setup in games like Destiny 2 or Farcry 5.

Akitio Node with MSI GTX 1080 inside.


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 2 years  ago
Posts: 276
October 18, 2018 3:06 am  

Can u guys consistently boot up? I just got the same setup but with a sonnet breakaway. If I plug eGPU before booting, I see windows logo but no spinning circle. If I plug as soon as I see spinning circle, it spins forever. And if I hotplug, I get only power, no devices (and the eGPUY doesn't light up). Kinda frustrating 🙁

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
RBeck
(@rbeck)
Active Member
Joined: 1 year  ago
Posts: 9
October 18, 2018 8:16 am  
Posted by: Rycco

Can u guys consistently boot up? I just got the same setup but with a sonnet breakaway. If I plug eGPU before booting, I see windows logo but no spinning circle. If I plug as soon as I see spinning circle, it spins forever. And if I hotplug, I get only power, no devices (and the eGPUY doesn't light up). Kinda frustrating 🙁

Did you follow the guide for making a USB to help you boot? That was a necessity for me and works really well.

//R

Akitio Node with MSI GTX 1080 inside.


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 2 years  ago
Posts: 276
October 18, 2018 5:46 pm  

I've done that before on another setup, but with reFIND instead of a USB driver. Will try it!

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
RBeck
(@rbeck)
Active Member
Joined: 1 year  ago
Posts: 9
October 19, 2018 7:37 am  
Posted by: Rycco

I've done that before on another setup, but with reFIND instead of a USB driver. Will try it!

Great! Let me know how it goes :o) 

//R

Akitio Node with MSI GTX 1080 inside.


ReplyQuote