late-2016 15'' Macbook Pro RP450 + [email protected] (Mantiz Venus) + macOS10.12&Win10 [ronchigram]^  

  RSS

ronchigram
(@ronchigram)
New Member
Joined: 1 year ago
Posts: 4
July 13, 2017 10:19 pm  

Hi guys, I managed to get my setup working, basically plug & pray.

So, a bit of background:
I received my Venus a couple of days ago and my EVGA 1080 SC yesterday. For the venus I paid 104 euro of custom duties here in Belgium, for a total of approximately 500 euro. Akitio node costs 390 from Germany, but I think the Venus is worth the extra cash, considering the docking capabilities.

Anyways, I have to say that I did some reading on the forum before buying the Venus, but at some point I got bored and orderd Venus and 1080 thinking I figured it all out... yes I am an idiot. the main reason to buy the gpu was to game in bootcamp, especially PUBG. Imagine my face yesterday while I was reading the guide from nice guy  rushvora realizing how dumb I am. I freaked out a bit, since it seemed I wouldn't have been able to do the setup...

In the end, I spent yesterday and today browsing the forum and reading all possible guides, in preparation of the weekend, for which I was planning extensive testing in order to try to make the eGPU work on my macbook pro 15 late 2016 rp450.

But here comes the plot twist... yesterday after installing the gpu in the Venus I hooked it up and launched macOs, run the automate-egpu.sh script and got it working. In details, I first installed rEFInd, installed the Nvidia drivers (useless) and then run the script, which found the gpu and reinstalled the drivers. After that the gpu was running and I got a uniengine heaven benchmark of approx 1500 at extreme settings on an external monitor 1680*1050 (old 22'' samsung that i have). I suppose the low benchmark is due to the crappy buggy drivers...

Today, after work, I went on with windows, I started windows from rEFInd (for some reason I have two windows options... I choose the EFI one) with the eGPU connected. After booting, windows recognized the gpu and installed the drivers, but the gpu wasn't working, giving error (Code 43). I tried some random s*it like hotplugging during boot, disabling the radeon etc. resulting only in windows freezing... so i just booted normally in windows and installed the latest NVidia drivers from the website and rebooted.

After reboot, to my disbelief, the external monitor, connected to the 1080, came to life and everything is working. So basically I didn't have to do anything of the crazy stuff in the guides.

I don't know, maybe this is normal, but i wasn't expecting it. I tried one game in PUBG with everything Ultra and it's working nicely.

Tomorrow or saturday I will be able to run some benchmarks like Heaven, to see how it's working, and if someone is interested I can send screenshots and more details, just ask, I would be happy to help.

Other details:

Venus is connected to front left tb port, for the moment no usb or disk is connected to it. mouse and keyboard are attached with a hub to the front right tb port. I will connect a sata hd during the weekend and try the full docking setup, maybe with some benchmark for comparison.

Another thing, which maybe is not related is that just before installing the nvidia drivers windows did an update...

I am using the free windows version I downloaded from microsoft website back in june.

Last thing, thanks to everyone here partecipating to the discussion and sharing information, egpu.io is a great community.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


nando4 liked
ReplyQuote
ronchigram
(@ronchigram)
New Member
Joined: 1 year ago
Posts: 4
July 13, 2017 10:27 pm  

Well, I rebooted and now it gives again code 43 with the external monitor not working...

I tried to reinstall the drivers but it doesn't work anymore... what a joke.

Any ideas? how is it possible that it was working and it doesn't anymore after a reboot? -_-

--------------

Now it works again.

I rebooted in macOs and now again in Windows but I waited 10 secs while on the rEFInd screen and now it works again. I don't know if it is random or I just need to wait, I will update the post after some testing...

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 2 years ago
Posts: 277
July 14, 2017 12:58 am  

On my first eGPU setup I had to boot into MacOS, shut down and boot into windows to work. Then I discovered the hotpluging (boot pressing option, select windows and one second after the logo appears plug the eGPU thunderbolt cable) and now I have 100% success rate.

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote