2015 13" MacBook Pro [5th,2C,U] + RX 590 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS...
 
Notifications
Clear all

2015 13" MacBook Pro [5th,2C,U] + RX 590 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.5  

  RSS

Arturo Romboli
(@arturo_romboli)
Active Member
Joined: 2 weeks ago
 

System specs

Macbook Pro (Retina, 13-inch, Mid 2015)

MacOS Catalina V. 10.15.5.

Memory 8 GB 1867 MHz DDR3.

 

eGPU hardware

Razer Core X enclosure

(Apple) Thunderbolt 3 to Thunderbolt 2 Adapter

(Apple) Thunderbolt 2 Cable (2 meters)

SAPPHIRE NITRO+ Radeon RX 590 8GB GDDR5

 

Installation steps

I used Purge Wrangler to be able to install the eGPU using the Razer Core X. The patch installation went very well and the system identified the card right away, and it seems to somehow operate ok while it is not under heavy load. If I run Heaven benchmark (ultra) for example, or use Twinmotion (3D architecture platform / ultra settings) the system will freeze or restart after 10 o 15 seconds. The laptop will also crash if I want to restart it with the eGPU plugged in. I often gets the black screen w/ "Your computer restarted because of a problem. Press a key or wait a few seconds to continue in a few seconds" message.

I have researched a lot online and was not able to find a solution. I did come across a post in an Apple forum where the conclusion was that the Macbook Pro early 2015 is simply not compatible with the Rx 590 when using the Thunderbolt 3 to Thunderbolt 2 adapter. I am not 100% sure this is the case, 

I would very much welcome any guidance or help to be able make it work. If indeed the card is not compatible then I will try to get a new one, such as the rx 580 or Vega 56

Macbook Pro (Retina, 13-inch, Mid 2015) running MacOS Catalina V. 10.15.5. Memory 8 GB 1867 MHz DDR3. Razer Core X enclosure. (Apple) Thunderbolt 3 to Thunderbolt 2 Adapter, (Apple) Thunderbolt 2 Cable (2 meters). SAPPHIRE NITRO+ Radeon RX 590 8GB GDDR5. iGPU: Intel Iris Graphics 6100 1536 MB.

 
2015 13" MacBook Pro [5th,2C,U] + RX 590 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.5 [build link]  


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

The RX 590 shares drivers with RX 580 and other Polaris Ellesmere cards. I don't think drivers is the culprit. How does your MacBook Pro run these apps without the eGPU? Is there a BIOS switch on the SAPPHIRE NITRO+ Radeon RX 590?

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Arturo Romboli
(@arturo_romboli)
Active Member
Joined: 2 weeks ago
 

Hello @itsage - the Macbook runs all apps ok without the egpu, of course with a lower FPS, but overall there are no issues or crashes. Yes, the Radeon RX 590 does have a switch and I have it set to 1. I have tried it in both modes and the card has the same behaviour. 

Macbook Pro (Retina, 13-inch, Mid 2015) running MacOS Catalina V. 10.15.5. Memory 8 GB 1867 MHz DDR3. Razer Core X enclosure. (Apple) Thunderbolt 3 to Thunderbolt 2 Adapter, (Apple) Thunderbolt 2 Cable (2 meters). SAPPHIRE NITRO+ Radeon RX 590 8GB GDDR5. iGPU: Intel Iris Graphics 6100 1536 MB.

 
2015 13" MacBook Pro [5th,2C,U] + RX 590 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.5 [build link]  


ReplyQuote
Anton Puzorjov
(@anton_puzorjov)
New Member
Joined: 1 week ago
 
Posted by: @arturo_romboli

If I run Heaven benchmark (ultra) for example, or use Twinmotion (3D architecture platform / ultra settings) the system will freeze or restart after 10 o 15 seconds.

I had the same issue when i installed eGPU and run test on my MPB mid2015 + 5600 XT. After that I could not see the card at all. I had to physically take the card out from eGPU and plug it back, delete Purge Wrangler and start the process again. Now 2nd day running no issues so far! Give it a try.

2015 15" MacBook Pro (R9 M370X) [4th,4C,H] + RX 5600 XT @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.5 & Win10 [build link]  

ReplyQuote
Arturo Romboli
(@arturo_romboli)
Active Member
Joined: 2 weeks ago
 

@anton_puzorjov, thanks. I have tried that already, will do it again, but I don't seem to be able to make it work. It may be the cable, or the adapter or that the card itself is not working properly. 

 

Macbook Pro (Retina, 13-inch, Mid 2015) running MacOS Catalina V. 10.15.5. Memory 8 GB 1867 MHz DDR3. Razer Core X enclosure. (Apple) Thunderbolt 3 to Thunderbolt 2 Adapter, (Apple) Thunderbolt 2 Cable (2 meters). SAPPHIRE NITRO+ Radeon RX 590 8GB GDDR5. iGPU: Intel Iris Graphics 6100 1536 MB.

 
2015 13" MacBook Pro [5th,2C,U] + RX 590 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.5 [build link]  


ReplyQuote