2012 13" MacBook Pro [3rd,2C,M] + GTX 1080 @ 10Gbps-TB1>TB3 (AORUS Gaming Box) ...
Clear all

2012 13" MacBook Pro [3rd,2C,M] + GTX 1080 @ 10Gbps-TB1>TB3 (AORUS Gaming Box) + macOS 10.12.6 & Win10 & Linux [gt0242]  


Active Member
Joined: 3 years ago

System specs  
Macbook Pro 13, non retina mid 2012,
CPU - i5 2.5 GHz ,
iGPU - Intel HD4000, dGPU - N/A,
operating system - Mac OS 10.12.6 and Arch Linux (Archmerge Distro)

eGPU hardware 
eGPU enclosure - Aorus Gaming Box 1080,
video card - Nvidia GTX 1080 mini ITX,
others - Apple TB3-TB2 adapter, Apple TB2 0.5m cable, Headless HDMI

Hardware pictures (TODO)

Installation steps (
1 - Backed up my installation of MacOS.
2 - Started the Macbook Pro in recovery mode and switched of SIP. Switched it off.
3 - Connected all the cables and the Gaming Box to a switched off Macbook Pro.
4- Started the Macbook Pro and then ran rastafabi's utility
5 - Restarted laptop and faced a looping kernel panic!
6 - Used backup to restore my MacOS install
7 - Started the Macbook Pro and ran the automate-egpu.sh script
8 - Restarted the laptop once the script finished
9 - Checked system report and the eGpu was detected! Success !!!

1 - Created a live USB for ArchMerge, with a latest download
2 - Rebooted the laptop with eGpu connected
3 - Kept option key pressed and booted the live USB
4 - Success! The OS started with eGpu as the main graphics driver and with Nvidia drivers loaded. 
5 - The Linux kernel version was 4.15

1 - Did a UEFI Windows 10 Pro install
2 - Booted into Windows, did all system and bootcamp updates
3 - Shutdown the laptop
4 - Connected the Gaming Box and booted back into Windows
5 - Installed Nvidia Geforce drivers
4 - And done! The LEDs don't light up for some reason, but Cuda-Z reports same numbers as MacOS.

In MacOS :
Blender BMW Benchmark Time 3.07:46!  https://ibb.co/cDDwpc
Cuda-Z  https://ibb.co/cNZ5FH

16 Mar 2018 -
I had run the laptop using the live USB without the eGpu plugged in. After I ran the live USB with the eGpu connected, the system just felt a lot faster.
Reading about the issues Apple has supporting eGpu, seeing Linux run it flawlessly and straight out of the box, without any extra setup needed was shocking. Either Apple's lack of eGpu support is malicious or its engineers are messing up big time. They should maybe look at Linux' support for eGpu and duplicate it in MacOS.
I am planning to move my whole workspace into Linux and use MacOS to only backup and update songs on my iPhone and iPod.
I will update this post as I run benchmarks later. Its late here and I need to get some sleep.

17 Mar 2018 -
Fast Blender renders! I put this together for 3D rendering and GPU compute and its working awesome for that.
The Cuda-Z reported H2D (705MiB/s) and D2H(895MiB/s) is par for the course for a TB1 port. The TB firmware is reported as 25.25. I downloaded the F1.0_H2D firmware update for the Gaming Box. On windows when I ran the TB fwupd tool it threw an error - couldn't find a Thunderbolt service. Seems I need to install Intel's TB software, even if I can't run it! Then the update might happen. I am not fussed here since the speeds appear to be fine for now.

Next I am going to finish my Linux install and see what that throws up. This has been the most promising till now. On Linux the eGpu is fully plug and play. I can hot plug the Gaming Box and GPU shows up available for use. And disconnect without any kernel panics!

2012 13" MacBook Pro [3rd,2C,M] + GTX 1080 @ 10Gbps-TB1>TB3 (AORUS Gaming Box) + macOS 10.12.6 & Win10 & Linux [build link]  

lallo and nando4 liked