mid-2014 13" Macbook Pro + [email protected] (AKiTiO Node via TB3 to TB2 adaptor) + macOS10.12.2&Win10 [casual_g]^  

  RSS

casual_g
(@casual_g)
Eminent Member
Joined: 2 years ago
Posts: 20
March 29, 2017 11:29 pm  

Despite now in 2017 the presence of several enclosure options for eGPUs, a working configuration still depends on the specific combination of computer, enclosure, and graphics card. If you read these forums closely, it's not the case that all configurations are operable at the moment, so it's always good to see a working implementation, evidence that for a particular set of hardware, eGPU is possible. With macbooks, if you desire eGPU compatibility with both OS X and Windows, then it's a double task to configure things for both operating systems.

Fortunately, the veterans of this forum have given the resources to make things slightly less daunting, and for me, my mid 2014 13" macbook pro works well with the AKiTiO Node enclosure. I am able to use the RX480 in both MacOS and Windows 10; I don't have to time plugging in of the thunderbolt cable with system boot; and no DSDT override was necessary.

 

Configuration details

I figure it important to list every little detail that could be relevant in getting a working setup

  • OS X Sierra 10.12.2 and Windows 10 boot camp
  • External monitor with displayport connection from RX 480
  • Powercolor RX 480 4GB
  • Apple TB3-to-TB2 adaptor and Apple Thunderbolt cable (2 m)
  • Trackpad is disabled in Windows via Device Manager (idk if relevant)
  • I use Apple Thunderbolt gigabit ethernet for internet access

 

MacOS setup

This was relatively easy. After installing the RX480 into the enclosure and hooking up the connections, I followed the instructions here:  https://egpu.io/forums/mac-setup/automate-egpu-sh-is-reborn-with-amd-polaris-fiji-support-for-macos/. automate-eGPU.sh was invoked without any options.

After the two reboots, things were underway.

Computer sleep with the eGPU works fine.

 

Win10 setup

Getting things going on Windows 10 seemed to be trickier. Initially, booting with eGPU plugged in caused the windows logo to appear briefly on the laptop display before the display went blank. The computer was in an operable, display-less state, evidenced by my ability to press enter, type my password, press enter, and then shutdown the computer from Win+R. If I booted the computer without the eGPU and then attempted to plug in the thunderbolt cable, no response would come from the computer.

The solution:

  1. Follow  https://egpu.io/forums/mac-setup/how-to-keep-mbps-irisiris-pro-activated-when-booting-into-windows-boot-camp/ to create a bootable flash drive that keeps the iGPU active during windows boot
  2. Have Node power switch on and all cables connected
  3. Boot system from flash drive.
  4. Magic will happen, as Windows automatically installs AMD drivers.
  5. After the computer appears to be idle, reboot the computer from the start menu
  6. Now the computer will take a long time to reboot, so after things are seemingly stalled, just force power off the computer and then boot from the flash drive again
  7. Windows 10 should now have a working eGPU powering the external display
  8. It's possible to install newer AMD drivers. When I did it, the process similarly involved a reboot that stalled, during which I force powered off the computer, so although a bit weird, I guess that's just the process for driver installation here.

 

Now although step 5 and 6 appear dubious, I did end up with a working eGPU setup. AMD drivers report the external display powered by XConnect, and of course, 3D performance is much enhanced.

The only issues I've encountered in Windows is that if I let the computer sleep, the eGPU will not reconnect after resuming, although the computer will still be usable off the iGPU. I boot off the flash drive usually: without the flash drive, the iGPU is not active and the internal display remains off. I previously wrote that performance is degraded without the iGPU active, but I have since found that I can just use the dGPU only.

Note, I am able to clamshell mode the computer and use the external monitor only.

 

Performance notes

I'm pretty happy with the GPU performance of the RX480. I wanted to see how far overclocking would go. I am seemingly stable at 1266->1355 MHz core and 1700->2095 MHz memory overclock at stock voltage. my particular card limits the power increase in AMD wattman to 5%, but I don't feel limited by that, given the overclock.

Best Firestrike score I obtained was 7750 ( http://imgur.com/a/wPx6t -- CPU id is wrong). Graphical score was 10k+, so the CPU is limiting the score as well. I'd say, given TB bandwidth and CPU limitations, going with a stronger GPU with my computer would be money-inefficient.

Regarding the Node enclosure. Everyone says it's large, and I strongly agree.

After powering off my computer, the PSU fan of the Node remains on, and so I have to manually flip the power switch to shut down the fan. After a while, capacitors in the Node will discharge, so when I turn the Node on the morning, the fans don't automatically come on until I boot my computer (this is just to say that I can't flip the power switch from off back to on immediately if I want to turn off the power supply fans in the Node).

Although I might hope for a firmware updates that enables sleep in Windows and better power control of the fans, I might not even be able to install such a firmware update from my TB2 laptop computer.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


Zetthard, thor203 and ikir liked
ReplyQuote