2014 15" MacBook Pro (GT750M) [4th,4C,H] + GTX 1070 @ 16Gbps-TB2>TB3 (AORUS Gami...
 
Notifications
Clear all

2014 15" MacBook Pro (GT750M) [4th,4C,H] + GTX 1070 @ 16Gbps-TB2>TB3 (AORUS Gaming Box) + macOS 10.13.6 [mac_editor]  

 of  6
  RSS

mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@thomas_tows read the troubleshooting guide regarding this. It’s not an issue. 

@georgios_lachanas it should work fine even in external disk. Follow the boot procedures as described in the original post. Timing is important. You can also try hot-plugging after the system boots, and log out. This may disable the internal monitor though.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Georgios Lachanas
(@georgios_lachanas)
Active Member
Joined: 3 years ago
 

@mac_editor
Good to know.
I believe I tried all possible timings (plugged egpu when Apple logo shows,when loading bar appears,middle half the loading bar,after complete boot and logout and login) but I'll keep trying now that I know that external disk isn't the problem.

So is it normal that node pro is shown in system report but 1070ti isn't ?

MBP 15" with Nvidia 750m (mid2014) + Razer Core X +Apple TB3 adapter+Apple TB2 cable+Nvidia 1070Ti 8gb+LG Ultrawide Monitor via HDMI ,MACOS 10.13.6 (17G4015),Web drivers 387.10.10.10.40.113, Cuda version 410.130


ReplyQuote
Georgios Lachanas
(@georgios_lachanas)
Active Member
Joined: 3 years ago
 

@mac_editor
last 2 days i'v tried every possible timing combination for plugging the egpu with no success..
also multiple install-uninstall efforts of the pure-wrangler and Nvidia web drivers and cuda...
My Mac always boot normal ,and external screen is never activated and 1070ti never shown in "about this Mac" page..
Only thing I can think is possible malfunction of the TB2 cable and Graphic cards.

I'll check graphic card in a PC and report back.

Ps Is it normal that the card powers off as soon as I unplug TB connection from my Mac?(egpu psu is still on.)

EDIT 1 : GPU tested in a pc.It’s ok.
EDIT 2 : clean install of 10.13.6 (17G65) in internal HD.Still not able to have 1070TI shown and external screen still black and not present.

MBP 15" with Nvidia 750m (mid2014) + Razer Core X +Apple TB3 adapter+Apple TB2 cable+Nvidia 1070Ti 8gb+LG Ultrawide Monitor via HDMI ,MACOS 10.13.6 (17G4015),Web drivers 387.10.10.10.40.113, Cuda version 410.130


ReplyQuote
Georgios Lachanas
(@georgios_lachanas)
Active Member
Joined: 3 years ago
 

@mac editor 
any other recommendations ?

MBP 15" with Nvidia 750m (mid2014) + Razer Core X +Apple TB3 adapter+Apple TB2 cable+Nvidia 1070Ti 8gb+LG Ultrawide Monitor via HDMI ,MACOS 10.13.6 (17G4015),Web drivers 387.10.10.10.40.113, Cuda version 410.130


ReplyQuote
Georgios Lachanas
(@georgios_lachanas)
Active Member
Joined: 3 years ago
 

bought another new apple TB2 cable...unfortunately no success ..also tried with and 7770gpu...same results...I never manage to have egpu recognised....
probably it's Akitio node pro problem.....
Bad thing is that I thought I made a very thorough reading before I bought the parts...
probably all are going for sale

MBP 15" with Nvidia 750m (mid2014) + Razer Core X +Apple TB3 adapter+Apple TB2 cable+Nvidia 1070Ti 8gb+LG Ultrawide Monitor via HDMI ,MACOS 10.13.6 (17G4015),Web drivers 387.10.10.10.40.113, Cuda version 410.130


ReplyQuote
Glement
(@glement)
Active Member
Joined: 2 years ago
 

Any success on windows part with this setup?

MBP 2013 15 inch gt750m 4850hq 16 ddr3


ReplyQuote
Khalid Halba
(@khalid_halba)
Active Member
Joined: 3 years ago
 

i m impressed by the results of the Unigine Valley Results, they are not different than the results in this build which uses a TB3 2017 model with the 1080 GPU

https://egpu.io/forums/builds/2017-13-touchbar-macbook-pro-gtx-108032gbps-tb3-aorus-gaming-box-macos-10-13-3-itsage/

this basically means the TB2 in the 2012-2015 retina models is not a bottleneck. 

thank you.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@glement Unfortunately not, plus I do not own this Mac anymore. You would have success with a TB2 enclosure. 

@khalid_halba True, but be wary of a single benchmark result that does not really maximize bandwidth need/use. The differences may arise due to the 4-core vs 2-core config as well. I would have expected the 1080 to far outperform the 1070.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Khalid Halba
(@khalid_halba)
Active Member
Joined: 3 years ago
 

Yeah you are right.
I m waiting for my2015 mbp 15" i7 2.8ghz 16gb memory  and the 1080 gaming box to arrive by the end of this month. I will try to post my results. I want to use the eGPU mainly with windows 10 to play games. i hope the setup won't be a disappointment. 

This post was modified 2 years ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago

ReplyQuote
 of  6