Mid 2014 & Mid 2012...
 
Share:

Mid 2014 & Mid 2012 15inch MacBook Pro Retina + AMD RX580 8GB (Sonnet eGFX 350) + macos 10.13.5 & win10  

  RSS

(@matthew_watson)
New Member
Joined: 9 months ago
Posts: 3
July 25, 2018 6:11 am  

System specs (model inc screen size, CPU, iGPU, dGPU, operating system)
2 Macs:
Mid 2012 MBP Retina with GT650M and intel iGPU
Mid 2014 MBP Retina with GT750M and intel iGPU

 

eGPU hardware (eGPU enclosure, video card, any third-party TB3 cable, any custom mods)

Bought Sonnet eGFX 350 bundled with AMD RX580 8GB
Apple MMEL2AM/A, Thunderbolt 3 (Usb-C) To 2 Adapter
Apple Thunderbolt Cable 2.0 m, Black (MF639ZM/A)

 

Hardware pictures (note: require 5+ posts for "attach files" button to appear. Or can link from say  http://imgur.com  )

 

 

Installation steps (what did you do to get it all going?)

Installed purge-wrangler ( https://egpu.io/forums/mac-setup/script-enable-egpu-on-tb1-2-macs-on-macos-10-13-4/) and purge-nvda ( https://egpu.io/forums/mac-setup/nvidia-workaround-for-high-sierra-egpu-acceleration/)

These make the external enclosure fire up and the HDMI monitor I have attached to the eGPU start working. I can set it as the default display (by moving the menu bar is display prefs) and using set-eGPU.sh ( https://egpu.io/forums/mac-setup/potentially-accelerate-all-applications-on-egpu-macos-10-13-4/) to force some apps (Elite) onto the eGPU display.

So far results don't look great speed-wise, but this is not my main use case (windows gaming)

On Windows 10 I have varied success:

  • On the 2014 I just downloaded the AMD drivers ( https://support.amd.com/en-us/download) and they autodetected the eGPU and it started working. Running Elite Dangerous Horizons and GTA V I'm able to run them at max settings with no noticeable slow down on the external 1080P monitor. To get it to work I have to boot into windows with the eGPU plugged in.
  • On the 2012 MBP (my sons) The drivers do not detect the eGPU and don't install. IF I boot into windows with the eGPU plugged in, both screens go black and I have to force reboot. 🙁

 

Benchmarks (Include a CUDA-Z or AIDA64 bandwidth pic. Optional: Valley, 3dmark, noting if it's on internal/external LCD )

NA

 

 

Comments (eg: how has the eGPU improved your workflow or gaming)

Given  gaming on windows is my main goal (getting GTA V with family friendly mod going for my son!) I really want to get the 2012 MBP to work in windows - do I need the  https://egpu.io/egpu-setup-13x/ to solve this problem?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


Quote
(@matthew_watson)
New Member
Joined: 9 months ago
Posts: 3
July 25, 2018 11:45 am  

Or maybe I need to follow this guide for the 2012 MBP:  https://egpu.io/forums/builds/mid-2012-15-macbook-pro-non-retina-rx58010gbps-tb1-gigabyte-gaming-box-via-tb3-to-tb1-adapter-macos10-13-4-win10-clarketus/

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@matthew_watson)
New Member
Joined: 9 months ago
Posts: 3
August 6, 2018 1:50 pm  

My 2012 Retina MBP needed GPT fdisk ( https://sourceforge.net/projects/gptfdisk/) to create a partition and set it to EFI, then I could install windows under EFI as per link in previous post, but for some reason this fails with a USB and goes into a reboot/error loop - I bought a $20 USB DVD burner and made a win10 boot disk and used that to do the EFI install and it worked.
I had some problems with windows continuing to reinstall the Intel graphics drivers, eventually I got gpedit.msc installed under win10 home edition using this:  https://www.itechtics.com/easily-enable-group-policy-editor-gpedit-msc-in-windows-10-home-edition/
Uninstalled the drivers for the Intel and checked the box saying remove them from system. Seems to be OK so far, now to try plugging in the GPU and getting the sound to work...

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@andy_hoebeke)
New Member
Joined: 5 months ago
Posts: 2
February 21, 2019 9:53 am  

I've got a "Macbook11,3" = Macbook Pro 2014 Retina 15".
I tried various things, to get it to work.
Uninstalling the dGPU GT750M with DDU tool seemed to help, after also via the DDU tool disabling windows auto online driver search.
I tried installing various bootcamp version-drivers for AMD, for my RX VEGA 56 but the only driver that worked was to get the latest from the AMD site. 

However, now I'm stuck... My RX Vega is recognized, my internal monitor doesn't turn on but the external monitor works.
However... "recognized" means the Device Manager shows its name, with a yellow exclamation: Error code 10, invalid parameter passed to service or function.

Impossible to figure out what causes it!!! Error 12 is well documented but error 10 not really.....
Any idea? 🙁  
Does your internal monitor work, in windows, when using EGPU? How did you get that to work?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote