Setup & Software Discussions
2017 15" MacBook Pro (RP560) [7th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node Lit...
 

2017 15" MacBook Pro (RP560) [7th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node Lite) + Win10 [Mike Damiano]  

  RSS

Mike Damiano
(@mike_damiano)
Active Member
Joined: 2 years ago
 

Hi all again,

In my last post, I showed off my GTX 1060 SC setup. Since then I got the itch and ended up getting a GTX1080 Founder's Edition. At first I was hesitant to mod the Akitio Node Lite in order to get the GPU in there because of the cost of the enclosure, but after seeing the difference in quality between the 1060 and the 1080 I decided to go for it.

For all interested, the deconstruction of the enclosure was pretty simple. I had seen another post with someone taking apart the Akitio Thunder2, and it involved a jewelers screw driver and a lot of hammer-tapping to undo the tack welding holding the enclosure together. With the Node Lite, there are only 2 small points so it was quick. After that I just bent the fan part out so it was as straight as could be, then popped it in.

Once everything was settled, I took the front and back of the enclosure and was actually able to just put them on. The front part took a little Mcguyvering. As you can see in the photos, the top part of it screwed to the original mount point, however the bottom part needed to be anchored to the enclosure with the help of some wire hanger.

Here's some photos:

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


nando4 liked
ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 3 years ago
 

Mike,  am loving the open-top look of your GTX1080-FE. Thank you for submitting your modified AKITiO Node Lite eGPU implementation.

Did you want to add successful High Sierra driver support to your implementation?

https://egpu.io/forums/mac-setup/wip-nvidia-egpu-support-for-high-sierra/paged/1/

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + GTX 1080 Ti @ 32Gbps-M2 (ADT-Link R43SG) + Win10


ikir liked
ReplyQuote
esatamacmodular
(@esatamacmodular)
Estimable Member
Joined: 3 years ago
 

So does this work in 10.12 or only 10.13? It is unclear if this is only performing in windows 10? Love the implementation but anxious to know more details!

iMac 2013 10.14.1, Macbook Air 2013 10.11, MBP 2016 13" 10.13.6 , HP 4530s 10.11, node lite, DA-2 PSU w/mod, PE4L 2.1b expresscard34, GTX460,1050Ti,1060,1070/Ti RX470,560,580


ReplyQuote
Mike Damiano
(@mike_damiano)
Active Member
Joined: 2 years ago
 

Im trying to reply to you but this forum never seems to let me do so.

I've only tried this in High Sierra and Windows 10. Can't speak to its compatibility with Sierra.

I'm getting a Razer Core tomorrow that's hopefully as plug and play as this was.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote