Setup & Software Discussions
2015 13" MacBook Air [5th,2C,U] + RX 460 @ 16Gbps-TB2 (Highpoint Rocketstor 636...
 

2015 13" MacBook Air [5th,2C,U] + RX 460 @ 16Gbps-TB2 (Highpoint Rocketstor 6361A) + Win10 [ViralTypo]  

  RSS

ViralTypo
(@viraltypo)
Active Member
Joined: 2 years ago
 

IMG 0022

 

My Setup:

 

  • 2015 MacBook Air 13
  • Rocketstor RS6361A TB2 enclosure
  • XFX RX 460 4GB Single Slot Graphics Card
  • UpBright 12v 10a Power Adapter
  • Windows 10 Anniversary - Latest Updates (6/8/2017)
  • AMD Crimson ReLive 17.1.1

Windows was installed via Bootcamp. AMD Driver 17.1.1 was auto-installed by Windows Update. eGPU was detected by Windows but I was receiving the infamous Error 12.

 

What I did to overcome Error 12:

  • Open Device Manager
  • Click View up top and select Devices by Connection

Setup1

  • Disable PCI Express Root Port #1 and #2 (Under Pci Bus)

Setup2

  • Click View again and go back to Devices by Type
  • Disable and Re-Enable eGPU under Display Adapters
  • Restart MacBook, Done

After restart, I instantly got this notification.

AMD1

Switchable Graphics settings available?

Setup4

Everything appears to be working fine and is 100% operational. PCI Express Root Port #1 has a function of zero and #2 is the FaceTime Camera. I tried just disabling one or the other but apparently both need to be disabled. I'm assuming this frees up enough lanes for the eGPU. Re-Enabling either of them brings error 12 right back.

I have not attempted to get it running in MacOS. I honestly don't really plan to being I will only be gaming in Windows.

 

 

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Such a cool little set up! I may be wrong but even without High Sierra the 460 should be a pretty easy set up in macOS. 

 

Any more pics of your set up?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Can’t help but think I was a pcie port away from getting my 580 working. You’ve made me want to try again, I’ve got W10 working with my 1070 on an external which I could experiment with without risking my solid boot camp set up. 

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
(@raj_uri)
New Member
Joined: 8 months ago
 

Hey @eightarmedpet, were you ever able to get your 580 working with this method? I was recently gifted that same card and I want to try it on my 2015 Macbook.

This post was modified 8 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

@raj_uri I have a Vega 56 working with my MacBook - see my signature. Quite a bits changed since this post was originally made.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote