2018 AMD X399 Threadripper 1950X [R1K,16C,X] + RTX 2080 @ 32Gbps-TB3 (Razer Core...
 
Notifications
Clear all

2018 AMD X399 Threadripper 1950X [R1K,16C,X] + RTX 2080 @ 32Gbps-TB3 (Razer Core X) + Win10 [itsage]  

 of  11
  RSS

itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@brabb, That's good to hear. Enjoy your setup with Thunderbolt 3!

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 Gigabyte Z490 Vision D [10th,8C,K] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


Brabb liked
ReplyQuote
AeneasWalk
(@aeneaswalk)
New Member
Joined: 5 months ago
 

First of all, thank you to @itsage and @MINDTHREAT. I'm just learning to video edit for a passion project. I'm actually using Titan-Ridge to read my thunderbolt flash drives. I'm running:

  • Gigabyte Designare x399
  • FW23
  • Driver 1.41.648.5
  • Application version 1.0.30.0
egpio
tcc

My flash drive is lit when I plug it in but I see nothing when I open Thunderbolt Control Center. I also boot up my PC with the flash drive (Samsung T5) attached - is this what is meant by warm bootup?

Thanks in advance for any help. Please let me know if you need any additional information.

 P.S. I've noticed the Thunderbolt Control Center does not appear in my system tray. When I open the application through the start menu it still does not reveal any attached devices.

 

This post was modified 5 months ago

Threadripper x2950
EVGA RTX 3080 FTW3 (internal)
Gigabyte x399 Designare EX


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@aeneaswalk, Samsung T5 is a USB-C device. It not going to show up in Thunderbolt Control Center. Have you tried connecting the Samsung T5 to the USB-C port in the X399 Designare rear I/O?

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 Gigabyte Z490 Vision D [10th,8C,K] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
AeneasWalk
(@aeneaswalk)
New Member
Joined: 5 months ago
 

Doh. Yes, I have plugged it into the rear and it does work. The thunderbolt will still be useful for when I have to build a NAS drive. Thank you for illuminating me and saving me from more hours of troubleshooting.

Threadripper x2950
EVGA RTX 3080 FTW3 (internal)
Gigabyte x399 Designare EX


itsage liked
ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@aeneaswalk, The GC-TITAN-RIDGE AIC can work with Thunderbolt 3 devices based on the screen captures you provided earlier. Due to lack of officially support, it's not correctly routed for USB connectivity. It's possible to make it work but not worth the trouble imo.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 Gigabyte Z490 Vision D [10th,8C,K] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
TripleYoThreat
(@tripleyothreat)
New Member
Joined: 3 months ago
 

@mindthreat, wow this is huge!!! I have a titan ridge and a titan ridge 2.0 card in front of me, and on both I'm getting

[Please login to see this]

When i run the UpdPack.exe

Any help or ideas on that? Excited to get this working in my all white build, NZXT N7 Z490, with no THB header!

Thanks in advance!

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
bladewalker
(@bladewalker)
New Member
Joined: 1 month ago
 

@tripleyothreat, were you able to get it working? I tried running the same tool and got the same message except with an area to select the path of a file and a grayed out button that says flash. I'm using a ASRock X399 Taichi and a titan ridge 2.0 AIC. I'm new to all of this and any help is greatly appreciated, thank you.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
TripleYoThreat
(@tripleyothreat)
New Member
Joined: 3 months ago
 

@bladewalker, the drivers were screwed up, and I honestly even had trouble uninstalling them properly. I went for a brand new windows installation, was able to flash it down to v23, but it still didn't work for me. In mac or windows. Then I went and returned and I've had it all set in an asus z490 pro art creator. Windows and Mac no problem 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
bladewalker
(@bladewalker)
New Member
Joined: 1 month ago
 

@tripleyothreat, Thanks for letting me know! I'll try it with a new installation of windows and see if that works. I'll probably end up going for a motherboard with official thunderbolt support, glad to hear that the asus z490 proart creator is working.  

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  11