EGPU breaking other USB devices warning! R43SG + MSI GS60 6QE ?
 
Notifications
Clear all

EGPU breaking other USB devices warning! R43SG + MSI GS60 6QE ?  

  RSS

EvelynMason
(@evelynmason)
New Member
Joined: 2 weeks ago
 

Thought I'd write a warning to anyone considering an EGPU with either of these devices.

 

After a lot of effort, time and money setting this up it seems that it destroys other USB devices that are connected to the laptop.

I had a mouse's right click die on me so decided to order myself a nice new Razer mouse. At the same time, I had given up with my egpu. I had managed to get it all working and it showed promising benchmarks, but for the games I play, there didn't seem to be much if any difference.

 

I did decide to give my egpu another shot though and jumped into a game. Straight away I noticed my mouse button acting up again on my new mouse, and my heart sank. I've uninstalled all the drivers etc, tested the mouse on another laptop and the same issue is happening. It can't seem to hold down the right click, with it randomly clicking while held. So upsetting.

 

I believe it is something to do with the power running through the egpu and laptop destroying other connected USB devices. I am unsure if it's to do with the  R43SG  or the laptop (I am inclined to believe it's the laptop as MSI seem to be unable to make good quality laptops, many issues with them on their forums).

 

Has anyone had any similar issues with their mouse or other USB devices?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mbliss11
(@mbliss11)
Active Member
Joined: 4 years ago
 

I have the exact same laptop and ran an Akitio Node on it for years.  Never had any problem like this.  What EGPU enclosure did you use before?  Did you have those devices plugged into the enclosure?  I always used a powered hub and connected devices through that to the laptop the node doesn't have any ports. 

2020 13" Razer Blade Stealth (GTX1650Ti) [10th,4C,G] + RTX 2060 Super @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote