2019 HP 15-DA1 (8th,4C,8H) + RX 580 @32Gbps running into x2 problems ADT-Link R4...
 
Notifications
Clear all

2019 HP 15-DA1 (8th,4C,8H) + RX 580 @32Gbps running into x2 problems ADT-Link R43SG  

  RSS

lhikary
(@lhikary)
New Member
Joined: 3 months ago
 

Hey guys

Would appreciate some help here

 

My eGPU is connected to the nvme slot but on GPU-z it shows that it's running x2 instead of x4

 

I disabled my dGPU which was running at x4 but my eGPU is still not running at x4

Anyone get any suggestions?

 

Specs

i5-8265u

32gb ddr4 2666mhz

Nvidia mx 110

MSI RX 580

External 144hz 1080p monitor

This topic was modified 3 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@lhikary, Did you confirm the NVMe slot was running at x4 with a har drive prior to using the eGPU adapter? Use other software than GPU-Z to see if that's the real link speed. I'd recommend trying AIDA64 and HWiNFO64.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
lhikary
(@lhikary)
New Member
Joined: 3 months ago
 
Posted by: @itsage

@lhikary, Did you confirm the NVMe slot was running at x4 with a har drive prior to using the eGPU adapter? Use other software than GPU-Z to see if that's the real link speed. I'd recommend trying AIDA64 and HWiNFO64.

 

it says its running at Drive Controller: NVMe (PCIe 2x 8.0 GT/s)

 
NVMe Version Supported: v1.2

How bad is that?

This post was modified 3 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@lhikary, Can you take another screen cap with the Toshiba AIS, Device ID: 0113 selected? Show the information on the right column too. If possible, expand the rest of other PCI Express Root Ports.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
lhikary
(@lhikary)
New Member
Joined: 3 months ago
 
Posted by: @itsage

@lhikary, Can you take another screen cap with the Toshiba AIS, Device ID: 0113 selected? Show the information on the right column too. If possible, expand the rest of other PCI Express Root Ports.

 

Thank you for your help

this is with the GPU installed

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

@lhikary , strangely HWINFO64 is showing your BUS as x4 but your eGPU running at x2.  Suggest use isopropyl alcohol to clean your RX 580 slot pins, the ADT-Link R43SG slot and the M.2 eGPU adapter edge connector and the slot pins. Allow to dry and retry to see if the card now runs at x4.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


itsage liked
ReplyQuote
lhikary
(@lhikary)
New Member
Joined: 3 months ago
 

@nando4, i changed the gpu entirely and it's still at x2

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

Looks like the M.2 port is configured as x4 but is only wired for x2. You can confirm by benchmarking a superfast SSD like a Samsung 970 EVO  and seeing large block transfers being limited to x2 3.0 transfer rate (16Gbps).

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote