Notifications
Clear all

Acer v3 571G egpu gdc disconnecting  

  RSS

aeonia
(@aeonia)
Active Member
Joined: 3 years ago
 

Hi all,  so i have the Acer v3 571G with dGPU nvidia 630m and an Nvidia 970+gdc exp 8.4d+evga 450BT psu.

After much struggling, I finally got the eGPU to be detected by first booting into windows then switching on the eGPU psu at which point the nvidia 970 shows up on my device manager with correct clocks on gpu-z and everything else. This only happens if i have the unlocked bios 2.21 and have enabled the wlan card pci-e port enabled and dGPU is switched off in bios.

Problem is my eGPU disconnects after a while (4-6 minutes) regardless of whether i am using it or not. I have tried downgrading speed to Gen1 from Gen2 and Auto but it still disconnects. After it disconnects in device manager, the only way to have it back is reboot laptop and switch on eGPU again after reboot. Kindly assist. Problem also persists in the setup 1.3x

I am using the nvidia drivers 368.** and don't have an external monitor so I'm using the internal lcd only.

The nvidia 970 works perfectly on a friend's desktop and the psu is brand new from Evga.

Kindly assist.

Thanks in advance

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

I provide troubleshooting support for Setup 1.3x via email. Pls establish contact that way:
https://egpu.io/egpu-setup-13x/

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
Full Bring
(@full_bring)
New Member
Joined: 2 years ago
 

I wonder if he did get it to work. Because I have the same laptop and a have that bios installed turn off the 630m makes no sense to be on, but thinking if I should invest in Beast GDC not sure if it will work on my laptop.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
aeonia
(@aeonia)
Active Member
Joined: 3 years ago
 

I did get it to work ok..My main issue was that I was using the GDC beast without an external screen. So i just bought a 1080p monitor and hooked the gpu to it then it started working. Nando4's software was of little to no help.

Even so, I still experienced a ton of disconnects then blue screens. Couldn't do a 2-3 hour gaming session without at least one disconnect and they only increased over time. In the end, my laptop started showing it's age, my GDC cable broke and I just couldn't bring myself to get another..so i built myself a gaming PC.

I would suggest you get a gdc if you have a decent gpu and a monitor readily available. The i5 3210m is a serious bottleneck nowadays so you might want to save yourself the time and just build a PC.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
jhonathanldp
(@jhonathanldp)
Active Member
Joined: 2 years ago
 
Posted by: Full Bring

I wonder if he did get it to work. Because I have the same laptop and a have that bios installed turn off the 630m makes no sense to be on, but thinking if I should invest in Beast GDC not sure if it will work on my laptop.

I have an acer V3-571 but only with IGPU(Intel HD 4000), and for me run's well on both internal and external display. The only problem that i've faced was error code 12. But i fixit reinstalling windows 10 and setting the BIOS to LEGACY Mode.
I can play many games that i was not able to play paying around US$ 260 in my country.

In your case, i think would be necessary to disable the dGPU(630m).
What i suggest is if you have a friend with a good PSU and a GPU you could borrow and them test on your system, and if runs nicely you could buy your own gear.

Ohh and if your house doesn't have a good grounding for your PSU, you should choose PE4C-PM060A 3.0 has your adapter.

Hope it Helps!

2013 Acer V3-571 + RX 470@4Gbps-mPCIe2 + EGPU GDC 8.5c + Windows 10


ReplyQuote
Random Stuff
(@random_stuff)
Active Member
Joined: 11 months ago
 

@jhonathanldp

hello sir. do you have video on installing the gpu i have the same laptop as yours. i would like to build egpu on mine please help me.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote