Asus ROG Strix GL553VD-DM666T exp gdc dock v8.5 not turning on
 
Notifications
Clear all

Asus ROG Strix GL553VD-DM666T exp gdc dock v8.5 not turning on  

  RSS

Judah van der Linde
(@judah_van_der_linde)
New Member
Joined: 1 week ago
 

Everything was working fine when I first installed my egpu (GTX 970) on an external monitor (internal wouldn't work), I was getting the expected performance with the egpu, but one day my setup fell ~1 m to the ground and the HDMI end of my m.2 cable broke, forcing me to buy a new cable because it was beyond repair. I ordered a new cable and when it arrived after ~2 weeks, I installed it, but I wasn't able to get it to work. first, my egpu was getting detected, but it had problems with error 12 and error 43. I wasn't able to fix the errors (even with error43-fixer) and I waited a couple of days until I tried agian, but this time, my egpu wasn't getting detected at all (one time it got detected as an other device). I stopped trying to get it to work for a while after that, because I was tired of all the problems it gave me. When I tried to install it agian I tried to switch the m.2 cable with the wificard and then put the system on sleepmode to swap the wificard with the m.2 in an attempt to get it to work, but this time when I turned it on agian, my powersupply (corsair VS450), exp gdc dock and egpu would work for half a second and then turn off agian. Does anyone know what I should do? Thanks in advance

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote