eGPU sometimes gets Detected, sometimes not 😕 Erazer x7841, AMD 5700XT eGPU, d...
 
Notifications
Clear all

eGPU sometimes gets Detected, sometimes not 😕 Erazer x7841, AMD 5700XT eGPU, dGPU 970M, iGPU Intel HD 530  

  RSS

Erazerx7841
(@erazerx7841)
New Member
Joined: 2 months ago
 

Hello egpu.io Community,

 

Sorry for my english, i am not a native speaker~ but i will try my best to describe the Problem i have with my Medion Erazer x7841 

iGPU: Intel HD Graphics 530

dGPU: GTX 970M Nvidia

eGPU: AMD 5700XT 

ADT-Link R43SG as the Adapter

 

i tried a lot, did multiple reinstalls of Win10 (Home and Prof.) and switched Ports, Hotswaps and whatever is possible.. even bought Nandus 1.35 eGPU prog..

 

My Problem: The eGPU (AMD 5700XT) gets detected, installed, works perfectly fine and once i Shut off the System/Laptop (restart is fine), its back to not being detected at all, again. even in the Nandus eGPU 1.35 boot its not getting detected! (in a pre-boot enviroment?!) 

now comes the big BUT and i cannot lie 😛 : after a while the system is running, shutting off the Intel HD graphics or the 970M Nvidia, restarting the system.. the eGPU (5700XT) gets detected again and works perfectly.

So its like flipping a coin for the eGPU to get detected. 

 

Things i tried to get it constantly running/ Solutions that didnt help:

- Nandus 1.35 eGPU prog. (since its not even getting detected there properly)

- reconnecting the Cables

- switched PSU

- all settings tried on the ADT-Link R43SG adapter (switches SW1,SW2,SW3..) so the eGPU is always running or not, it does not matter

- Switched UEFI to Legacy installation (it helped a little further noticeably!)

- Using conventional SSD instead of M2 SSD, so the Adapter is the only thing Plugged into the M2/NVME Ports

- Switching off the iGPU and dGPU, uninstalling them.. nothing really helped, even blocking their reinstall over Registry didnt help. 

- installation of older Drivers 

- in Device Manager, the 5700XT is still shown as a hidden Device when its not Detected (as if its not Connected to the System)

- Using an extern Monitor or the Laptop Display, doesnt matter.

 

Things I didnt tried out yet:

- Tweaking the BIOS/ Unlocking it; because i thought with the Nandus 1.35 Program i could de-whitelist the Ports. Maybe i am too stupid to understand how everything works      with it since there are no real 100% Walkthroughs with the Program. Its not really self explanatory the whole enviroment and i am still a newbie with eGPUs.

  i guess that Whitelisting is not the Problem here.

- Testing another Graphics Cards or another PCI devices on the Adapter. i just dont have them here.

- Testing the Adapter on another Laptop, but im sure it works fine.

 

My Only Solution for now: Never shut off the System once its running with the eGPU. Even Hibernation makes the eGPU shut off/not registered. But Restarts are fine once the AMD is running and recognized.

 

My only explanation is maybe a Controller Protocol not running properly from the beginning? it needs to be powered up first and then restarting the system gets the eGPU properly detected? why else is the eGPU not being detected always in the pre-boot enviroment from the Nandus 1.35 eGPU boot.. i dont even move/nudge the adapter around and still its a random detection. 

 

Got any ideas, how i can have a stable always-detected eGPU?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote