[Solved] EXP GDC Beast forces power supply to power off
 
Notifications
Clear all

[Solved] [Solved] EXP GDC Beast forces power supply to power off  

 of  3
  RSS

Ajayajayaj
(@ajayajayaj)
Estimable Member
Joined: 3 years ago
 

I am very new to this stuff, but i decided to try to do an eGPU setup. I have the EXP GDC Beast, a GTX 1050, and an EVGA 500 Watt power supply. I have the beast plugged into the power supply with the long 20 pin connector and the 4 pin connector labeled "CPU", but the beast and the PSU never turn on. There are no fans on and no lights.

I can get it to turn on for half a second, then turn off again, if I unplug everything, then plug in the HDMI(plug that connects to computer), then the power, but it seems like that will break it, and this only happens when the left switch is set to "PWR".  

I have the left switch set to "ATX", and the right set to off.    

Have any of you had this problem, I am stumped right now.  

Thanks!

2011 15" Asus U57A + GTX1050@4Gbps-mPCIe2 (EXP GDC) + Win10 (no guide)


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

Jumper the 20/24pin ATX plug's green-black wires to set it permanently on. See https://egpu.io/forums/expresscard-mpcie-m-2-adapters/mpcieecngff-m2-resolving-detection-bootup-and-stability-problems/

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
Ajayajayaj
(@ajayajayaj)
Estimable Member
Joined: 3 years ago
 
Posted by: nando4

 

Jumper the 20/24pin ATX plug's green-black wires to set it permanently on. See https://egpu.io/forums/expresscard-mpcie-m-2-adapters/mpcieecngff-m2-resolving-detection-bootup-and-stability-problems/

   

Also, to use a normal PSU, do you need the switch on ATX or PW?

Ok, now I did the paperclip test without the GDC beast plugged in, and the power supply fan turned on. Is there a thing to fix that?

Is the attached image what it is supposed to be? Or is the motherboard plug supposed to plug into something?

14868673268011944127610

2011 15" Asus U57A + GTX1050@4Gbps-mPCIe2 (EXP GDC) + Win10 (no guide)


ReplyQuote
Ajayajayaj
(@ajayajayaj)
Estimable Member
Joined: 3 years ago
 

Anyone have a clue what's up?

2011 15" Asus U57A + GTX1050@4Gbps-mPCIe2 (EXP GDC) + Win10 (no guide)


ReplyQuote
tolyaba1
(@tolyaba1)
Active Member
Joined: 3 years ago
 

Hi

If atx switch is on the left then it should power your GPU without signal from your laptop. If its right then it will turn on after you power up your laptop.

I think it doesn't really matter which option you run but I prefer right stance, so my egpu turns on together with the laptop.

just plug in the motherboard connector....

So you saying that if you power up your laptop your egpu doesn't work ?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Ajayajayaj
(@ajayajayaj)
Estimable Member
Joined: 3 years ago
 

Ya, the GDC beast doesn't even light up. But I think it might be defective and am getting a replacement now. I hope this one will work.

2011 15" Asus U57A + GTX1050@4Gbps-mPCIe2 (EXP GDC) + Win10 (no guide)


ReplyQuote
Ajayajayaj
(@ajayajayaj)
Estimable Member
Joined: 3 years ago
 

I got a new one and it started working. Make sure if you are using an ATX power supply, that you have the power in the right orientation. I found out that there are 3 ways that fit, so make sure to try them all.

Thanks for all of your help!

2011 15" Asus U57A + GTX1050@4Gbps-mPCIe2 (EXP GDC) + Win10 (no guide)


ReplyQuote
SolracOreca
(@solracoreca)
New Member
Joined: 2 years ago
 

Off topic here, does anyone know how to extend the adapter so I don't have to see it on the desk?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Vinit99
(@vinit99)
New Member
Joined: 2 years ago
 
Posted by: Ajayajayaj

I got a new one and it started working. Make sure if you are using an ATX power supply, that you have the power in the right orientation. I found out that there are 3 ways that fit, so make sure to try them all.

Thanks for all of your help!

I have a problem my egpu+psu is always on when my laptop is off. But when i turn on my laptop psu+egpu turns off.A day before it was working fine.
Samsung Rv409
1050ti 4gb + antec 450 atx psu.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
midhunj97
(@midhunj97)
New Member
Joined: 2 years ago
 

how did u solve the issue man?
I have a gtx 650ti.
without the gpu plugged to exp gdc dock it works and green light is on. But when I plug the gpu to dock it shuts down along with the psu? pls help.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  3