[Help] Switching on room light freezes my laptop
 
Notifications
Clear all

[Help] Switching on room light freezes my laptop  

 of  4
  RSS

favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 

Components :

  • Check my signature.

 

Things i have done :

  • Wrapped the cable with aluminium foil.
  • Bought APC 700VA UPS to get rid off Electrical Interference 

 

 I have traced why my laptop hangs ... its because of the room light. When i switch it off/on the laptop hangs and i have to use power button long press to kill it. There is no other socket which is isolated from these tube lights. So i tried buying a UPS (read a reddit topic that a user solved this very same problem with UPS)  but no it does not. I am out of ideas.   please help

Update

- Kudos to Jaswant Panchumarti for verifying that the adapter works perfectly under a sensitive fluorescent tubelight environment, details here

After changing his PSU to a corsair all is well and good . details here

 

- Kudos to dani_tx for implementing the solution to remove all ballast tubelight with  LED tubelight(with its own ballast  no ballast) to rectify the problem, details here

- However i am waiting for the adapter to arrive to see if this works out my issue.If it doesnt i will go the tubelight route as last resort.

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


dani29m liked
ReplyQuote
Yukikaze
(@yukikaze)
Prominent Member Moderator
Joined: 4 years ago
 

Looks like an EMI problem. I fear you are somewhat out of luck if extra shielding doesn't help. Are you using the mPCIe version of the GDC Beast? If so, you can try to replace the beast with this adapter. They are very cheap and reportedly have better PCIe Gen2 performance.

Want to output [email protected] out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

 
2012 14" Lenovo Thinkpad T430s [3rd,2C,M] + RX 550 @ 10Gbps-TB1 (Atto Thunderlink) + Win10 [build link]  


ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 

Yes using a mpcie adapter 

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

Consider adding ferrite beads to filter out EMI noise:

https://egpu.io/forums/expresscard-mpcie-m-2-adapters/too-sensitive-egou-beast/#post-15691

Or as @Yukikaze points out, a $7 eGPU adapter may give you better results:

https://egpu.io/forums/expresscard-mpcie-m-2-adapters/us7-50-generic-mpcie-egpu-adapter/

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 

If it is EMI issue my UPS has sensitivity option For that saying that it can reduce Electrical Noise . Here is the pic 

UPS Sensitivity

But this doesnt solve the issue. i also have warpped the adapter x16 slot with aluminium foil ... only thing left is wrapping the 8pin power cable.... Is ferrite core  option same as Aluminium foil setup ?

Regarding EMI is it really the issue ? with This UPS and aluminuim foil wrapped around the cable ?

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 

https://egpu.io/forums/expresscard-mpcie-m-2-adapters/us7-50-generic-mpcie-egpu-adapter/

 

That is soo cheap , i dont know whether that thick usb coming from the mpcie adapter will allow me to close my laptop , thats the only thing bothering me .

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 

This is how i have set it up for now.

3754 IMG6524
IMG 6525

.

Not to mistake the black hdmi cable... its covered with aluminium foil and i duct taped it black.

And just for kicks i aluminum foiled to 8pin cable for the exp gdc 8.4d

IMG 6526

... that didnt help... guess its the new adapter then. I dont think Ferrite core beads will be much help here.

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


ReplyQuote
favas0
(@favas0)
Eminent Member
Joined: 3 years ago
 

So i ordered the 6pin adapter from that link .... now have to wait a month 🙁 .

Laptop : Lenovo z410 ( i5-4200m GT740M 12GB 1TB-SSD) running Windows 10 Pro build 14393 // Hot-Plug Enabled BIOS
eGPU : Gigabyte GTX1070@4Gbps-mPCIe2 (EXP GDC 8.4d) + SilverStone sfx-500L PSU


ReplyQuote
Yukikaze
(@yukikaze)
Prominent Member Moderator
Joined: 4 years ago
 

Well, gaming in the dark is better anyway 😛

Good luck with the new adapter!

Want to output [email protected] out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

 
2012 14" Lenovo Thinkpad T430s [3rd,2C,M] + RX 550 @ 10Gbps-TB1 (Atto Thunderlink) + Win10 [build link]  


ReplyQuote
Jaswant Panchumarti
(@plasmaguy)
Active Member
Joined: 3 years ago
 

I'm that user who reported it to work with UPS , but that was a temporary solution albeit a great UPS, cuz I don't own one. I borrowed it.

I too ordered the cheap 7$ adapter, it should arrive anytime this week, will update soon! I'm positive it would work.

2011 15" Dell XPS L502x (GT525M) [2nd,4C,Q] + GTX 1050 Ti @ 4Gbps-mPCIe2 (PCE164P-N03) + Win7 & Linux [build link]  

ReplyQuote
 of  4