Share:

Help! Hp EliteBook 8570p  

  RSS

MrD
 MrD
(@mrd)
New Member
Joined: 2 weeks ago
Posts: 3
April 13, 2019 1:29 pm  

Hi! im trying to make an eGPU work for my laptop (Hp EliteBook 8570p), im useing a Nvidia GTX 670. The notebook recognizes the eGPU perfectly, without any error. The problem is that, even if I assign the external graphics card with the nvidia control panel, it is not used and the pc keeps running the iGPU. Anyone can help me to solve the problem pls. Best regards. 

This topic was modified 2 weeks ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


Quote
herrwaldos
(@herrwaldos)
Active Member
Joined: 2 weeks ago
Posts: 11
April 14, 2019 7:25 am  

So, I assume you have connected external monitor to your eGPU - and there is nothing on it. Or you are plannig to use eGPU with internal laptop's monitor?

Was working only briefely, now solving, maybe Expresscard cable will do...
Adapter:
EXP GDC Beast v8.5c - internal Mini-PCIee cable to
'HDMI' connection

Card: GeForce
8800GTS
Laptop: Lenovo R60, 3GB RAM, 120GB
SSD
OS: Lubuntu 18.04.02
Power:
ATX PSU 400W
Game: Mount & Blade: Warband,
Steam Native Linux version


ReplyQuote
MrD
 MrD
(@mrd)
New Member
Joined: 2 weeks ago
Posts: 3
April 14, 2019 11:19 am  

Hi, thank you for your answer. I'd like to use the eGPU with the internal laptop's monitor if possibile.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
herrwaldos
(@herrwaldos)
Active Member
Joined: 2 weeks ago
Posts: 11
April 14, 2019 5:38 pm  
Posted by: MrD

Hi, thank you for your answer. I'd like to use the eGPU with the internal laptop's monitor if possibile.

Welcome. I wont be able to help with that, unfortunately. I can only guess - is somewhere in the settings of Nvidia or Display Settings or Game itself - where you speciffy primary GPU...?
Then there should be some settings where you specify Nvidia to use Laptops Screen...?

Was working only briefely, now solving, maybe Expresscard cable will do...
Adapter:
EXP GDC Beast v8.5c - internal Mini-PCIee cable to
'HDMI' connection

Card: GeForce
8800GTS
Laptop: Lenovo R60, 3GB RAM, 120GB
SSD
OS: Lubuntu 18.04.02
Power:
ATX PSU 400W
Game: Mount & Blade: Warband,
Steam Native Linux version


ReplyQuote
(@armin_b)
New Member
Joined: 3 months ago
Posts: 3
April 15, 2019 8:52 am  

Maybe try to get the screen to run on intel hd 4000 dgpu first, before connecting egpu. I would look in BIOS settings or try to disable igpu in device manager. After that try to hot plug egpu. I have hp 8570p but it only has intel hd4000 and I am running gtx 660ti egpu by hot plugging without problems on internal or external monitor. If all else fails you need to get external monitor, look thru the forum a lot of people have implemented it like that.

HP Elitebook 8570p i73630qm + 8GB RAM + Nvidia GTX 660 ti OC + 400w Be Quiet E9 PSU


ReplyQuote