Issues with egpu after last windows 10 update to 1903
 
Notifications
Clear all

[Solved] Issues with egpu after last windows 10 update to 1903  

  RSS

(@alexander_hoff)
Active Member
Joined: 2 years ago
 

hi
i got problems with my MSI GTX 970 on 8.4d. after last update from, i think, 1804 to 1903 windows 10 update my system not showing up brightness controls (laptops Fn keys not doing any trick) and even sleep mode gone from shutdown. also system runnning on my GTX 970, as i can see, but games have very slow fps rate (week before was all fine) and when i trying to get into nvidia control panel, its saying "you are not currently using a display attached to and NVIDIA GPU (i never had second one display). so i installed DDU and uninstalled all nvidia drivers (with all recommended settings). after i restarted, installed fresh nvidia drivers for gtx 970 and disabled dgpu (nvidia nvs5200m) in device manager. after next restart everything happens same - no brightness control (which restores when i launched fresh nvidia drivers installation) and control panel saying same thing. and when i switching to dgpu (which of course either nvidia) brightness controls returns. seems egpu working on some other display (which only one)? i deleted all monitors in device manager, but it not helps (even hidden one, which second, last one). any hints?

This topic was modified 12 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@alexander_hoff)
Active Member
Joined: 2 years ago
 

got some update.... nothing changed in this issue, but what is really strange can be seen on this screens.
i have only one laptop's screen. I deleted all monitors from device manager - nothing changed.

SharedScreenshot
SharedScreenshot3
SharedScreenshot2

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
The_Livy
(@the_livy)
Eminent Member
Joined: 1 year ago
 

It appears that your Intel HD 4000 is inactive or missing a driver. (Due to it being transparent in device manager and the display being connected to "Microsoft Basic Display Driver") Did you try updating the Intel driver yet? I also assume your Nvidia Optimus icon doesn't appear in the task bar?

 

Maybe try running DDU again with the eGPU disconnected and run it for both, Nvidia and Intel drivers. Also make sure to enable the setting to have Windows not look for new drivers. Make sure to use the latest Intel drivers from https://ark.intel.com for your CPU. Before reconnecting the eGPU reinstall the Intel driver (not sure how Nvidia drivers work for dGPU+eGPU setups and which version you need to pick there, but you might want to leave the dGPU driverless for now).

How to undervolt your GPU

2017 13-inch MacBook Pro TB
2019 Intel NUC10i7FNK, 16GB RAM + PM981a 1TB
Aorus Gaming Box 1070 (EVGA GTX1060 3G) - silent mod #1
Aorus Gaming Box 1080 (Gigabyte GTX1070 ITX OC) - Custom Case solution (TBD)


ReplyQuote
(@alexander_hoff)
Active Member
Joined: 2 years ago
 

i have 2 dGPU - intel4000 and nvidia nvs5200, but when optimus engaged - intel 4000 is on, otherwise if optimus off - only nvs5200 on. i disabled Xeon PCI port in device manager, so its all time off (or getting 43 error on eGPU, which either Nvidia). so now i engaged optimus and both cards - intel4000 and gtx970 is working... but i need to set on every game to on it with gtx970 via advanced video setttings (which is not comfortable or game launching with dGPU)... before gtx970 was working with other dGPU nvidia fine with no error and no advanced settings on every game was required.... bloody update done the trick.. i already reinstalled all gpu's with DDU 5 times... same result...
its still strange, but if i disable intel4000 and checking on which adapted monitor working its said Microsoft Basic Video Driver... not gtx970.... when i turn it on (intel4000) and said it working on it... guess microsoft done some changes, maybe, in update, which affects it.

UPD:
I fixed it at last. just to disable some PCI ports through device manager, then enable Optimus, disable and uninstall dGPU Nvidia and reinstall eGPU. and then last drivers. via nvidia control panel activate default adapter for 3d apps which more high powered. and it worked. thanks all! topic can be closed.

This post was modified 12 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote