Setup & Software Discussions
Laptop Not Detecting New GTX 970. Am I missing a step? Hardware setup photo insi...
 

Laptop Not Detecting New GTX 970. Am I missing a step? Hardware setup photo inside.  

  RSS

LittyLobster
(@littylobster)
New Member
Joined: 7 months ago
 

Reddit link: https://www.reddit.com/r/eGPU/comments/ax0luo/laptop_not_detecting_new_gtx_970_am_i_missing_a/

-----------------------------------------------------------

Hello all,

Photo:  https://imgur.com/a/ncoROIq

I finally hooked up my exp gdc beast up as above. I have ATX PSU 6 pin and 8 pin going to the top of the video card, 20 pin going into the adapter plus a separate 4 pin going into the adapter which is going into the exp gdc beast. I powered on the PSU and the Beast lights up and the video card fans start twitching every 5 seconds or so but do not spin fully.

After powering on my laptop, I should be seeing the video card detected by the laptop according to the youtube videos I've seen but for some reason, nothing is detected so I can't even move to the next step which is dealing with the drivers.

How do I troubleshoot?

Thank you in advance.

Details:

Asus N56JN-DS71

Windows 8.1

16 GB ram, Intel i7-4700HQ @ 2.4 GHz

Evga Geforce GTX 970

Silencer 750 EPS12V Quad Red PSU


Edit: Found a link to some previous Asus builds ( https://egpu.io/forums/builds/2012-15-6-asus-n56vm-gtx1060-6gb4gbps-mpcie2-exp-gdc-v8-3e-win7-zodiusinfuser/ ) that require the dGPU's PCI bus connection to be disabled in the device manager. According to the link below, their device manager item was named "Xeon(R) processor E3-1200 v2/3rd Gen Core processor PCI Express Root Port - 0151"

However, under my device manager i see some related items but not the exact ones. How do I know which one to disable? Screenshot below:

https://imgur.com/a/JSJqoNI


Edit 2: So I was able to get the 840m dGPU to disappear from the Device Manager by disabling the "Intel(R) Xeon(R) processor E3-1200 v3/4th Gen Core processor PCI Express x4 Controller - 0C09" but my eGPU is still undetected.......... FML

This topic was modified 7 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote