[Sticky] [GUIDE] error 12/43 & other detection, bootup and stability problems  

  RSS

nando4
Prominent MemberAdmin
Joined:6 months  ago
Posts: 824
December 23, 2016 1:59 pm  

I've had a stack of recurring offline questions from users with problems getting mPCIe, expresscard or NGFF.M2 eGPU adapter interfaces working. This includes GPU-Z not reporting no clock details, error 10/12/43 or even not being detected at all.  mPCIe and NGFF.M2 are more troublesome getting going than say expresscard or Thunderbolt.

Below are common problems and how to correct them:

 

eGPU is detected but has error 12. See these software solutions:

https://egpu.io/forums/pc-setup/fix-dsdt-override-to-correct-error-12/
https://egpu.io/egpu-setup-13x/

 

Set the PSU to be permanently on to help detection and error troubleshooting

BPlus eGPU and EXP GDC eGPU adapters by default only enable PSU power upon detecting a PCIe signal. This can cause a race condition where the eGPU isn't ready to go when the PCIe CLKRUN signal is asserted.

The fix is to jumper the PSU so it's permanently on rather than being eGPU adapter managed.

BPlus PE4C 3.0 can set a the PWR ON jumper shown with yellow arrow on the far left here to do that.
EXP GDC has a ATX PWR switch shown here to do that.

If neither of those switches is available, then manually power ON your PSU with these instructions:

ATX PSU:  http://aphnetworks.com/tutorials/psu_paperclip_trick pictured here
Dell DA-2: bridge [remote+GND] pin 5+6 with a paperclip.  (another  pic). Explained here.

Doing this will greatly assist further troubleshooting.

 

error 43: NVidia driver 372.90 or newer with GTX10xx cards on mPCIe/M2 interfaces

NVidia driver 372.90 and and newer have been found to cause an eGPU error 43 when hosted on non-hotpluggable interfaces (mPCIe, M2) using GTX10xxx cards.  For workarounds see:

https://egpu.io/forums/expresscard-mpcie-m-2-adapters/nvidia-is-killing-off-mpciengff-m2-egpus-error-43-with-372-90/

 

error 43: incorrect eGPU initialization due to PSU mistiming

Use GPU-Z software to check if your clock information is being reported correctly. If not, then your eGPU isn't initialising properly. This can happen due to incorrect clock timings. Ensure you have set your PSU to be permanently on as per previous step.

 1. Set the delays on the eGPU adapter (PTD - EXP GDC or CLKRUN/PERST# on PE4L/PE4C). Boot into Windows or Setup 1.35. Is the eGPU detected with correct clock info reported by GPU-Z?

 

error 43: running a NVidia dGPU and eGPU

If you have NVidia dGPU as well as NVidia eGPU then it's likely because of having the mobile NVidia and desktop NVidia drivers loaded simultaneously. Proceed to disable your dGPU, uninstall ALL your NVidia drivers, use "DDU" to disable automatic driver installation and clean NVidia registry entries. Then do a 'clean' install of the latest NVidia desktop driver.

 

A black bootup screen or ACPI_BIOS_ERROR windows bootup BSOD

Here the BIOS doesn't know what to do or mangles the ACPI when it sees an eGPU. The latter preventing Windows from loading successfully. So the solution is to not let the BIOS see the eGPU. Two ways of doing that:

1. Set the delays on the eGPU adapter (PTD - EXP GDC or CLKRUN/PERST# on PE4L/PE4C). Boot into Windows or Setup 1.35. Is the eGPU detected?

2. With no eGPU attached, halt Windows bootup with F12/F8 hotplug your eGPU adapter interface. Is the eGPU detected?

3. Or alternatively, with no eGPU attached,  boot into Setup 1.35 , hotplug your eGPU adapter interface, hit F5 to scan for the eGPU. Is the eGPU detected? If the eGPU isn't detected, bootup with wifi connected into Setup 1.35, hotplug your eGPU, hit F5 to scan for the eGPU.

 

mPCIe port that hosted the wifi card disappears when connecting an eGPU in it's place

Use the Setup 1.35 PCIe Ports->enable to enable the missing port.

 

mPCIe/M2: eGPU doesn't get detected

Likely due to BIOS whitelisting preventing the port from being enabled when a non vendor device is detected. Overcome by booting with the wifi card and then hotswapping in the eGPU. That way the BIOS will enable the mPCIe port to work. A few ways to do that:

1. Boot with wifi card into Windows, sleep system, swap wifi card for mPCIe eGPU adapter and ensure eGPU is powered on, resume system. Do a device manager scan in Windows. Is the eGPU detected?

2. Boot with wifi card into Setup 1.35. *carefully* hotplug the eGPU adapter in place of wifi card. Hit F5 to rescan the PCIe bus. Is the eGPU detected?

If this enables detection then avoid this tedious hotswapping by seeking a unwhitelisted modified BIOS for your system from say http://www.bios-mods.com OR test the Setup 1.35's PCI ports->undo_whitesting feature.

 

mPCIe: eGPU still not detected - a non-standard vendor port implementation?

PERST# mPCIe pin 22 may need to be isolated with a very thin piece of cellophane tape (sticky tape) due to a non-standard implementation by your notebook vendor causing CLKRUN/CLKREQ initialization mistiming. See PERST# pinout. Asus notebooks known to suffer from this issue.

If you are absolutely unable to boot and hotplug the eGPU on your T530i, try to tape (isolate) pin2 aka the 3.3v_RUN of the GDC mpci-e connector like this, it solved all my cold boot issues! SRC: wimpzilla.

 

eGPU still not detected: faulty hardware?

If you still don't get detection then test the video card and eGPU adapter in another machine to confirm neither is faulty.

 

"NVidia driver stopped responding" intermittent messages: can't run Gen2 signalling

EXP GDC, PE4H 2.4 and PE4L 1.5 all use a socketted cable and therefore have shown Gen2 signalling issues. This error indicates there was transmissions errors. If have another video card test it as subtle impedance differences between vendors can cause these errors.  Also try isolating your PSU to it's own power outlet, not using any USB devices in the eGPU adapter and even wrapping aluminium cooking over the eGPU adapter's connecting cable (between system and eGPU adapter) to isolate EMI noise

The other solution is either to get a better Gen2-compliant eGPU adapter such as PE4C V3.0 or PE4L 2.1b (both with soldered cable).

Finally, if Gen2 cannot provide a reliable link, downgrade your link from Gen2 to Gen1 using BIOS options or Setup 1.35.

 

 

Edited: 4 weeks  ago

Buyers Guide: Top 2017 eGPU Enclosures comparedDIY eGPU Setup 1.35


ReplyQuote
Shevtcha
New Member
Joined:5 months  ago
Posts: 2
January 7, 2017 12:53 pm  

I have PSU turned on (i think) ... on EXP GDC v8 adapter is switch for atx pw, which makes power supply run without laptop turned on ... and clocks still dont work.


ReplyQuote
mrdeadshoot
Active Member
Joined:2 months  ago
Posts: 7
March 31, 2017 6:24 am  

Hi Svetcha can you solve your problem with Nvidia Geforce 1050 with lenovo g780?


ReplyQuote

eGPU

27 User(s) Online Join Server
  • SC_bombsquad6
  • veriestVarlet
  • NatLuc
  • Markos
  • Dazion
  • DanKnight0
  
Working

Please Login or Register